aboutsummaryrefslogtreecommitdiff
path: root/games/xmris
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-10-31 09:12:47 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-10-31 09:12:47 +0000
commitdb93717ea56b73711097036be3c9800f2f459c55 (patch)
tree55476a1b42f5bcac37f99cd1482c75ef5f7a2315 /games/xmris
parentad2350c8fa65cac5ab375b21ae1fb030026edf86 (diff)
downloadports-db93717ea56b73711097036be3c9800f2f459c55.tar.gz
ports-db93717ea56b73711097036be3c9800f2f459c55.zip
Notes
Diffstat (limited to 'games/xmris')
-rw-r--r--games/xmris/Makefile2
-rw-r--r--games/xmris/files/patch-timer.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/xmris/Makefile b/games/xmris/Makefile
index 5bb21c6617d8..209c89e88e84 100644
--- a/games/xmris/Makefile
+++ b/games/xmris/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmris
PORTVERSION= 4.04
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= XCONTRIB/games
DISTNAME= ${PORTNAME}.${PORTVERSION}
diff --git a/games/xmris/files/patch-timer.c b/games/xmris/files/patch-timer.c
index 2bb57c41ed41..f2482ed1d734 100644
--- a/games/xmris/files/patch-timer.c
+++ b/games/xmris/files/patch-timer.c
@@ -9,3 +9,14 @@
#else
# ifdef __hpux /* hpux is a weird mixture of BSD & SYSV */
/* don't know if this is right */
+@@ -572,7 +572,10 @@ extern VOIDFUNC timer_wait FUNCARGVOID
+ else
+ {
+ while(!tickafter(now, timer.timeout))
++ {
++ usleep(tickdelta(timer.timeout, now) * TICKTIME);
+ gettick(&now);
++ }
+ timer.timeout = tickadd(timer.timeout, timer.delay);
+ point = -1;
+ }