aboutsummaryrefslogtreecommitdiff
path: root/games/xmris
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-03-08 16:05:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-03-08 16:05:54 +0000
commit5dabc7c217062e764a1e50ff0ff8948a217f3add (patch)
tree5229ca49abb85b33c8aa4e9e8cd526d1cd69a5a7 /games/xmris
parent8fa625a46b0c93b9b78df07a547751fae20abbb8 (diff)
downloadports-5dabc7c217062e764a1e50ff0ff8948a217f3add.tar.gz
ports-5dabc7c217062e764a1e50ff0ff8948a217f3add.zip
Notes
Diffstat (limited to 'games/xmris')
-rw-r--r--games/xmris/Makefile19
-rw-r--r--games/xmris/files/patch-Imakefile23
-rw-r--r--games/xmris/files/patch-Xmris-ad.src11
-rw-r--r--games/xmris/files/patch-ab19
-rw-r--r--games/xmris/files/patch-all.c (renamed from games/xmris/files/patch-aa)6
-rw-r--r--games/xmris/files/patch-draw.c20
-rw-r--r--games/xmris/files/patch-scoring.c20
-rw-r--r--games/xmris/files/patch-timer.c11
-rw-r--r--games/xmris/files/patch-xmred.man29
-rw-r--r--games/xmris/files/patch-xmris.man31
-rw-r--r--games/xmris/pkg-plist20
11 files changed, 164 insertions, 45 deletions
diff --git a/games/xmris/Makefile b/games/xmris/Makefile
index 538182de0ecf..5bb21c6617d8 100644
--- a/games/xmris/Makefile
+++ b/games/xmris/Makefile
@@ -11,35 +11,32 @@ DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Version of the Mr Do video arcade game for X11
-BROKEN= fails to run
-
USES= imake tar:tgz
USE_XORG= x11 xext xaw xmu xt sm ice
-MAKE_ARGS= XAPPLOADDIR=${PREFIX}/lib/X11/app-defaults
-ALL_TARGET= xmris xmred
+ALL_TARGET= xmris xmred Xmris.ad
DESKTOP_ENTRIES="XMRis" "" "" "${PORTNAME}" "" ""
post-build:
- @${LN} -sf Xmris-ad.src ${WRKSRC}/Xmris
+ @${LN} -sf Xmris.ad ${WRKSRC}/Xmris
do-install:
.for i in xmred xmris
(cd ${WRKSRC} && ${INSTALL_PROGRAM} ${i} \
${STAGEDIR}${PREFIX}/bin)
.endfor
- @${LN} -sf xmris ${STAGEDIR}${PREFIX}/bin/xmsit
+ ${LN} -sf xmris ${STAGEDIR}${PREFIX}/bin/xmsit
.for i in xmred xmris
(cd ${WRKSRC} && ${INSTALL_MAN} ${i}.man \
${STAGEDIR}${MANPREFIX}/man/man6/${i}.6)
.endfor
- @${LN} -sf xmris.6 ${STAGEDIR}${MANPREFIX}/man/man6/xmsit.6
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/app-defaults
+ ${LN} -sf xmris.6 ${STAGEDIR}${MANPREFIX}/man/man6/xmsit.6
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/app-defaults
(cd ${WRKSRC} && ${INSTALL_DATA} Xmris \
${STAGEDIR}${PREFIX}/lib/X11/app-defaults)
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/app-defaults/xmris
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/xmris
(cd ${WRKSRC} && ${INSTALL_DATA} *.gdn \
- ${STAGEDIR}${PREFIX}/lib/X11/app-defaults/xmris)
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/xmris
+ ${STAGEDIR}${PREFIX}/lib/X11/xmris)
+ ${MKDIR} ${STAGEDIR}/var/games/xmris
.include <bsd.port.mk>
diff --git a/games/xmris/files/patch-Imakefile b/games/xmris/files/patch-Imakefile
new file mode 100644
index 000000000000..444303f60a5f
--- /dev/null
+++ b/games/xmris/files/patch-Imakefile
@@ -0,0 +1,23 @@
+--- Imakefile.orig 1995-12-22 12:05:52 UTC
++++ Imakefile
+@@ -59,7 +59,7 @@ EXTRA_LOAD_FLAGS = -lV3
+ XCOMM system environment
+ XCOMM
+ XCOMM don't you have gettimeofday?
+-TIME =
++TIME = -DPOSIX
+ XCOMM TIME = -DUSETIME
+ XCOMM don't you have lockf or flock?
+ LOCK =
+@@ -71,9 +71,9 @@ XCOMM
+ /* #define thefont "-*-courier-*-r-*-*-18-*-*-*-m-*-*-*" */
+ XCOMM where is the high score file?
+ XCOMM SCORE = $(LOCAL)/lib/$(APP)
+-SCORE = $(LIBDIR)/$(APP)
++SCORE = /var/games/$(APP)
+ /* to install default gardens not in app_defaults/$(APP)
+-/* #define InstallDefaultGardens $(SCORE)/gardens */
++#define InstallDefaultGardens $(LIBDIR)/$(APP)
+
+ XCOMM The following defines are needed for some implementations and/or sites.
+ XCOMM It is xmkmf's job to get these right in the first place.
diff --git a/games/xmris/files/patch-Xmris-ad.src b/games/xmris/files/patch-Xmris-ad.src
new file mode 100644
index 000000000000..b9ef0c4e5c97
--- /dev/null
+++ b/games/xmris/files/patch-Xmris-ad.src
@@ -0,0 +1,11 @@
+--- Xmris-ad.src.orig 1995-12-22 12:05:55 UTC
++++ Xmris-ad.src
+@@ -18,7 +18,7 @@
+ *Monochrome: no
+ *Gender: he
+ *Random: no
+-*Busywait: no
++*Busywait: yes
+ *UserName: no
+ *Font: FONT
+ *Static: no
diff --git a/games/xmris/files/patch-ab b/games/xmris/files/patch-ab
deleted file mode 100644
index 177623f93806..000000000000
--- a/games/xmris/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
-*** Xmris-ad.src.orig Fri Dec 22 04:05:55 1995
---- Xmris-ad.src Thu Dec 5 16:18:55 1996
-***************
-*** 18,24 ****
- *Monochrome: no
- *Gender: he
- *Random: no
-! *Busywait: no
- *UserName: no
- *Font: FONT
- *Static: no
---- 18,24 ----
- *Monochrome: no
- *Gender: he
- *Random: no
-! *Busywait: yes
- *UserName: no
- *Font: FONT
- *Static: no
diff --git a/games/xmris/files/patch-aa b/games/xmris/files/patch-all.c
index da7d13e38483..9ca2971fed0f 100644
--- a/games/xmris/files/patch-aa
+++ b/games/xmris/files/patch-all.c
@@ -1,6 +1,6 @@
---- all.c.orig Fri Dec 22 13:05:56 1995
-+++ all.c Sat Oct 19 22:49:11 2002
-@@ -637,8 +637,10 @@
+--- all.c.orig 1995-12-22 12:05:56 UTC
++++ all.c
+@@ -637,8 +637,10 @@ FUNCARG((stream),
* returns the error string, or NULL
*/
{
diff --git a/games/xmris/files/patch-draw.c b/games/xmris/files/patch-draw.c
new file mode 100644
index 000000000000..131e1f89da84
--- /dev/null
+++ b/games/xmris/files/patch-draw.c
@@ -0,0 +1,20 @@
+--- draw.c.orig 1995-12-22 12:07:19 UTC
++++ draw.c
+@@ -1030,14 +1030,14 @@ ARGSEP char CONST *parent
+ stream = fopen(filename, "r");
+ }
+ if(!stream)
+- /*{{{ try in app-defaults/xmris/<file>*/
++ /*{{{ try in xmris/<file>*/
+ {
+ char CONST *lib;
+
+ lib = XtResolvePathname(display.display,
+- "app-defaults/xmris", name, NULL, NULL, NULL, 0, NULL);
++ "xmris", name, NULL, NULL, NULL, 0, NULL);
+ if(!lib)
+- lib = XtResolvePathname(display.display, "app-defaults/xmris",
++ lib = XtResolvePathname(display.display, "xmris",
+ name, FILE_SUFFIX, NULL, NULL, 0, NULL);
+ if(!lib && data.dir)
+ lib = XtResolvePathname(display.display, data.dir, name,
diff --git a/games/xmris/files/patch-scoring.c b/games/xmris/files/patch-scoring.c
new file mode 100644
index 000000000000..7ff2cc6d8ecb
--- /dev/null
+++ b/games/xmris/files/patch-scoring.c
@@ -0,0 +1,20 @@
+--- scoring.c.orig 1995-12-22 12:08:10 UTC
++++ scoring.c
+@@ -208,7 +208,7 @@ ARGSEP uid_t uid
+ {
+ if(current_uid != effective_uid)
+ set_euid((current_uid = effective_uid));
+- filed = open(locking_file, O_CREAT | O_EXCL, 0666);
++ filed = open(locking_file, O_CREAT | O_EXCL, 0660);
+ if(filed >= 0)
+ break;
+ if(errno == EINTR)
+@@ -259,7 +259,7 @@ ARGSEP uid_t uid
+ #endif /* USELOCKFILE */
+ #ifndef TRANSPUTER
+ if(stream && flag & 4 && effective_uid == real_uid)
+- chmod(name, 0666); /* not everyone has fchmod */
++ chmod(name, 0660); /* not everyone has fchmod */
+ if(current_uid != real_uid)
+ set_euid((current_uid = real_uid));
+ #endif /* TRANSPUTER */
diff --git a/games/xmris/files/patch-timer.c b/games/xmris/files/patch-timer.c
new file mode 100644
index 000000000000..2bb57c41ed41
--- /dev/null
+++ b/games/xmris/files/patch-timer.c
@@ -0,0 +1,11 @@
+--- timer.c.orig 1995-12-22 12:08:21 UTC
++++ timer.c
+@@ -85,7 +85,7 @@
+ sigprocmask(SIG_BLOCK, &temp, (maskp)); \
+ }
+ # define signal_release(maskp) sigprocmask(SIG_SETMASK, maskp, (MASK *)NULL)
+-# define signal_pause(maskp) sigpause(*(maskp))
++# define signal_pause(maskp) sigsuspend(maskp)
+ #else
+ # ifdef __hpux /* hpux is a weird mixture of BSD & SYSV */
+ /* don't know if this is right */
diff --git a/games/xmris/files/patch-xmred.man b/games/xmris/files/patch-xmred.man
new file mode 100644
index 000000000000..faf70c6bc1a8
--- /dev/null
+++ b/games/xmris/files/patch-xmred.man
@@ -0,0 +1,29 @@
+--- xmred.man.orig 1995-12-22 12:08:24 UTC
++++ xmred.man
+@@ -1,13 +1,13 @@
+-. Copyright (C) 1993 Nathan Sidwell
+-. RCS $Id: xmred.man,v 4.6 1995/12/14 13:53:27 nathan Exp $
++.\" Copyright (C) 1993 Nathan Sidwell
++.\" RCS $Id: xmred.man,v 4.6 1995/12/14 13:53:27 nathan Exp $
+ .TH XMRED 6 "20 December 1993" "X Version 11"
+-.IX xmred#(n) "" "\fLxmred\fP(n)"
++.\" .IX xmred#(n) "" "\fLxmred\fP(n)"
+ .SH NAME
+ xmred - garden editor for xmris
+ .SH SYNOPSIS
+ .B xmred
+ [-option ...] [-toolkitoption ...]
+-.IX xmred#(n) "" "\fLxmred\fP(n) \(em video game editor"
++.\" .IX xmred#(n) "" "\fLxmred\fP(n) \(em video game editor"
+ .SH DESCRIPTION
+ .PP
+ Mr Ed is a tool for creating and editing alternate gardens for Mr Is.
+@@ -70,7 +70,7 @@ This controls where the initial path is.
+ of a centre and four edges. Depending on the exact location of the pointer,
+ you will select either the centre, or an edge. Filling a path will place a
+ random apple in the filled location. The four locations immediately below the
+-'EXTRA' letters must be clear.
++\fIEXTRA\fR letters must be clear.
+ .TP
+ .B Player
+ This controls where the player starts from. There must be exactly one
diff --git a/games/xmris/files/patch-xmris.man b/games/xmris/files/patch-xmris.man
new file mode 100644
index 000000000000..89b4b38fb427
--- /dev/null
+++ b/games/xmris/files/patch-xmris.man
@@ -0,0 +1,31 @@
+--- xmris.man.orig 1995-12-22 12:08:29 UTC
++++ xmris.man
+@@ -1,7 +1,7 @@
+-. Copyright (C) 1995, 1994, 1993, 1992 Nathan Sidwell
+-. RCS $Id: xmris.man,v 4.17 1995/12/14 13:53:27 nathan Exp $
++.\" Copyright (C) 1995, 1994, 1993, 1992 Nathan Sidwell
++.\" RCS $Id: xmris.man,v 4.17 1995/12/14 13:53:27 nathan Exp $
+ .TH XMRIS 6 "12 December 1995" "X Version 11"
+-.IX xmris#(n) "" "\fLxmris\fP(n)"
++.\" .IX xmris#(n) "" "\fLxmris\fP(n)"
+ .SH NAME
+ xmris - video game for X
+ .SH SYNOPSIS
+@@ -10,7 +10,7 @@ xmris - video game for X
+ .LP
+ .B xmsit
+ [-option ...] [-toolkitoption ...]
+-.IX xmris#(n) "" "\fLxmris\fP(n) \(em video game"
++.\" .IX xmris#(n) "" "\fLxmris\fP(n) \(em video game"
+ .SH DESCRIPTION
+ .PP
+ Mr Is is a version of the Mr Do video arcade game for the X Window
+@@ -986,7 +986,7 @@ requested time. This has to be detected,
+ .PP
+ The visual class name conversion is performed by a standard toolkit
+ routine. It accepts only American spelling, the English spelling of
+-'grey' and 'colour' are not allowed.
++\fIgrey\fR and \fIcolour\fR are not allowed.
+ .SH COPYRIGHT
+ Copyright (C) 1995, 1994, 1993, 1992 Nathan Sidwell.
+ .SH AUTHOR
diff --git a/games/xmris/pkg-plist b/games/xmris/pkg-plist
index 2543a095c096..712906f523ed 100644
--- a/games/xmris/pkg-plist
+++ b/games/xmris/pkg-plist
@@ -1,16 +1,12 @@
-@group games
-@mode 2555
-bin/xmris
-bin/xmsit
-bin/xmred
-@mode
-@group
+@(,games,2555) bin/xmris
+@(,games,2555) bin/xmsit
+@(,games,2555) bin/xmred
man/man6/xmred.6.gz
man/man6/xmris.6.gz
man/man6/xmsit.6.gz
lib/X11/app-defaults/Xmris
-lib/X11/app-defaults/xmris/alphabet.gdn
-lib/X11/app-defaults/xmris/digits.gdn
-lib/X11/app-defaults/xmris/puzzle.gdn
-lib/X11/app-defaults/xmris/xmred.gdn
-@dir(,games,775) lib/X11/xmris
+lib/X11/xmris/alphabet.gdn
+lib/X11/xmris/digits.gdn
+lib/X11/xmris/puzzle.gdn
+lib/X11/xmris/xmred.gdn
+@dir(,games,755) /var/games/xmris