aboutsummaryrefslogtreecommitdiff
path: root/games/xneko
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>1995-12-22 18:10:20 +0000
committerMark Murray <markm@FreeBSD.org>1995-12-22 18:10:20 +0000
commitca4f23e91fcd6b4d0ee2cf7d1af28f3e005e8dd2 (patch)
tree1d6a6bfc7d871d9a7bdd62abf7a13ecc35014250 /games/xneko
parent2ce7f9e17e3a6ebb475c32baf8e18c5206c0be84 (diff)
downloadports-ca4f23e91fcd6b4d0ee2cf7d1af28f3e005e8dd2.tar.gz
ports-ca4f23e91fcd6b4d0ee2cf7d1af28f3e005e8dd2.zip
Notes
Diffstat (limited to 'games/xneko')
-rw-r--r--games/xneko/Makefile16
-rw-r--r--games/xneko/distinfo1
-rw-r--r--games/xneko/files/patch-aa37
-rw-r--r--games/xneko/pkg-comment1
-rw-r--r--games/xneko/pkg-descr6
-rw-r--r--games/xneko/pkg-plist2
6 files changed, 63 insertions, 0 deletions
diff --git a/games/xneko/Makefile b/games/xneko/Makefile
new file mode 100644
index 000000000000..6eb67cbad52a
--- /dev/null
+++ b/games/xneko/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: xneko
+# Version required: 4.4BSD-Lite
+# Date created: 22 December 1995
+# Whom: markm
+#
+# $Id$
+#
+
+PKGNAME= xneko-4.4BSD
+DISTNAME= xneko
+CATEGORIES+= x11 games
+MASTER_SITES= ftp://ftp.cdrom.com/pub/bsd-sources/4.4BSD-Lite/usr/src/games/
+
+MAINTAINER= markm@FreeBSD.ORG
+
+.include <bsd.port.mk>
diff --git a/games/xneko/distinfo b/games/xneko/distinfo
new file mode 100644
index 000000000000..2baa45b19c46
--- /dev/null
+++ b/games/xneko/distinfo
@@ -0,0 +1 @@
+MD5 (xneko.tar.gz) = d09fa1eeb6300fbedae689259dd261d2
diff --git a/games/xneko/files/patch-aa b/games/xneko/files/patch-aa
new file mode 100644
index 000000000000..483988a15c8c
--- /dev/null
+++ b/games/xneko/files/patch-aa
@@ -0,0 +1,37 @@
+diff -udr ../xneko.BSD/Makefile ./Makefile
+--- ../xneko.BSD/Makefile Tue Jun 1 03:46:11 1993
++++ ./Makefile Fri Dec 22 19:16:13 1995
+@@ -1,8 +1,17 @@
+ # @(#)Makefile 8.1 (Berkeley) 5/31/93
+
+ PROG= xneko
+-MAN6= xneko.0
+-DPADD= ${LIBX} ${LIBM}
+-LDADD= -lX11/X11 -lm
++MAN6= xneko.6
++
++DPADD+= ${X11BASE}/lib/libX11.a ${LIBM}
++CFLAGS+= -I${X11BASE}/include
++LDDESTDIR+= -L${X11BASE}/lib
++LDADD+= -lX11 -lm
++
++MANDIR= ${X11BASE}/man/man
++
++BINOWN= bin
++BINDIR= ${X11BASE}/bin
++BINMODE= 755
+
+ .include <bsd.prog.mk>
+diff -udr ../xneko.BSD/xneko.c ./xneko.c
+--- ../xneko.BSD/xneko.c Tue Jun 1 03:46:10 1993
++++ ./xneko.c Fri Dec 22 19:10:44 1995
+@@ -139,6 +139,9 @@
+
+ #include <stdio.h>
+
++#include <stdlib.h>
++#include <string.h>
++
+ #include <signal.h>
+ #include <math.h>
+ #include <sys/time.h>
diff --git a/games/xneko/pkg-comment b/games/xneko/pkg-comment
new file mode 100644
index 000000000000..f290bea46cda
--- /dev/null
+++ b/games/xneko/pkg-comment
@@ -0,0 +1 @@
+XNEKO - the classic BSD4.4 cat-and-mouse
diff --git a/games/xneko/pkg-descr b/games/xneko/pkg-descr
new file mode 100644
index 000000000000..4a9ba4db2b5e
--- /dev/null
+++ b/games/xneko/pkg-descr
@@ -0,0 +1,6 @@
+Xneko displays a window in which a cat chases your ``mouse''
+cursor.
+
+The word ``neko'' means ``cat'' in Japanese.
+
+Masayuki Koba, 1990
diff --git a/games/xneko/pkg-plist b/games/xneko/pkg-plist
new file mode 100644
index 000000000000..7a8fee1d9726
--- /dev/null
+++ b/games/xneko/pkg-plist
@@ -0,0 +1,2 @@
+bin/xneko
+man/man6/xneko.6.gz