aboutsummaryrefslogtreecommitdiff
path: root/games/xonotic/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-28 20:46:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-28 20:46:37 +0000
commite1b66ed5739c630c6103380b527718e9ef97ecd9 (patch)
treebb426a55baefb0a2162bcc0a8ab85e752ddcafd6 /games/xonotic/Makefile
parentffa134e44cc8b2e34b17bed3c9a3a56e9ff015ce (diff)
Notes
Diffstat (limited to 'games/xonotic/Makefile')
-rw-r--r--games/xonotic/Makefile43
1 files changed, 17 insertions, 26 deletions
diff --git a/games/xonotic/Makefile b/games/xonotic/Makefile
index 4234aa8bdc4b..5b0c22f24053 100644
--- a/games/xonotic/Makefile
+++ b/games/xonotic/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xonotic
-PORTVERSION= 0.8.1
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= games
MASTER_SITES= http://nl.dl.xonotic.org/ \
http://mirror.bitmissile.com/xonotic/releases/
@@ -12,34 +11,37 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Fast-paced, chaotic, and intense multiplayer first person shooter
LIB_DEPENDS= libcurl.so:ftp/curl \
- libpng.so:graphics/png
+ libpng.so:graphics/png \
+ libd0_blind_id.so:security/d0_blind_id \
+ libd0_rijndael.so:security/d0_blind_id \
+ libode.so:devel/ode
-USES= compiler:features jpeg shebangfix zip:infozip
+USES= compiler:features gmake jpeg localbase shebangfix zip:infozip
SHEBANG_FILES= server/rcon.pl server/rcon2irc/rcon2irc.pl
WRKSRC= ${WRKDIR}/Xonotic
BUILD_WRKSRC= ${WRKSRC}/source/darkplaces
-MAKEFILE= BSDmakefile
+MAKEFILE= makefile
MAKE_ARGS= DP_FS_BASEDIR="${DATADIR}" \
DP_PRELOAD_DEPENDENCIES=yes \
- CFLAGS_LIBJPEG="-I${LOCALBASE}/include -DLINK_TO_LIBJPEG" \
- OPTIM_RELEASE="${CFLAGS} -fno-strict-aliasing -funroll-loops" \
+ OPTIM_RELEASE="${CFLAGS}" \
STRIP="${STRIP_CMD}"
MAKE_JOBS_UNSAFE=yes
ALL_TARGET= # empty
PORTDATA= *
-OPTIONS_DEFINE= ENCRYPTION
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
OPTIONS_MULTI= COMPONENTS
OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
-OPTIONS_DEFAULT= CLIENT DEDICATED ENCRYPTION
+OPTIONS_DEFAULT= CLIENT DEDICATED
CLIENT_DESC= Build client
-CLIENT_LIB_DEPENDS= libmodplug.so:audio/libmodplug \
- libtheora.so:multimedia/libtheora \
+CLIENT_LIB_DEPENDS= libtheora.so:multimedia/libtheora \
libvorbis.so:audio/libvorbis \
+ libvorbisenc.so:audio/libvorbis \
+ libvorbisfile.so:audio/libvorbis \
libogg.so:audio/libogg
-CLIENT_USE= SDL=sdl XORG=x11
+CLIENT_USE= SDL=sdl2 XORG=x11
CLIENT_ALL_TARGET= sdl-release
CLIENT_PLIST_FILES= bin/${PORTNAME} share/pixmaps/${PORTNAME}.ico
CLIENT_DESKTOP_ENTRIES= "Xonotic" \
@@ -53,22 +55,11 @@ DEDICATED_DESC= Build dedicated server
DEDICATED_ALL_TARGET= sv-release
DEDICATED_PLIST_FILES= bin/${PORTNAME}-dedicated
-ENCRYPTION_DESC= Build encryption (required for stats submission)
-ENCRYPTION_LIB_DEPENDS= libd0_rijndael.so:security/d0_blind_id
-
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} == 42
-# internal compiler error with base gcc
-USE_GCC= yes
-.endif
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -fno-strict-aliasing -fno-math-errno -ffinite-math-only -fno-rounding-math -fno-signaling-nans -fno-trapping-math
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},' \
- ${BUILD_WRKSRC}/${MAKEFILE} ${BUILD_WRKSRC}/makefile.inc
- @${REINPLACE_CMD} -e '/LDFLAGS_BSDSV/s,$$,-L${LOCALBASE}/lib,' \
- ${BUILD_WRKSRC}/makefile.inc
- @${ECHO_CMD} >> ${BUILD_WRKSRC}/prvm_offsets.h # silence 'no newline' warnings
+ ${BUILD_WRKSRC}/makefile ${BUILD_WRKSRC}/makefile.inc
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/data
@@ -88,4 +79,4 @@ do-install-DEDICATED-on:
do-install-ENCRYPTION-on:
${INSTALL_DATA} ${WRKSRC}/key_0.d0pk ${STAGEDIR}${DATADIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>