aboutsummaryrefslogtreecommitdiff
path: root/games/xonotic/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-03-19 11:32:45 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-03-19 11:32:45 +0000
commitcf89f4a811a235b8e32ba247efde9b4adefb41c6 (patch)
treef0a1b26359666a7f1c4e9f55327b13e889efa429 /games/xonotic/Makefile
parenta76da3e1c8ee676667400ec2c1614c9da7d75fa3 (diff)
downloadports-cf89f4a811a235b8e32ba247efde9b4adefb41c6.tar.gz
ports-cf89f4a811a235b8e32ba247efde9b4adefb41c6.zip
- Do not extract things during `pre-patch' phase
- Fix `libcurl.so' support Based on PR: ports/110418 Submitted by: Dierk Sacher
Notes
Notes: svn path=/head/; revision=187713
Diffstat (limited to 'games/xonotic/Makefile')
-rw-r--r--games/xonotic/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/xonotic/Makefile b/games/xonotic/Makefile
index 00504f652d2a..c76c9fbf4a80 100644
--- a/games/xonotic/Makefile
+++ b/games/xonotic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nexuiz
PORTVERSION= 2.2.3
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -39,7 +40,8 @@ OPTIONS= CLIENT "Build GLX client" on \
# Loads libraries on run-time, thus RUN_DEPENDS
RUN_DEPENDS= ${LOCALBASE}/lib/libvorbis.so:${PORTSDIR}/audio/libvorbis \
${LOCALBASE}/lib/libjpeg.so:${PORTSDIR}/graphics/jpeg \
- ${LOCALBASE}/lib/libpng.so:${PORTSDIR}/graphics/png
+ ${LOCALBASE}/lib/libpng.so:${PORTSDIR}/graphics/png \
+ ${LOCALBASE}/lib/libcurl.so:${PORTSDIR}/ftp/curl
.endif
.if !defined(WITHOUT_CLIENT)
@@ -65,13 +67,14 @@ PLIST_SUB+= SERVER=""
PLIST_SUB+= SERVER="@comment "
.endif
-pre-patch:
+post-extract:
@${EXTRACT_CMD} ${WRKDIR}/Nexuiz/sources/enginesource20070123.zip \
-d ${WRKDIR}/Nexuiz/sources
@${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},; 88,$$d' \
${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -E 's,(fs_basedir\, )"",\1"${DATADIR}",' ${WRKSRC}/fs.c
@${REINPLACE_CMD} -e 's,RTLD_LAZY,& | RTLD_GLOBAL,' ${WRKSRC}/vid_glx.c
+ @${REINPLACE_CMD} -E 's,(libcurl\.so)\.3,\1,' ${WRKSRC}/libcurl.c
do-build:
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \