aboutsummaryrefslogtreecommitdiff
path: root/games/xosmulti
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-03-23 09:13:25 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-03-23 09:13:25 +0000
commit437372be00ae93aa3662ee32a4d2ca13dda7504c (patch)
tree9209a281ea147290e6c32ab8856fd45a712a30e2 /games/xosmulti
parent06d9cb422f611fa69188229fdce4f8bb97da8315 (diff)
downloadports-437372be00ae93aa3662ee32a4d2ca13dda7504c.tar.gz
ports-437372be00ae93aa3662ee32a4d2ca13dda7504c.zip
Fix runtime
PR: 217945 Submitted by: Masayoshi Fujimoto <m.fujimoto@yandex.ru> Reviewed by: Masayoshi Fujimoto <m.fujimoto@yandex.ru> Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D10116
Notes
Notes: svn path=/head/; revision=436760
Diffstat (limited to 'games/xosmulti')
-rw-r--r--games/xosmulti/Makefile7
-rw-r--r--games/xosmulti/files/patch-biff.c11
-rw-r--r--games/xosmulti/files/patch-image.c18
-rw-r--r--games/xosmulti/files/patch-xosmulti.c37
4 files changed, 71 insertions, 2 deletions
diff --git a/games/xosmulti/Makefile b/games/xosmulti/Makefile
index 1edb3866e3c9..df4cc071f4d0 100644
--- a/games/xosmulti/Makefile
+++ b/games/xosmulti/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xosmulti
PORTVERSION= 1.00
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= LOCAL/flathill
DISTNAME= ${PORTNAME}_${PORTVERSION}_tar
@@ -12,8 +12,11 @@ EXTRACT_SUFX= .gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Little girl cartoon on the top of the active window
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/README.jp
+
WRKSRC= ${WRKDIR}/xosmulti
-USE_XORG= xbitmaps x11 xt xi
+USE_XORG= x11 xbitmaps xext
OPTIONS_DEFINE= DOCS
diff --git a/games/xosmulti/files/patch-biff.c b/games/xosmulti/files/patch-biff.c
new file mode 100644
index 000000000000..6899c5383c8d
--- /dev/null
+++ b/games/xosmulti/files/patch-biff.c
@@ -0,0 +1,11 @@
+--- biff.c.orig 2017-03-22 15:54:32 UTC
++++ biff.c
+@@ -6,6 +6,8 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
++#include <unistd.h>
+ #include <pwd.h> /* for passwd */
+ #include <sys/stat.h> /* for stat, needs types.h */
+
diff --git a/games/xosmulti/files/patch-image.c b/games/xosmulti/files/patch-image.c
new file mode 100644
index 000000000000..a70e01196815
--- /dev/null
+++ b/games/xosmulti/files/patch-image.c
@@ -0,0 +1,18 @@
+--- image.c.orig 2017-03-22 15:54:32 UTC
++++ image.c
+@@ -6,6 +6,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+@@ -44,6 +45,7 @@ unsigned int GetXDepth( disp )
+ Display *disp;
+ {
+
++ return DefaultDepth(disp, 0);
+ XVisualInfo xvi_template;
+ XVisualInfo *p_xvi;
+ int n_item, i;
diff --git a/games/xosmulti/files/patch-xosmulti.c b/games/xosmulti/files/patch-xosmulti.c
new file mode 100644
index 000000000000..1529c65c13e2
--- /dev/null
+++ b/games/xosmulti/files/patch-xosmulti.c
@@ -0,0 +1,37 @@
+--- xosmulti.c.orig 2017-03-22 15:54:32 UTC
++++ xosmulti.c
+@@ -22,6 +22,7 @@ static char Usage[] = {
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/time.h>
+
+ #include <X11/Xlib.h>
+@@ -76,7 +77,7 @@ extern char *QuitMsg; /* 終了時のメッセージ */
+ /******** External Function ********/
+
+ /* in image.c */
+-extern unsigned int GetDepth( );
++extern unsigned int GetXDepth( );
+ extern XImage *CreateMyImage( );
+ extern Cursor CreateMyCursor( );
+
+@@ -419,7 +420,7 @@ void GetArgs( argc, argv )
+
+ XPosRatio = atoi( argv[i] );
+ if( XPosRatio < 0 || 100 < XPosRatio )
+- { fprintf( stderr, "WARNING: xpos(%) must be in 0-100, use default\n" );
++ { fprintf( stderr, "WARNING: xpos(%%) must be in 0-100, use default\n" );
+ XPosRatio = XPOS_RATIO;
+ }
+ }
+@@ -1109,7 +1110,7 @@ void Do_Talk( str )
+
+ n_line = AppendTalk( theFont, str );
+ talk_height = n_line * FontHeight;
+- talk_width = MaxTalkWidth( theFont );
++ talk_width = MaxTalkWidth( );
+ talk_width = talk_width * 9 >> 3; /* 横幅を 9/8 倍する */
+
+ TalkShape( Disp, TalkWin, talk_width, talk_height, 0 );