aboutsummaryrefslogtreecommitdiff
path: root/games/xpacman
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-30 09:38:55 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-30 09:38:55 +0000
commitf34a4a891c18c3df2c741e475aca50f290ade268 (patch)
tree1997f862fecc2ff4788a3c83683f4a0b10d617fa /games/xpacman
parentc77858ab11adccc511566885569ada96136e3fb2 (diff)
downloadports-f34a4a891c18c3df2c741e475aca50f290ade268.tar.gz
ports-f34a4a891c18c3df2c741e475aca50f290ade268.zip
Notes
Diffstat (limited to 'games/xpacman')
-rw-r--r--games/xpacman/Makefile6
-rw-r--r--games/xpacman/files/patch-pac.h15
2 files changed, 20 insertions, 1 deletions
diff --git a/games/xpacman/Makefile b/games/xpacman/Makefile
index d77c74441473..aa6b4af60e26 100644
--- a/games/xpacman/Makefile
+++ b/games/xpacman/Makefile
@@ -14,9 +14,13 @@ LICENSE= GPLv2
RUN_DEPENDS+= ${LOCALBASE}/share/fonts/misc/9x18.pcf.gz:x11-fonts/font-misc-misc
+USES= compiler
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-doublesize
-CPPFLAGS+= -I${LOCALBASE}/include
+# Build ignores CFLAGS, CXXFLAGS
+CPPFLAGS+= -I${LOCALBASE}/include ${CPPFLAGS_${CHOSEN_COMPILER_TYPE}}
+CPPFLAGS_clang= -Wno-c++11-narrowing
LDFLAGS+= -L${LOCALBASE}/lib
USE_XORG= x11 xext
PLIST_FILES= bin/pacman
diff --git a/games/xpacman/files/patch-pac.h b/games/xpacman/files/patch-pac.h
new file mode 100644
index 000000000000..0904693afd79
--- /dev/null
+++ b/games/xpacman/files/patch-pac.h
@@ -0,0 +1,15 @@
+./pac.h:36:30: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
+#define PACTITLE "Pacman v. "VERSION" \xa9 1995,1999,2000 by Roar Thron\xe6s"
+ ^
+
+--- pac.h.orig 2018-07-30 09:36:15 UTC
++++ pac.h
+@@ -33,7 +33,7 @@ void writetext(); //just draw text
+
+ //change my name and you will be sued!!!!!!!!!!!!!!!!!!!!!!!!!!
+ #ifndef VMS
+-#define PACTITLE "Pacman v. "VERSION" \xa9 1995,1999,2000 by Roar Thron\xe6s"
++#define PACTITLE "Pacman v. " VERSION " \xa9 1995,1999,2000 by Roar Thron\xe6s"
+ #else
+ #define PACTITLE "Pacman v. 1_002 \xa9 1995,1999,2000 by Roar Thron\xe6s"
+ #endif