aboutsummaryrefslogtreecommitdiff
path: root/games/xpuyopuyo/Makefile
diff options
context:
space:
mode:
authorDan Moschuk <dan@FreeBSD.org>1999-10-08 21:26:19 +0000
committerDan Moschuk <dan@FreeBSD.org>1999-10-08 21:26:19 +0000
commite019d159b374e30837ad6c42319c9d6ca2142d03 (patch)
tree4f98eeff28d8420c30e8cdc00d0424fa39f8f6c9 /games/xpuyopuyo/Makefile
parentf341afe0b0eba5f03048cd0b2c9d9a78ebdf689d (diff)
downloadports-e019d159b374e30837ad6c42319c9d6ca2142d03.tar.gz
ports-e019d159b374e30837ad6c42319c9d6ca2142d03.zip
Notes
Diffstat (limited to 'games/xpuyopuyo/Makefile')
-rw-r--r--games/xpuyopuyo/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/games/xpuyopuyo/Makefile b/games/xpuyopuyo/Makefile
index c55315051ec6..0c2147cadbce 100644
--- a/games/xpuyopuyo/Makefile
+++ b/games/xpuyopuyo/Makefile
@@ -1,33 +1,38 @@
# New ports collection makefile for: xpuyopuyo
-# Version required: 0.1.1
+# Version required: 0.2.3
# Date created: 19 Sep 1999
# Whom: Yin-Jieh Chen <yinjieh@csie.nctu.edu.tw>
#
# $FreeBSD$
#
-DISTNAME= xpuyopuyo-0.1.1
+DISTNAME= xpuyopuyo-0.2.3
CATEGORIES= games
MASTER_SITES= http://chaos2.org/xpuyopuyo/
MAINTAINER= yinjieh@csie.nctu.edu.tw
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
+ gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ gnomeui.2:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}"
+CONFIGURE_ARG= --with-gnome
USE_GMAKE= yes
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xpuyopuyo ${PREFIX}/bin
-
post-install:
@${MKDIR} ${PREFIX}/share/xpuyopuyo
.for i in AUTHORS COPYING ChangeLog INSTALL NEWS README TESTED TODO
@${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/xpuyopuyo
.endfor
@${MKDIR} ${PREFIX}/share/xpuyopuyo/img
- @${INSTALL_DATA} ${WRKSRC}/img/* ${PREFIX}/share/xpuyopuyo/img
+ @${INSTALL_DATA} ${WRKSRC}/img/*.xpm ${PREFIX}/share/xpuyopuyo/img
.include <bsd.port.mk>