aboutsummaryrefslogtreecommitdiff
path: root/games/xqf/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-26 17:59:25 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-26 17:59:25 +0000
commite0aec28ab0105fc66d5534cdeebae2ba6565af3c (patch)
tree46524a44c1bb50898ba98c86ea0169f53ed67484 /games/xqf/Makefile
parentd20b89ce288d46468e3ab129490347f0c3ef69f2 (diff)
downloadports-e0aec28ab0105fc66d5534cdeebae2ba6565af3c.tar.gz
ports-e0aec28ab0105fc66d5534cdeebae2ba6565af3c.zip
Notes
Diffstat (limited to 'games/xqf/Makefile')
-rw-r--r--games/xqf/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/games/xqf/Makefile b/games/xqf/Makefile
index f38e6f868913..7eae89815b62 100644
--- a/games/xqf/Makefile
+++ b/games/xqf/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xqf
-PORTVERSION= 0.9.14
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,15 +14,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Find quake servers
-RUN_DEPENDS= qstat:${PORTSDIR}/games/qstat \
- wget:${PORTSDIR}/ftp/wget
+RUN_DEPENDS= qstat:${PORTSDIR}/games/qstat
-USE_GNOME= gnometarget intlhack
+USE_X_PREFIX= yes
+USE_GNOME= gnomehier gnometarget intlhack
USE_GETOPT_LONG= yes
USE_GETTEXT= yes
USE_REINPLACE= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN6= xqf.6
@@ -54,12 +53,14 @@ RUN_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|: install-ApplicationsDATA|:|g ; \
+ 's|: install-desktopDATA|:|g ; \
s|$$(datadir)/pixmaps|$$(pkgdatadir)/pixmaps|g'
post-install:
- @${MKDIR} ${DATADIR}/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/pixmaps/xqf_48x48.png ${DATADIR}/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/xqf.desktop \
+ ${PREFIX}/share/gnome/applications
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/xqf_32x32.png \
+ ${PREFIX}/share/gnome/pixmaps
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/xqfdocs.html ${DOCSDIR}