aboutsummaryrefslogtreecommitdiff
path: root/games/xrally/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-05-08 12:30:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-05-08 12:30:52 +0000
commit58032d5b452ff497881c4bd9e39096eea6881caa (patch)
tree81e208fcdd72ea5fdbb5160ec97d1597ed0b9367 /games/xrally/Makefile
parentf43f7d39537669e76911639b34e62f1c41bc2377 (diff)
Notes
Diffstat (limited to 'games/xrally/Makefile')
-rw-r--r--games/xrally/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/xrally/Makefile b/games/xrally/Makefile
new file mode 100644
index 000000000000..cee927665b0a
--- /dev/null
+++ b/games/xrally/Makefile
@@ -0,0 +1,31 @@
+#
+# New ports collection makefile for: xrally
+# Date created: 86 May 2005
+# Whom: Edwin Groothuis
+#
+# $FreeBSD$
+#
+
+PORTNAME= xrally
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xrally
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= XRally is a Linux clone of the classic Rally X arcade game
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GCC= 2.95
+HAS_CONFIGURE= yes
+USE_PTHREADS= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_XLIB= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include" \
+ INCLUDES="-I${X11BASE}/include"
+
+.include <bsd.port.mk>