aboutsummaryrefslogtreecommitdiff
path: root/games/xroads/files
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-08-09 01:22:00 +0000
committerSteve Price <steve@FreeBSD.org>1998-08-09 01:22:00 +0000
commitdbc64fac16eecbb8b327a91baf34446d4a8f7c5b (patch)
treed13885fdd4a1de8218c19f36a80788366866d317 /games/xroads/files
parent95ec841a80588a1db9ec77344050e92c6bda19a5 (diff)
downloadports-dbc64fac16eecbb8b327a91baf34446d4a8f7c5b.tar.gz
ports-dbc64fac16eecbb8b327a91baf34446d4a8f7c5b.zip
Notes
Diffstat (limited to 'games/xroads/files')
-rw-r--r--games/xroads/files/patch-aa47
-rw-r--r--games/xroads/files/patch-ab11
2 files changed, 46 insertions, 12 deletions
diff --git a/games/xroads/files/patch-aa b/games/xroads/files/patch-aa
index 1b96a9c2391a..6fb4422b3bce 100644
--- a/games/xroads/files/patch-aa
+++ b/games/xroads/files/patch-aa
@@ -1,20 +1,43 @@
---- Makefile Mon Jun 29 22:40:15 1998
-+++ /home/andy/tmp/wrk/Makefile Tue Jun 30 15:15:12 1998
-@@ -31,7 +31,7 @@
- # window and monochrome graphics.
+--- Makefile Mon Aug 3 17:24:42 1998
++++ /home/andy/tmp/wrk/Makefile Tue Aug 4 12:55:37 1998
+@@ -5,7 +5,11 @@
+ # optimizations. Check the manual for your compiler.
###########################################################################
--FLAGS = -O3 -DXPLOSIONS -DGAMEDELAY=10000
-+FLAGS= ${CFLAGS} -DXPLOSIONS -DGAMEDELAY=10000 -I${X11BASE}/include
+-FLAGS = -O2 -g -Wall
++CFLAGS?= -O2 -g -Wall
++PREFIX?= /usr/X11R6
++DATADIR?= $(PREFIX)/share/xroads
++INCLUDE?= -I/usr/X11R6/include
++LIBS?= -L/usr/X11R6/lib -lX11 -lm
# These lines ain't needed... but I'm not taking 'em out yet
#BOGOMIPS = `grep bogomips /proc/cpuinfo | awk '{ printf("%s", $$3) }'`
-@@ -48,7 +48,7 @@
- # Make sure there is a / at the end of the path
+@@ -36,7 +40,7 @@
###########################################################################
--XRMPATH = ./
-+XRMPATH = ${X11BASE}/share/xroads/
+ # Your C compiler
+-CC = gcc
++CC?= gcc
- ###########################################################################
- # Links necessary for X11
+ # Your tar
+ TAR = tar
+@@ -54,12 +58,12 @@
+
+ ## "all" of course builds XRoads.
+ all:
+- $(CC) $(FLAGS) -c chardata.c
+- $(CC) $(FLAGS) -c tiledata.c
+- $(CC) $(FLAGS) -c fileops.c
+- $(CC) $(FLAGS) -c ai.c
+- $(CC) $(FLAGS) -c screens.c
+- $(CC) $(FLAGS) $(LINK) -o xroads xroads.c chardata.o tiledata.o fileops.o ai.o screens.o
++ $(CC) $(CFLAGS) $(INCLUDE) -DDATADIR=\"$(DATADIR)\" -c chardata.c
++ $(CC) $(CFLAGS) $(INCLUDE) -DDATADIR=\"$(DATADIR)\" -c tiledata.c
++ $(CC) $(CFLAGS) $(INCLUDE) -DDATADIR=\"$(DATADIR)\" -c fileops.c
++ $(CC) $(CFLAGS) $(INCLUDE) -DDATADIR=\"$(DATADIR)\" -c ai.c
++ $(CC) $(CFLAGS) $(INCLUDE) -DDATADIR=\"$(DATADIR)\" -c screens.c
++ $(CC) $(CFLAGS) $(INCLUDE) -DDATADIR=\"$(DATADIR)\" $(LIBS) -o xroads xroads.c chardata.o tiledata.o fileops.o ai.o screens.o
+
+ ## "quick" just recompiles xroads.c and links it with the existing .o's
+ ## do NOT use this unless you've been altering my code :P
diff --git a/games/xroads/files/patch-ab b/games/xroads/files/patch-ab
new file mode 100644
index 000000000000..420389b77329
--- /dev/null
+++ b/games/xroads/files/patch-ab
@@ -0,0 +1,11 @@
+--- config.h Mon Aug 3 17:24:42 1998
++++ /home/andy/tmp/wrk/config.h Tue Aug 4 12:49:10 1998
+@@ -62,7 +62,7 @@
+ line parameters too. Make sure to put a / on the end, or it won't
+ work correctly */
+
+-#define XRMPATH "./"
++#define XRMPATH DATADIR "/"
+
+ /* Comment this out to use the P key to pause the game. If you used this
+ key as one of your motion keys, then leave then uncomment it and use