aboutsummaryrefslogtreecommitdiff
path: root/games/xrubik
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1996-10-12 00:11:34 +0000
committerChuck Robey <chuckr@FreeBSD.org>1996-10-12 00:11:34 +0000
commit3424625c588bfd6fc81b81fcdf7340b7f7117cb0 (patch)
tree69cacd7313bc9c9f06a85e6e891dbe6196d41003 /games/xrubik
parent83fd705cec9a2d623cb55905b56e1a0fe59af9d9 (diff)
downloadports-3424625c588bfd6fc81b81fcdf7340b7f7117cb0.tar.gz
ports-3424625c588bfd6fc81b81fcdf7340b7f7117cb0.zip
New game port, Rubik's Cube type game.
Submitted by: Yukihiro Nakai <nakai@mlab.t.u-tokyo.ac.jp>
Notes
Notes: svn path=/head/; revision=3966
Diffstat (limited to 'games/xrubik')
-rw-r--r--games/xrubik/Makefile23
-rw-r--r--games/xrubik/distinfo1
-rw-r--r--games/xrubik/pkg-comment1
-rw-r--r--games/xrubik/pkg-descr69
-rw-r--r--games/xrubik/pkg-plist2
5 files changed, 96 insertions, 0 deletions
diff --git a/games/xrubik/Makefile b/games/xrubik/Makefile
new file mode 100644
index 000000000000..12893317a740
--- /dev/null
+++ b/games/xrubik/Makefile
@@ -0,0 +1,23 @@
+#New ports collection makefile for: xrubik
+# Version required: V5.3.2
+# Date created: 20 Oct 1996
+# Whom: Yukihiro Nakai <nakai@mlab.t.u-tokyo.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= xrubik
+PKGNAME= xrubik-5.3.2
+CATEGORIES+= games x11
+MASTER_SITES= ftp://ftp.iis.u-tokyo.ac.jp/pub1/X/contrib/games/puzzles/
+
+MAINTAINER= nakai@mlab.t.u-tokyo.ac.jp
+
+USE_IMAKE= yes
+USE_X11= yes
+
+post-install:
+ @chmod 755 ${PREFIX}/bin/xrubik
+ @chown bin.bin ${PREFIX}/bin/xrubik
+
+.include <bsd.port.mk>
diff --git a/games/xrubik/distinfo b/games/xrubik/distinfo
new file mode 100644
index 000000000000..2d81fdebf06a
--- /dev/null
+++ b/games/xrubik/distinfo
@@ -0,0 +1 @@
+MD5 (xrubik.tar.gz) = e1d36062c416f21f332226cd85fd4209
diff --git a/games/xrubik/pkg-comment b/games/xrubik/pkg-comment
new file mode 100644
index 000000000000..088053b2eba4
--- /dev/null
+++ b/games/xrubik/pkg-comment
@@ -0,0 +1 @@
+X-based rubik's cube(tm)
diff --git a/games/xrubik/pkg-descr b/games/xrubik/pkg-descr
new file mode 100644
index 000000000000..81be555cce13
--- /dev/null
+++ b/games/xrubik/pkg-descr
@@ -0,0 +1,69 @@
+Xrubik, X-based rubik's cube(tm)
+
+ Click on the left mouse button to move a piece. Release it on a
+ piece in the same row and on the face. The puzzle will then turn
+ towards where the mouse button was released.
+ Click on the middle mouse button toggle the practice mode. (This is
+ good for learning moves). Also 'P' or 'p' do the same thing.
+ One must double click on the middle mouse button if the puzzle is
+ being worked on.
+ Click on the right mouse button if you want to randomize the puzzle.
+ Also 'R' or 'r' do the same thing. One must double click on
+ the right mouse button if the puzzle is being worked on.
+ 'I' or 'i' to increase the number of cubes.
+ 'D' or 'd' to decrease the number of cubes.
+ 'O' or 'o' to toggle orient mode. (I prefer the orient mode since
+ it is slightly more challenging).
+ 'S', 's' to auto-solve. It only works on 1x1x1, 2x2x2, 3x3x3 cubes.
+ For the 3x3x3 it only solves it in the non-orient mode.
+ 'U' or 'u' to undo last move.
+ 'G' or 'g' to get a saved puzzle.
+ 'W' or 'w' to write or save a puzzle.
+ 'Q', 'q', or Control-C to kill program.
+
+ Key pad is defined for 2d rubik as:
+ /
+
+ 8
+ ^
+ 4 < 5 > 6
+ v
+ 2
+
+ The key pad along with the use of the mouse will allow you to move the
+ cube i.e.,
+ KP_DIVIDE=>CCW
+ KP_8=>Top
+ KP=>Left KP_5=>CW KP_6=>Right
+ KP_2=>Bottom
+
+ Key pad for 3d rubik, use your intuition (is this a cop out or what?).
+ The key pad is defined differently depending on which side of the cube
+ your mouse is pointing at. One thing that stays the same is KP_5=>CW.
+
+ The control key allows you to move the whole cube at once without
+ being entered as a move. Hold down the control key while using the
+ left mouse button or the keypad.
+ One has to orient the faces in orient mode, besides getting all the
+ faces to be the same color. To do this one has to get the lines to
+ be oriented in the same direction, this only matters with center
+ cubes (i.e. those cubes not on a corner or edge). This does add
+ complexity so there are 2 sets of records.
+
+ Try resizing the cube. Notice the puzzle resizes to take advantage
+ of the "room" available.
+
+ The title is in the following format (non-motif version):
+ xrubik{2|3}d: {1|2|3|4|5|6} @ (<Number of moves>/\
+ {<Record number of moves>|NEVER|PRACTICE}) - <Comment>
+ {2|3}: current dimensional view
+ {1|2|3|4|5|6}: number of cubes per edge
+ {<Record...}: puzzle is either in practice mode or record mode
+ In record mode, if there is no record of the current puzzle, it
+ displays "NEVER".
+
+ If you were looking for a auto-solver, sorry. One of the problems in
+ auto-solvers the generally don't work for different number of cuts.
+ If you know of one let me know. There is a real neat 3x3x3 cube called
+ "magiccube" with a better 3-D look, a auto-solver, and Motif. Use
+ "archie" to find "magiccube" at the site nearest you.
diff --git a/games/xrubik/pkg-plist b/games/xrubik/pkg-plist
new file mode 100644
index 000000000000..c12f796d4a7e
--- /dev/null
+++ b/games/xrubik/pkg-plist
@@ -0,0 +1,2 @@
+bin/xrubik
+man/man1/xrubik.1.gz