aboutsummaryrefslogtreecommitdiff
path: root/games/xshogi
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-10-16 17:11:57 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-10-16 17:11:57 +0000
commiteecd165e2cc8a540578347e4df46da07cd251083 (patch)
treebd98d92c5ac2f6283a23d57fcbd489d45d5b3930 /games/xshogi
parent848c2b81bac98794643404a00b7c92a68a67d881 (diff)
downloadports-eecd165e2cc8a540578347e4df46da07cd251083.tar.gz
ports-eecd165e2cc8a540578347e4df46da07cd251083.zip
Notes
Diffstat (limited to 'games/xshogi')
-rw-r--r--games/xshogi/Makefile4
-rw-r--r--games/xshogi/files/patch-xshogi_sysdeps.h19
2 files changed, 21 insertions, 2 deletions
diff --git a/games/xshogi/Makefile b/games/xshogi/Makefile
index db8ca1287566..43074b61a8c4 100644
--- a/games/xshogi/Makefile
+++ b/games/xshogi/Makefile
@@ -7,13 +7,12 @@
PORTNAME= xshogi
PORTVERSION= ${GNUSHOGI_PORTVERSION}
-PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${GNUSHOGI_MASTER_SITES}
MASTER_SITE_SUBDIR= ${GNUSHOGI_MASTER_SITE_SUBDIR}
DISTNAME= ${GNUSHOGI_DISTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= The Japanese chess-like game for X Window System
RUN_DEPENDS= gnushogi:${PORTSDIR}/games/gnushogi
@@ -22,6 +21,7 @@ BUILD_WRKSRC= ${WRKSRC}/xshogi
USE_XORG= xt xaw x11
GNU_CONFIGURE= yes
+USE_CSTD= gnu99
MAN6= xshogi.6
PLIST_FILES= bin/xshogi
diff --git a/games/xshogi/files/patch-xshogi_sysdeps.h b/games/xshogi/files/patch-xshogi_sysdeps.h
new file mode 100644
index 000000000000..da73946e8264
--- /dev/null
+++ b/games/xshogi/files/patch-xshogi_sysdeps.h
@@ -0,0 +1,19 @@
+--- xshogi/sysdeps.h.orig 2011-10-16 17:53:35.000000000 +0200
++++ xshogi/sysdeps.h 2011-10-16 17:54:05.000000000 +0200
+@@ -74,16 +74,6 @@
+ #include <sys/time.h>
+ #include <fcntl.h>
+
+-/*
+- * Stuff that isn't reliably included (on Linux, anyway).
+- */
+-
+-extern FILE *fdopen(int fd, const char *modes);
+-extern int fileno(FILE *stream);
+-extern int kill(pid_t pid, int sig);
+-extern int strcasecmp(const char *s1, const char *s2);
+-extern int gethostname(char *name, size_t len);
+-
+
+ /*
+ * Check for POSIX-compatible wait().