aboutsummaryrefslogtreecommitdiff
path: root/games/xskat
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-02-01 16:31:45 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-02-01 16:31:45 +0000
commita111ad3a24d9dc156bc64d23cf8a9e96562c04fa (patch)
tree578e0790b379dcc05ecb5b6b90a612667e783517 /games/xskat
parentfa6095be8835ceb2d66a87bb2401cfec5e2108df (diff)
Notes
Diffstat (limited to 'games/xskat')
-rw-r--r--games/xskat/Makefile37
-rw-r--r--games/xskat/files/patch-Makefile20
2 files changed, 37 insertions, 20 deletions
diff --git a/games/xskat/Makefile b/games/xskat/Makefile
index 22c41c2eed7d..ca40b458646d 100644
--- a/games/xskat/Makefile
+++ b/games/xskat/Makefile
@@ -6,33 +6,30 @@ PORTVERSION= 4.0
PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://www.xskat.de/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Play the card game Skat
-.if defined(WITH_ALTENBURGER_CARDS)
-DISTFILES+= xskat-cards.tar.gz
-RESTRICTED= The altenburger card file is NOT freely redistributable!
-.endif
+LICENSE= unknown
+LICENSE_NAME= xskat license clause
+LICENSE_FILE= ${WRKSRC}/README
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= imake
USE_XORG= x11
-MAN1= xskat.1 xskat-de.1
-PLIST_FILES= bin/xskat
-
-NO_STAGE= yes
-pre-fetch:
-.if !defined(WITH_ALTENBURGER_CARDS)
- @${ECHO}
- @${ECHO} "You can compile xskat with the beautiful original"
- @${ECHO} "Altenburger card set by setting WITH_ALTENBURGER_CARDS"
- @${ECHO}
-.endif
+PLIST_FILES= bin/xskat \
+ man/man1/xskat.1.gz \
+ man/man1/xskat-de.1.gz
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lX11
post-patch:
-.if defined(WITH_ALTENBURGER_CARDS)
- cd ${WRKSRC}; ${CP} ../xskat-cards.c cards.c
-.endif
+ ${MV} ${WRKSRC}/xskat.man ${WRKSRC}/xskat.1
+ ${MV} ${WRKSRC}/xskat-de.man ${WRKSRC}/xskat-de.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xskat ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xskat.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/xskat-de.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/games/xskat/files/patch-Makefile b/games/xskat/files/patch-Makefile
new file mode 100644
index 000000000000..92c6cf39e794
--- /dev/null
+++ b/games/xskat/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2000-03-08 20:31:24.000000000 +0100
++++ Makefile 2014-02-01 13:26:41.616864659 +0100
+@@ -16,8 +16,6 @@
+ # where x.y is the version of the original program
+ # and z is an arbitrary suffix.
+
+-CFLAGS =
+-LDFLAGS = -L/usr/X11R6/lib -lX11
+ # perhaps you need one of: -lsocket -lnsl
+
+ #DEFL = -DDEFAULT_LANGUAGE=\"german\"
+@@ -28,6 +26,8 @@
+ SHELL = /bin/sh
+ OBJECTS = skat.o ramsch.o null.o bitmaps.o xio.o xdial.o irc.o text.o
+
++all: xskat
++
+ xskat: $(OBJECTS)
+ $(CC) $(OBJECTS) $(LDFLAGS) -o $@
+