aboutsummaryrefslogtreecommitdiff
path: root/games/xtris
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-01-24 01:35:42 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-01-24 01:35:42 +0000
commit553bbd3676334c507bb541dfd60e0e57e91b2510 (patch)
treeead4bb00af2961167a189aa10f5d3e7f5d2f23cb /games/xtris
parentba3098780813b471aa111b11ca1a0b50d57a2aa1 (diff)
downloadports-553bbd3676334c507bb541dfd60e0e57e91b2510.tar.gz
ports-553bbd3676334c507bb541dfd60e0e57e91b2510.zip
Notes
Diffstat (limited to 'games/xtris')
-rw-r--r--games/xtris/Makefile15
-rw-r--r--games/xtris/distinfo1
-rw-r--r--games/xtris/files/patch-aa24
3 files changed, 30 insertions, 10 deletions
diff --git a/games/xtris/Makefile b/games/xtris/Makefile
index c08c3ac69d38..fc42e54e58ec 100644
--- a/games/xtris/Makefile
+++ b/games/xtris/Makefile
@@ -7,9 +7,14 @@
#
DISTNAME= xtris-1.15
-CATEGORIES= games
+CATEGORIES= games ipv6
MASTER_SITES= http://www.iagora.com/~espel/xtris/
+PATCH_SITES= ftp://ftp2.v6.linux.or.jp/pub/Linux/IPv6-2/xtris/ \
+ http://ftp2.v6.linux.or.jp/pub/Linux/IPv6-2/xtris/
+PATCHFILES= xtris-1.15-v6-19991218.diff.gz
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= sec@42.org
RESTRICTED= "Possible trademark infringement"
@@ -18,4 +23,10 @@ WRKSRC= ${WRKDIR}/xtris
USE_X_PREFIX= yes
MAN6= xtris.6 xtserv.6 xtbot.6
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 400014
+MAKE_ENV= IPV6_CFLAGS="-DINET6"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/xtris/distinfo b/games/xtris/distinfo
index 824f98bc6396..1c581501101b 100644
--- a/games/xtris/distinfo
+++ b/games/xtris/distinfo
@@ -1 +1,2 @@
MD5 (xtris-1.15.tar.gz) = c63be31895feca9f929b57b67b779ced
+MD5 (xtris-1.15-v6-19991218.diff.gz) = 1e38715a5c990586198a141a4b78fed5
diff --git a/games/xtris/files/patch-aa b/games/xtris/files/patch-aa
index d263a62caa45..8c31415ccecc 100644
--- a/games/xtris/files/patch-aa
+++ b/games/xtris/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.orig Sun Dec 14 20:43:35 1997
-+++ Makefile Sun Aug 29 20:28:11 1999
-@@ -8,22 +8,22 @@
+--- Makefile.orig Mon Jan 17 13:33:15 2000
++++ Makefile Mon Jan 17 13:36:11 2000
+@@ -8,27 +8,27 @@
###################
# change this to your favorite ANSI C compiler
@@ -16,15 +16,23 @@
+MANDIR = ${PREFIX}/man
# change according to taste and local custom...
--CFLAGS = -O3 -D__USE_FIXED_PROTOTYPES__
-+CFLAGS += -D__USE_FIXED_PROTOTYPES__ -I${PREFIX}/include
+-CFLAGS = -O3 -D__USE_FIXED_PROTOTYPES__ $(IPV6_CFLAGS) $(XCFLAGS)
++CFLAGS += -D__USE_FIXED_PROTOTYPES__ $(IPV6_CFLAGS) $(XCFLAGS)
# on Solaris and similar systems, you'll need to uncomment this:
- # EXTRALIBS = -lnsl -lsocket
+ EXTRALIBS = $(IPV6_LDFLAGS) #-lnsl -lsocket
- # specify X11 libdir if your system needs it
--# XLIBDIR = -L/usr/X11/lib
+ # specify X11 cflags and libdir if your system needs it
+-XCFLAGS = #-I/usr/X11/include
+-XLIBDIR = #-L/usr/X11/lib
++XCFLAGS = -I${PREFIX}/include
+XLIBDIR = -L${PREFIX}/lib
+ # IPv6 Settings
+-IPV6_CFLAGS = #-DINET6 #-I/usr/inet6/include
+-IPV6_LDFLAGS = #-L/usr/local/v6/lib -linet6
++#IPV6_CFLAGS = #-DINET6 #-I/usr/inet6/include
++#IPV6_LDFLAGS = #-L/usr/local/v6/lib -linet6
###########################################################################
+ ## You shouldn't need to change anything past this. ##