aboutsummaryrefslogtreecommitdiff
path: root/games/xye/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-30 07:12:06 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-30 07:12:06 +0000
commit04f0e6ce8ffaf2c02088ac47320dda7f4a7c5ddb (patch)
treef52f5b4f2f41518899ee0a99d3abf0051983c54e /games/xye/Makefile
parentbe089cfc8128a0a16c63cea3a8871d7c6b68b1d0 (diff)
downloadports-04f0e6ce8ffaf2c02088ac47320dda7f4a7c5ddb.tar.gz
ports-04f0e6ce8ffaf2c02088ac47320dda7f4a7c5ddb.zip
Notes
Diffstat (limited to 'games/xye/Makefile')
-rw-r--r--games/xye/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/xye/Makefile b/games/xye/Makefile
index 92402eba2818..da9eaa723def 100644
--- a/games/xye/Makefile
+++ b/games/xye/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xye
PORTVERSION= 0.12.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF:game \
http://xye.sourceforge.net/levels/ \
@@ -27,10 +27,12 @@ LICENSE= ZLIB
EXTRACT_DEPENDS=${UNZIP_CMD}:archivers/unzip
-USES= gmake
+USES= compiler gmake
USE_SDL= sdl image ttf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-docdir=${PREFIX}/share/doc
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
LEVELS= Xye%20level%20-%204corners Xye%20level%20-%20Against%20the%20force \
Xye%20level%20-%20Stop%20that%20cab Xye%20level%20-%20Helping%20Hand \
@@ -89,7 +91,7 @@ post-install:
@(cd ${WRKDIR}/skins && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/res)
.endif
- ${LN} -sf ${DATADIR}/res/detailed_icon.png \
+ ${RLN} ${STAGEDIR}${DATADIR}/res/detailed_icon.png \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.include <bsd.port.mk>