aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-05-12 18:53:07 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-05-12 18:53:07 +0000
commit0a88456a6ac27fd016c7ee89a3b506eb4efca840 (patch)
tree80dccab8e47ca90aed27878960da1c9b3f1e558e /games
parente9ade083b940f3604cfb0d742bd15dd77e98e374 (diff)
downloadports-0a88456a6ac27fd016c7ee89a3b506eb4efca840.tar.gz
ports-0a88456a6ac27fd016c7ee89a3b506eb4efca840.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/wesnoth-devel/Makefile1
-rw-r--r--games/wesnoth-devel/files/patch-src::language.hpp17
-rw-r--r--games/wesnoth-devel/files/patch-src::widgets::textbox.hpp17
-rw-r--r--games/wesnoth/Makefile1
-rw-r--r--games/wesnoth/files/patch-src::language.hpp17
-rw-r--r--games/wesnoth/files/patch-src::widgets::textbox.hpp17
6 files changed, 68 insertions, 2 deletions
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
index 3e4cbd290870..4fe63e9f9aca 100644
--- a/games/wesnoth-devel/Makefile
+++ b/games/wesnoth-devel/Makefile
@@ -17,7 +17,6 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
-USE_GCC= 3.3
USE_SDL= image mixer net ttf
USE_GNOME= gnometarget
WANT_GNOME= yes
diff --git a/games/wesnoth-devel/files/patch-src::language.hpp b/games/wesnoth-devel/files/patch-src::language.hpp
new file mode 100644
index 000000000000..8ab1e88d877f
--- /dev/null
+++ b/games/wesnoth-devel/files/patch-src::language.hpp
@@ -0,0 +1,17 @@
+--- src/language.hpp.orig Mon May 3 18:35:49 2004
++++ src/language.hpp Wed May 12 00:50:43 2004
+@@ -19,6 +19,14 @@
+ #include <string>
+ #include <vector>
+
++#if (__FreeBSD_version < 500029)
++#include <cwchar>
++namespace std
++{
++ typedef basic_string <wchar_t> wstring;
++}
++#endif
++
+ //this module controls internationalization.
+
+ struct symbol_table
diff --git a/games/wesnoth-devel/files/patch-src::widgets::textbox.hpp b/games/wesnoth-devel/files/patch-src::widgets::textbox.hpp
new file mode 100644
index 000000000000..6abbf1e960b2
--- /dev/null
+++ b/games/wesnoth-devel/files/patch-src::widgets::textbox.hpp
@@ -0,0 +1,17 @@
+--- src/widgets/textbox.hpp.orig Mon May 3 18:35:49 2004
++++ src/widgets/textbox.hpp Wed May 12 00:51:03 2004
+@@ -22,6 +22,14 @@
+
+ #include "SDL.h"
+
++#if (__FreeBSD_version < 500029)
++#include <cwchar>
++namespace std
++{
++ typedef basic_string <wchar_t> wstring;
++}
++#endif
++
+ namespace gui {
+
+ class textbox : public widget
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 3e4cbd290870..4fe63e9f9aca 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -17,7 +17,6 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
-USE_GCC= 3.3
USE_SDL= image mixer net ttf
USE_GNOME= gnometarget
WANT_GNOME= yes
diff --git a/games/wesnoth/files/patch-src::language.hpp b/games/wesnoth/files/patch-src::language.hpp
new file mode 100644
index 000000000000..8ab1e88d877f
--- /dev/null
+++ b/games/wesnoth/files/patch-src::language.hpp
@@ -0,0 +1,17 @@
+--- src/language.hpp.orig Mon May 3 18:35:49 2004
++++ src/language.hpp Wed May 12 00:50:43 2004
+@@ -19,6 +19,14 @@
+ #include <string>
+ #include <vector>
+
++#if (__FreeBSD_version < 500029)
++#include <cwchar>
++namespace std
++{
++ typedef basic_string <wchar_t> wstring;
++}
++#endif
++
+ //this module controls internationalization.
+
+ struct symbol_table
diff --git a/games/wesnoth/files/patch-src::widgets::textbox.hpp b/games/wesnoth/files/patch-src::widgets::textbox.hpp
new file mode 100644
index 000000000000..6abbf1e960b2
--- /dev/null
+++ b/games/wesnoth/files/patch-src::widgets::textbox.hpp
@@ -0,0 +1,17 @@
+--- src/widgets/textbox.hpp.orig Mon May 3 18:35:49 2004
++++ src/widgets/textbox.hpp Wed May 12 00:51:03 2004
+@@ -22,6 +22,14 @@
+
+ #include "SDL.h"
+
++#if (__FreeBSD_version < 500029)
++#include <cwchar>
++namespace std
++{
++ typedef basic_string <wchar_t> wstring;
++}
++#endif
++
+ namespace gui {
+
+ class textbox : public widget