aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2018-10-15 00:13:06 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2018-10-15 00:13:06 +0000
commit1b2573bc31c748c6428c264b584e4817ccaa070c (patch)
tree2e6e4546ac75dafef5721d5b2e6642500032fe76 /games
parent29b3a86f5fe19c93ce73b44b19d10064d5a5ba9d (diff)
downloadports-1b2573bc31c748c6428c264b584e4817ccaa070c.tar.gz
ports-1b2573bc31c748c6428c264b584e4817ccaa070c.zip
unbreak games/nxengine on powerpc64 and others
PR: 232016 Submitted by: Piotr Kubaj
Notes
Notes: svn path=/head/; revision=482126
Diffstat (limited to 'games')
-rw-r--r--games/nxengine/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/games/nxengine/Makefile b/games/nxengine/Makefile
index 360e3dc90747..c3c205d717ca 100644
--- a/games/nxengine/Makefile
+++ b/games/nxengine/Makefile
@@ -2,8 +2,8 @@
PORTNAME= nxengine
PORTVERSION= 2.6.3
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES+= https://www.cavestory.org/downloads/:data \
SF/lifanov-ports-distfiles/games/${PORTNAME}/:icons
@@ -23,22 +23,20 @@ LICENSE_PERMS_FREEWARE= dist-mirror pkg-mirror auto-accept
LICENSE_DISTFILES_GPLv3= ${DISTFILES:[3]}
LICENSE_DISTFILES_FREEWARE= ${DISTFILES:[2]:S/:data//}
-BROKEN_aarch64= fails to compile: player.cpp:763:50: constant expression evaluates to -1 which cannot be narrowed to type 'char' [-Wc++11-narrowing]
-BROKEN_armv6= fails to compile: player.cpp:763:50: constant expression evaluates to -1 which cannot be narrowed to type 'char' [-Wc++11-narrowing]
-BROKEN_armv7= fails to compile: player.cpp:763:50: constant expression evaluates to -1 which cannot be narrowed to type 'char' [-Wc++11-narrowing]
-
LIB_DEPENDS= libpng.so:graphics/png
-DESKTOP_ENTRIES="NXEngine" "" "${PORTNAME}" \
- "${PORTNAME}" "Game;AdventureGame;" ""
-
USES= cmake:outsource compiler:c++11-lang
+
USE_SDL= mixer2 sdl2
SUB_FILES= ${PORTNAME}
+CXXFLAGS+= -Wno-error-narrowing
USE_GITHUB= yes
GH_PROJECT= ${PORTNAME}-evo
+DESKTOP_ENTRIES="NXEngine" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;AdventureGame;" ""
+
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/bin/nx ${STAGEDIR}${DATADIR}