aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2018-10-05 10:10:02 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2018-10-05 10:10:02 +0000
commit33f178ede0d659eb53b7d087a8f6fa33418d8a7a (patch)
treef2189578c9b7432c0c6dab878683896270da4d2d /games
parentf5975804d89f6510861a92c266abc816cd9b09d9 (diff)
downloadports-33f178ede0d659eb53b7d087a8f6fa33418d8a7a.tar.gz
ports-33f178ede0d659eb53b7d087a8f6fa33418d8a7a.zip
Add missing USES=gl to my ports
Notes
Notes: svn path=/head/; revision=481268
Diffstat (limited to 'games')
-rw-r--r--games/blobby/Makefile3
-rw-r--r--games/briquolo/Makefile2
-rw-r--r--games/flightgear/Makefile4
-rw-r--r--games/jfsw/Makefile2
-rw-r--r--games/openalchemist/Makefile3
-rw-r--r--games/trackballs/Makefile2
6 files changed, 9 insertions, 7 deletions
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index ceec14a5b164..ac1f12f7e7ac 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -22,7 +22,8 @@ LIB_DEPENDS= libphysfs.so:devel/physfs
BUILD_DEPENDS= zip:archivers/zip \
${LOCALBASE}/include/boost/crc.hpp:devel/boost-libs
-USES= cmake compiler:c++11-lang dos2unix localbase:ldflags pkgconfig
+USES= cmake compiler:c++11-lang dos2unix gl localbase:ldflags \
+ pkgconfig
DOS2UNIX_REGEX= .*\.(c|h|cpp)
CMAKE_ARGS= -DDATADIR:PATH="${DATADIR}"
WRKSRC= ${WRKDIR}/blobby-${PORTVERSION}
diff --git a/games/briquolo/Makefile b/games/briquolo/Makefile
index 56060342ae8a..720b2d6d8979 100644
--- a/games/briquolo/Makefile
+++ b/games/briquolo/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
-USES= tar:bzip2 gmake iconv desktop-file-utils
+USES= tar:bzip2 gl gmake iconv desktop-file-utils
USE_GL= gl
USE_SDL= mixer sdl ttf
USE_XORG= x11
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index f5f7cef5e64f..368903703303 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -28,8 +28,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
${LOCALBASE}/share/flightgear/version:games/flightgear-data
LLD_UNSAFE= yes
-USES= alias cmake compiler cpe dos2unix jpeg openal:al,alut sqlite \
- tar:bzip2
+USES= alias cmake compiler cpe dos2unix gl jpeg openal:al,alut \
+ sqlite tar:bzip2
USE_XORG= ice sm x11 xext xft xi xinerama xmu xt
USE_GL= gl glew glu glut
diff --git a/games/jfsw/Makefile b/games/jfsw/Makefile
index 48048c7c29a5..1a308b685571 100644
--- a/games/jfsw/Makefile
+++ b/games/jfsw/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS_BuildLic= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-acc
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
-USES= alias dos2unix gmake gnome pkgconfig:build
+USES= alias dos2unix gl gmake gnome pkgconfig:build
DOS2UNIX_REGEX= .*(\.(c|h)|Makefile)(\.deps)?
USE_GITHUB= yes
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index 7718848da013..427816bd1a06 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -23,7 +23,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-USES= autoreconf gmake gnome iconv jpeg pkgconfig python:2.7,run shebangfix
+USES= autoreconf gl gmake gnome iconv jpeg pkgconfig python:2.7,run \
+ shebangfix
SHEBANG_FILES= openalchemist-config
USE_GNOME= pygtk2
diff --git a/games/trackballs/Makefile b/games/trackballs/Makefile
index a15a163fa3a4..d13c6e6e7141 100644
--- a/games/trackballs/Makefile
+++ b/games/trackballs/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libguile-2.0.so:lang/guile2 \
libgc.so:devel/boehm-gc
-USES= cmake desktop-file-utils gettext-runtime gnome pkgconfig
+USES= cmake desktop-file-utils gettext-runtime gl gnome pkgconfig
USE_GITHUB= yes