aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-08-04 15:16:55 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-08-04 15:16:55 +0000
commit49cc2d63e2dcf02210a6d2126b6fc28ce83d1b58 (patch)
tree0ed24f3484aa2511e85523f49321bb3c198a1824 /games
parentdcac88c1482937a83a167095f6737f694d55bc64 (diff)
downloadports-49cc2d63e2dcf02210a6d2126b6fc28ce83d1b58.tar.gz
ports-49cc2d63e2dcf02210a6d2126b6fc28ce83d1b58.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/warsow-data/Makefile55
-rw-r--r--games/warsow-data/distinfo3
-rw-r--r--games/warsow-data/pkg-deinstall16
-rw-r--r--games/warsow-data/pkg-descr7
-rw-r--r--games/warsow-data/pkg-install11
-rw-r--r--games/warsow-data/pkg-plist122
7 files changed, 215 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index fc4d702389f1..55a16a01881a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -720,6 +720,7 @@
SUBDIR += wanderer
SUBDIR += wargus
SUBDIR += warsow
+ SUBDIR += warsow-data
SUBDIR += warzone2100
SUBDIR += wesnoth
SUBDIR += wmeyes
diff --git a/games/warsow-data/Makefile b/games/warsow-data/Makefile
new file mode 100644
index 000000000000..67e68b283edc
--- /dev/null
+++ b/games/warsow-data/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: warsow-data
+# Date created: 2006-08-03
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= data
+PORTVERSION= 0.12
+CATEGORIES= games
+MASTER_SITES= http://ftp.club-internet.fr/pub/games/nofrag/warsow/
+MASTER_SITES= http://ftp.club-internet.fr/pub/games/nofrag/warsow/ \
+ http://mirrors-av.club-internet.fr/pub/games/nofrag/warsow/ \
+ http://kenh.rxvt.net/ \
+ http://turkeyfiles.escapedturkey.net/warsow/versions/ \
+ http://www.gizmo.fi/warsow/ \
+ http://warsow.as-mirror.net/ \
+ http://wsw.surreal-xenotronic.com/ \
+ http://tmp.death-row.org/
+PKGNAMEPREFIX= warsow-
+DISTNAME= ${PKGNAMEPREFIX:S/-//}_${PORTVERSION}_linux
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Warsow data files
+
+NO_BUILD= yes
+WARSOW_EXTRACT= ${PKGNAMEPREFIX:S/-//}/basewsw ${PKGNAMEPREFIX:S/-//}/docs
+DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX:S/-//}
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX:S/-//}
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX:S/-//}
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${WARSOW_EXTRACT}
+
+post-extract:
+ ${RM} -R ${WRKSRC}/basewsw/*.so
+ ${RM} -R ${WRKSRC}/basewsw/screenshots ${WRKSRC}/basewsw/demos
+
+do-install:
+ @${MKDIR} ${DATADIR}/basewsw
+ @cd ${WRKSRC}/basewsw && \
+ ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/basewsw/{}" \; && \
+ ${FIND} -E * -type f -iregex ".*\.(pk3|cfg|hud)" \
+ -exec ${INSTALL_DATA} "{}" "${DATADIR}/basewsw/{}" \;
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for FILE in Shader* bots_navigation.txt changelog.txt contact.txt dedicated* demoavi.txt \
+ huds.txt linux_sound_sdl.txt new* query*
+ ${INSTALL_DATA} ${WRKSRC}/docs/${FILE} ${DOCSDIR}
+. endfor
+.endif
+
+post-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/games/warsow-data/distinfo b/games/warsow-data/distinfo
new file mode 100644
index 000000000000..d91c3b53b27c
--- /dev/null
+++ b/games/warsow-data/distinfo
@@ -0,0 +1,3 @@
+MD5 (warsow/warsow_0.12_linux.tar.gz) = ee288d7508237a0670b20cf64516ad36
+SHA256 (warsow/warsow_0.12_linux.tar.gz) = 7ff7b48106fe09663c76f8e305b1532538bd3ee29458a6c4241225266951c926
+SIZE (warsow/warsow_0.12_linux.tar.gz) = 66745206
diff --git a/games/warsow-data/pkg-deinstall b/games/warsow-data/pkg-deinstall
new file mode 100644
index 000000000000..e5681b6e459d
--- /dev/null
+++ b/games/warsow-data/pkg-deinstall
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+case $2 in
+ DEINSTALL)
+ config_file=$PKG_PREFIX/share/warsow/basewsw/config.cfg
+
+ if [ -e $config_file ] && ! [ -s $config_file ]; then
+ rm -f $config_file
+ fi
+ ;;
+
+ POST-DEINSTALL)
+ rmdir $PKG_PREFIX/share/warsow/basewsw 2>/dev/null || true
+ rmdir $PKG_PREFIX/share/warsow 2>/dev/null || true
+ ;;
+esac
diff --git a/games/warsow-data/pkg-descr b/games/warsow-data/pkg-descr
new file mode 100644
index 000000000000..442bab3457ed
--- /dev/null
+++ b/games/warsow-data/pkg-descr
@@ -0,0 +1,7 @@
+The warsow data files.
+
+This port install the data files needed to run warsow a full free multiplayer
+first person shooter with cartoon design, using qfusion (a cool improvement to
+the Quake 2 engine)
+
+WWW: http://www.warsow.net/
diff --git a/games/warsow-data/pkg-install b/games/warsow-data/pkg-install
new file mode 100644
index 000000000000..fd65a71818bb
--- /dev/null
+++ b/games/warsow-data/pkg-install
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+[ "$2" != "POST-INSTALL" ] && exit 0
+
+config_file=$PKG_PREFIX/share/warsow/basewsw/config.cfg
+
+if ! [ -e $config_file ]; then
+ touch $config_file
+ chown root:wheel $config_file 2>/dev/null
+ chmod 666 $config_file
+fi
diff --git a/games/warsow-data/pkg-plist b/games/warsow-data/pkg-plist
new file mode 100644
index 000000000000..f6ff821cf2f6
--- /dev/null
+++ b/games/warsow-data/pkg-plist
@@ -0,0 +1,122 @@
+%%DATADIR%%/basewsw/cfgs/Medar.cfg
+%%DATADIR%%/basewsw/cfgs/pb.cfg
+%%DATADIR%%/basewsw/cfgs/nip.cfg
+%%DATADIR%%/basewsw/cfgs/jal.cfg
+%%DATADIR%%/basewsw/cfgs/dedicated_ffa.cfg
+%%DATADIR%%/basewsw/cfgs/dedicated_ctf.cfg
+%%DATADIR%%/basewsw/cfgs/ekse.cfg
+%%DATADIR%%/basewsw/cfgs/ETR.cfg
+%%DATADIR%%/basewsw/cfgs/dedicated_tdm_ctf.cfg
+%%DATADIR%%/basewsw/cfgs/dedicated_allaround.cfg
+%%DATADIR%%/basewsw/cfgs/dedicated_duel_quad.cfg
+%%DATADIR%%/basewsw/cfgs/chas.cfg
+%%DATADIR%%/basewsw/cfgs/dedicated_tdm.cfg
+%%DATADIR%%/basewsw/cfgs/dedicated_duel.cfg
+%%DATADIR%%/basewsw/cfgs/dedicated_quad.cfg
+%%DATADIR%%/basewsw/huds/inc/nip/speed_right_small.hud
+%%DATADIR%%/basewsw/huds/inc/nip/health_numbers.hud
+%%DATADIR%%/basewsw/huds/inc/nip/team_info.hud
+%%DATADIR%%/basewsw/huds/inc/nip/selected_weapon.hud
+%%DATADIR%%/basewsw/huds/inc/nip/pointing_middle.hud
+%%DATADIR%%/basewsw/huds/inc/nip/selected_item.hud
+%%DATADIR%%/basewsw/huds/inc/nip/race_timer.hud
+%%DATADIR%%/basewsw/huds/inc/nip/armor_numbers.hud
+%%DATADIR%%/basewsw/huds/inc/nip/fps_right_small.hud
+%%DATADIR%%/basewsw/huds/inc/nip/frag_counter.hud
+%%DATADIR%%/basewsw/huds/inc/nip/powerup_item.hud
+%%DATADIR%%/basewsw/huds/inc/nip/picked_up_item.hud
+%%DATADIR%%/basewsw/huds/inc/nip/clock_right_mid.hud
+%%DATADIR%%/basewsw/huds/inc/nip/ammo.hud
+%%DATADIR%%/basewsw/huds/inc/nip/help_message_center.hud
+%%DATADIR%%/basewsw/huds/inc/nip/weaponlist_up.hud
+%%DATADIR%%/basewsw/huds/inc/nip/crosshair.hud
+%%DATADIR%%/basewsw/huds/inc/nip/chasing_top.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/speed_right_small.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/health_numbers.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/clock_right_mid.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/team_info.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/armor_bar.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/selected_item.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/chasing_left.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/armor_numbers.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/health_bar.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/weaponlist_down.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/crosshair.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/fps_right_small.hud
+%%DATADIR%%/basewsw/huds/inc/1oooK/frag_counter.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/health_numbers.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/picked_up_item.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/team_info.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/speed_mid_mid.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/clock_mid_big.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/pointing_middle.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/chasing_left.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/armor_numbers.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/weaponlist_down.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/fps_right_small.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/crosshair.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/frag_counter.hud
+%%DATADIR%%/basewsw/huds/inc/ETR/scores.hud
+%%DATADIR%%/basewsw/huds/inc/health_numbers.hud
+%%DATADIR%%/basewsw/huds/inc/selected_weapon.hud
+%%DATADIR%%/basewsw/huds/inc/team_info.hud
+%%DATADIR%%/basewsw/huds/inc/pointing_middle.hud
+%%DATADIR%%/basewsw/huds/inc/health_pic_bar2.hud
+%%DATADIR%%/basewsw/huds/inc/selected_item.hud
+%%DATADIR%%/basewsw/huds/inc/net.hud
+%%DATADIR%%/basewsw/huds/inc/race_timer.hud
+%%DATADIR%%/basewsw/huds/inc/clock_right_small.hud
+%%DATADIR%%/basewsw/huds/inc/armor_numbers.hud
+%%DATADIR%%/basewsw/huds/inc/weaponlist_down.hud
+%%DATADIR%%/basewsw/huds/inc/fps_right_small.hud
+%%DATADIR%%/basewsw/huds/inc/powerup_item.hud
+%%DATADIR%%/basewsw/huds/inc/speed_right_small.hud
+%%DATADIR%%/basewsw/huds/inc/picked_up_item.hud
+%%DATADIR%%/basewsw/huds/inc/clock_right_mid.hud
+%%DATADIR%%/basewsw/huds/inc/armor_pic_bar2.hud
+%%DATADIR%%/basewsw/huds/inc/weaponlist_right.hud
+%%DATADIR%%/basewsw/huds/inc/health_pic_bar.hud
+%%DATADIR%%/basewsw/huds/inc/armor_pic_bar.hud
+%%DATADIR%%/basewsw/huds/inc/chasing_left.hud
+%%DATADIR%%/basewsw/huds/inc/ammo.hud
+%%DATADIR%%/basewsw/huds/inc/crosshair.hud
+%%DATADIR%%/basewsw/huds/inc/help_message_center.hud
+%%DATADIR%%/basewsw/huds/inc/scores.hud
+%%DATADIR%%/basewsw/huds/inc/weaponlist_left.hud
+%%DATADIR%%/basewsw/huds/default.hud
+%%DATADIR%%/basewsw/huds/nip.hud
+%%DATADIR%%/basewsw/huds/1oooK.hud
+%%DATADIR%%/basewsw/huds/hud_left.hud
+%%DATADIR%%/basewsw/huds/ETR.hud
+%%DATADIR%%/basewsw/huds/hud_right.hud
+%%DATADIR%%/basewsw/data0.pk3
+%%DATADIR%%/basewsw/data0fix1.pk3
+%%DATADIR%%/basewsw/data0fix2.pk3
+%%DATADIR%%/basewsw/dedicated_autoexec.cfg
+%%DATADIR%%/basewsw/map_wctf1.pk3
+%%DATADIR%%/basewsw/map_wdm1.pk3
+%%DATADIR%%/basewsw/map_wdm2.pk3
+%%DATADIR%%/basewsw/map_wdm5.pk3
+%%DATADIR%%/basewsw/map_wmid1.pk3
+%%DATADIR%%/basewsw/map_wmid2.pk3
+%%DATADIR%%/basewsw/map_wmid3.pk3
+%%DATADIR%%/basewsw/map_wtest1.pk3
+%%DATADIR%%/basewsw/map_wtest3.pk3
+%%DATADIR%%/basewsw/map_wtest4.pk3
+%%PORTDOCS%%%%DOCSDIR%%/Shader_Manual.rtf
+%%PORTDOCS%%%%DOCSDIR%%/bots_navigation.txt
+%%PORTDOCS%%%%DOCSDIR%%/contact.txt
+%%PORTDOCS%%%%DOCSDIR%%/changelog.txt
+%%PORTDOCS%%%%DOCSDIR%%/dedicated_server_quide.txt
+%%PORTDOCS%%%%DOCSDIR%%/demoavi.txt
+%%PORTDOCS%%%%DOCSDIR%%/huds.txt
+%%PORTDOCS%%%%DOCSDIR%%/linux_sound_sdl.txt
+%%PORTDOCS%%%%DOCSDIR%%/new_features.txt
+%%PORTDOCS%%%%DOCSDIR%%/query_protocols.txt
+@dirrm %%DATADIR%%/basewsw/huds/inc/nip
+@dirrm %%DATADIR%%/basewsw/huds/inc/ETR
+@dirrm %%DATADIR%%/basewsw/huds/inc/1oooK
+@dirrm %%DATADIR%%/basewsw/huds/inc
+@dirrm %%DATADIR%%/basewsw/huds
+@dirrm %%DATADIR%%/basewsw/cfgs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%