aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
commit9dff3523203bdda7ae358dcff3eb5a5ef3e54d33 (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /games
parent2e4b740f2cc9a250b2c6056d8706e15d3bfa9763 (diff)
downloadports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.tar.gz
ports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Notes
Notes: svn path=/head/; revision=481365
Diffstat (limited to 'games')
-rw-r--r--games/p5-Baseball-Sabermetrics/Makefile4
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile4
-rw-r--r--games/p5-Games-Bingo-Print/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/games/p5-Baseball-Sabermetrics/Makefile b/games/p5-Baseball-Sabermetrics/Makefile
index e16b22d44efd..7042524e4061 100644
--- a/games/p5-Baseball-Sabermetrics/Makefile
+++ b/games/p5-Baseball-Sabermetrics/Makefile
@@ -11,10 +11,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Baseball Statistics Module
-BUILD_DEPENDS= p5-Data-Serializer>=0.29:devel/p5-Data-Serializer \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Data-Serializer>=0.29:devel/p5-Data-Serializer \
p5-HTML-TableExtract>=2.08:www/p5-HTML-TableExtract \
p5-libwww>=5.801:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
index 61fae013216f..c2e2762a6fde 100644
--- a/games/p5-Games-Bingo-Bot/Makefile
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple class holding IRC related methods for bingo
-BUILD_DEPENDS= p5-Games-Bingo>=0:games/p5-Games-Bingo
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Games-Bingo>=0:games/p5-Games-Bingo
USES= perl5 shebangfix
SHEBANG_FILES= bin/bingobot.pl
diff --git a/games/p5-Games-Bingo-Print/Makefile b/games/p5-Games-Bingo-Print/Makefile
index a49012184018..35dc64bd474f 100644
--- a/games/p5-Games-Bingo-Print/Makefile
+++ b/games/p5-Games-Bingo-Print/Makefile
@@ -13,9 +13,9 @@ COMMENT= Games::Bingo::Print - PDF Generation Class
LICENSE= ART10
-BUILD_DEPENDS= p5-Games-Bingo>=0:games/p5-Games-Bingo \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Games-Bingo>=0:games/p5-Games-Bingo \
p5-PDFLib>=0:print/p5-PDFLib
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Perl-Critic>=0:textproc/p5-Test-Perl-Critic \
p5-Test-Pod>=0:devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:devel/p5-Test-Pod-Coverage