aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 22:27:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 22:27:05 +0000
commit9ff06b3cbf038359059e40e0db31ba0cbe996d0f (patch)
tree8583dfe71adaea6ce266633e1799cd602516b801 /games
parent25c4307da135103ea810d65f96f2f1c21e0547b4 (diff)
downloadports-9ff06b3cbf038359059e40e0db31ba0cbe996d0f.tar.gz
ports-9ff06b3cbf038359059e40e0db31ba0cbe996d0f.zip
Convert a bunch of ports from WITHOUT_NLS -> ${PORT_OPTIONS:MNLS}
While here: - trim headers - convert to new options framework
Notes
Notes: svn path=/head/; revision=316850
Diffstat (limited to 'games')
-rw-r--r--games/fgrun/Makefile18
-rw-r--r--games/ggz-client-libs/Makefile17
-rw-r--r--games/ggz-gtk-client/Makefile17
-rw-r--r--games/ggz-gtk-games/Makefile17
-rw-r--r--games/ggz-txt-client/Makefile17
-rw-r--r--games/glchess/Makefile18
-rw-r--r--games/lincity/Makefile14
-rw-r--r--games/lpairs/Makefile10
-rw-r--r--games/neverball/Makefile8
-rw-r--r--games/springlobby/Makefile20
-rw-r--r--games/typespeed/Makefile18
-rw-r--r--games/zaz/Makefile12
12 files changed, 82 insertions, 104 deletions
diff --git a/games/fgrun/Makefile b/games/fgrun/Makefile
index 3c7c57ba248a..187898efeff9 100644
--- a/games/fgrun/Makefile
+++ b/games/fgrun/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fgrun
-# Date created: 18 Oct 2008
-# Whom: buganini@gmail.com
-#
+# Created by: buganini@gmail.com
# $FreeBSD$
-#
PORTNAME= fgrun
PORTVERSION= 1.6.0
@@ -26,16 +22,18 @@ CONFIGURE_ARGS= --with-boost="${LOCALBASE}"
USE_GMAKE= yes
USE_GL= gl
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-CONFIGURE_ARGS+= --disable-nls
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+= --disable-nls
.endif
post-patch:
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} 's|SUBDIRS = src po msvc|SUBDIRS = src|' \
${WRKSRC}/Makefile.in
.endif
diff --git a/games/ggz-client-libs/Makefile b/games/ggz-client-libs/Makefile
index af9fb1a0cc59..a0746e67ab7e 100644
--- a/games/ggz-client-libs/Makefile
+++ b/games/ggz-client-libs/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: ggz-client-libs
-# Date created: Oct 8, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= ggz-client-libs
PORTVERSION= ${GGZ_VERSION}
@@ -31,12 +26,14 @@ MAN7= ggz.7
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
diff --git a/games/ggz-gtk-client/Makefile b/games/ggz-gtk-client/Makefile
index 8eb33dd6df2d..817caefadd7c 100644
--- a/games/ggz-gtk-client/Makefile
+++ b/games/ggz-gtk-client/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: ggz-gtk-client
-# Date created: Oct 22, 2005
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= ggz-gtk-client
PORTVERSION= ${GGZ_VERSION}
@@ -25,12 +20,14 @@ MAN6= ggz-gtk.6
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.pre.mk>
diff --git a/games/ggz-gtk-games/Makefile b/games/ggz-gtk-games/Makefile
index ab8852fc4285..7b73f40f94c7 100644
--- a/games/ggz-gtk-games/Makefile
+++ b/games/ggz-gtk-games/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: ggz-gtk-games
-# Date created: Feb. 19, 2006
-# Whom: yinjieh
-#
+# Created by: yinjieh
# $FreeBSD$
-#
PORTNAME= ggz-gtk-games
PORTVERSION= ${GGZ_VERSION}
@@ -24,12 +19,14 @@ USE_GGZ= client
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-install:
diff --git a/games/ggz-txt-client/Makefile b/games/ggz-txt-client/Makefile
index aebf6b871823..09d07d333ea6 100644
--- a/games/ggz-txt-client/Makefile
+++ b/games/ggz-txt-client/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: ggz-txt-client
-# Date created: Oct 8, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= ggz-txt-client
PORTVERSION= ${GGZ_VERSION}
@@ -23,12 +18,14 @@ MAN6= ggz-txt.6
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-install:
diff --git a/games/glchess/Makefile b/games/glchess/Makefile
index 8f5b3ec8af36..6ace8df4e212 100644
--- a/games/glchess/Makefile
+++ b/games/glchess/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: glchess
-# Date created: Wed Jul 18 08:35:56 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= glchess
PORTVERSION= 1.0.6
@@ -23,12 +19,14 @@ USE_PYDISTUTILS= yes
GCONF_SCHEMAS= glchess.schemas
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment"
-CONFIGURE_ARGS+= --disable-nls
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USES+= gettext
+.else
+PLIST_SUB+= NLS="@comment"
+CONFIGURE_ARGS+= --disable-nls
.endif
post-patch:
@@ -49,7 +47,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/po/$$lang.mo \
${PREFIX}/share/locale/$$lang/LC_MESSAGES/glchess.mo ; \
done)
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ChangeLog README TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/games/lincity/Makefile b/games/lincity/Makefile
index 2555d8ffc660..e18e55b68fb0 100644
--- a/games/lincity/Makefile
+++ b/games/lincity/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lincity
-# Date created: 13 Feb 1997
-# Whom: Julian Assange
-#
+# Created by: Julian Assange
# $FreeBSD$
-#
PORTNAME= lincity
PORTVERSION= 1.13.1
@@ -14,6 +10,8 @@ MASTER_SITES= SF/${PORTNAME}/Lincity%20Development%20Source/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Rich city simulation game for X
+OPTIONS_DEFINE= SVGALIB NLS
+
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
.if ${CC} == "clang"
@@ -27,10 +25,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN6= lincity.6
+.include <bsd.port.options.mk>
+
pre-configure:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' ${WRKSRC}/readpng.c
-.if defined(WITH_SVGALIB)
+.if ${PORT_OPTIONS:MSVGALIB}
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+= --without-x
PLIST_SUB= PROG="bin/lincity"
@@ -40,7 +40,7 @@ CONFIGURE_ARGS+= --without-svga
PLIST_SUB= PROG="bin/xlincity"
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/games/lpairs/Makefile b/games/lpairs/Makefile
index f0291129dfdc..f3a9a41df5fd 100644
--- a/games/lpairs/Makefile
+++ b/games/lpairs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lpairs
-# Date created: 12 Sep 2008
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= lpairs
PORTVERSION= 1.0.4
@@ -19,7 +15,9 @@ USE_SDL= sdl
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USES+= gettext
CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
diff --git a/games/neverball/Makefile b/games/neverball/Makefile
index 64553dcbd0f7..c744a36d1c9d 100644
--- a/games/neverball/Makefile
+++ b/games/neverball/Makefile
@@ -25,7 +25,9 @@ MAKE_JOBS_SAFE= yes
PORTDOCS= CHANGES COPYING README
MAN6= neverball.6 neverputt.6
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
MAKE_ENV+= ENABLE_NLS=1
LOCALE_DIRS= ca de es fi fr lv nn
@@ -55,7 +57,7 @@ do-install:
${PREFIX}/share/pixmaps/${f}.png
@${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/
.endfor
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
. for ii in ${LOCALE_DIRS}
@${MKDIR} ${PREFIX}/share/locale/${ii}/LC_MESSAGES
@${INSTALL_DATA} ${WRKSRC}/locale/${ii}/LC_MESSAGES/*.mo \
@@ -63,7 +65,7 @@ do-install:
. endfor
.endif
-.ifndef (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
. for i in ${PORTDOCS}
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index 4988795755c9..489bca5a7853 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: springlobby
-# Date created: 02 Sep 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= springlobby
PORTVERSION= 0.143
@@ -28,12 +24,14 @@ MAKE_JOBS_SAFE= yes
PORTDOCS= *
-OPTIONS= TORRENT "Support automatic content downloads via torrent" on \
- SOUND "Enable sound" on
+OPTIONS_DEFINE= TORRENT SOUND DOCS NLS
+OPTIONS_DEFAULT= TORRENT SOUND
+TORRENT_DESC= Support automatic content downloads via torrent
+SOUND_DESC= Enable sound
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -41,13 +39,13 @@ CMAKE_ARGS+= -DOPTION_TRANSLATION_SUPPORT:BOOL=OFF
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(WITHOUT_TORRENT)
+.if ${PORT_OPTIONS:MTORRENT}
LIB_DEPENDS+= torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15
.else
CMAKE_ARGS+= -DOPTION_TORRENT_SYSTEM:BOOL=OFF
.endif
-.if !defined(WITHOUT_SOUND)
+.if ${PORT_OPTIONS:MSOUND}
USE_OPENAL= al
.else
CMAKE_ARGS+= -DOPTION_SOUND:BOOL=OFF
@@ -57,7 +55,7 @@ post-patch:
@${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
${WRKSRC}/src/utils/curlhelper.h \
${WRKSRC}/src/utils/downloader.cpp
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/install.*FILES.*share\/doc/ d' \
${WRKSRC}/CMakeLists.txt
.endif
diff --git a/games/typespeed/Makefile b/games/typespeed/Makefile
index ffba651e1041..65f1a6baad31 100644
--- a/games/typespeed/Makefile
+++ b/games/typespeed/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: typespeed
-# Date created: 06 September 2003
-# Whom: refugee
-#
+# Created by: refugee
# $FreeBSD$
-#
PORTNAME= typespeed
PORTVERSION= 0.6.5
@@ -28,12 +24,14 @@ SUB_FILES= pkg-install pkg-deinstall
SUB_LIST= SCOREDIR="${SCOREDIR}" SCOREFILE="${SCOREFILE}" WRKSRC="${WRKSRC}"
MAN1= typespeed.1
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -52,7 +50,7 @@ do-install:
${MKDIR} ${DATADIR}/words
${FIND} ${WRKSRC}/words/ -name "words.*" -type f \
-exec ${INSTALL_DATA} {} ${DATADIR}/words \;
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
.for i in de_DE fr_FR it
${MKDIR} ${PREFIX}/share/locale/${i}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/po/${i}.gmo \
diff --git a/games/zaz/Makefile b/games/zaz/Makefile
index fcc534e1ef7d..61693d1798cf 100644
--- a/games/zaz/Makefile
+++ b/games/zaz/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zaz
-# Date created: 25 Aug 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= zaz
PORTVERSION= 1.0.0
@@ -32,7 +28,9 @@ CONFIGURE_ARGS= --with-icondir="${PREFIX}/share/pixmaps"
PORTDOCS= *
# Unconditially disable NLS for now: the game segfaults with 8bit locales
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -43,7 +41,7 @@ PLIST_SUB+= NLS="@comment "
post-patch:
@${REINPLACE_CMD} -e '/^zazdocdir =/ s|$${prefix}/doc|$${prefix}/share/doc|' \
${WRKSRC}/Makefile.in
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/^install-data-am:/ s|install-dist_docDATA||' \
${WRKSRC}/Makefile.in
.endif