aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-28 09:12:04 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-28 09:12:04 +0000
commitaea8084dfb37d03cd4c2cea4addcd0ce7bbb45a2 (patch)
treeb0744fbcc5dfe61e07c61877442379c2eb4429db /games
parentff4e0e08ddfa72eb724f64f3c346f0eaa4287931 (diff)
downloadports-aea8084dfb37d03cd4c2cea4addcd0ce7bbb45a2.tar.gz
ports-aea8084dfb37d03cd4c2cea4addcd0ce7bbb45a2.zip
games/alephone: unbreak build with Clang 6 (C++14 by default)
In file included from csdialogs_sdl.cpp:29: In file included from ../../Source_Files/Misc/sdl_dialogs.h:33: In file included from /usr/local/include/boost/function.hpp:70: In file included from /usr/local/include/boost/preprocessor/iteration/detail/iter/forward1.hpp:47: In file included from /usr/local/include/boost/function/detail/function_iterate.hpp:14: In file included from /usr/local/include/boost/function/detail/maybe_include.hpp:15: /usr/local/include/boost/function/function_template.hpp:158:33: error: called object type 'nullptr_t' is not a function or function pointer BOOST_FUNCTION_RETURN((*f)(BOOST_FUNCTION_ARGS)); ^~~~ /usr/local/include/boost/function/function_template.hpp:80:36: note: expanded from macro 'BOOST_FUNCTION_RETURN' # define BOOST_FUNCTION_RETURN(X) X ^ /usr/local/include/boost/function/function_template.hpp:935:53: note: in instantiation of member function 'boost::detail::function::void_function_obj_invoker0<nullptr_t, void>::invoke' requested here { { &manager_type::manage }, &invoker_type::invoke }; ^ /usr/local/include/boost/function/function_template.hpp:724:13: note: in instantiation of function template specialization 'boost::function0<void>::assign_to<nullptr_t>' requested here this->assign_to(f); ^ /usr/local/include/boost/function/function_template.hpp:1073:5: note: in instantiation of function template specialization 'boost::function0<void>::function0<nullptr_t>' requested here base_type(f) ^ ../../Source_Files/Misc/sdl_widgets.h:1082:5: note: in instantiation of function template specialization 'boost::function<void ()>::function<nullptr_t>' requested here , m_callback (NULL) ^ interface.cpp:3114:25: error: non-constant-expression cannot be narrowed from type 'int' to 'Sint16' (aka 'short') in initializer list [-Wc++11-narrowing] SDL_Rect dst_rect = { (s->w - 640)/2, (s->h - 480)/2, 640, 480 }; ^~~~~~~~~~~~~~ interface.cpp:3114:25: note: insert an explicit cast to silence this issue SDL_Rect dst_rect = { (s->w - 640)/2, (s->h - 480)/2, 640, 480 }; ^~~~~~~~~~~~~~ static_cast<Sint16>( )
Notes
Notes: svn path=/head/; revision=483246
Diffstat (limited to 'games')
-rw-r--r--games/alephone/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index dde1b4abff78..ab63fa5e1dd4 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -14,6 +14,7 @@ COMMENT= The open source version of Bungie's Marathon game
BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:devel/boost-libs
USES= gmake localbase pkgconfig tar:bzip2
+USE_CXXSTD= gnu++98
USE_SDL= image net sdl ttf
USE_GL= yes
GNU_CONFIGURE= yes