aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-10-05 16:47:52 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-10-05 16:47:52 +0000
commitc03df2a8c84514a3d9f3544e55cb472e7a24ab25 (patch)
treeba98bf1504b756292967f53f2372509c8661eea5 /games
parent9e7b6e10621da2607f5ce44024180fac3e5e2361 (diff)
downloadports-c03df2a8c84514a3d9f3544e55cb472e7a24ab25.tar.gz
ports-c03df2a8c84514a3d9f3544e55cb472e7a24ab25.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/amphetamine/Makefile10
-rw-r--r--games/amphetamine/distinfo2
-rw-r--r--games/amphetamine/files/patch-aa48
3 files changed, 28 insertions, 32 deletions
diff --git a/games/amphetamine/Makefile b/games/amphetamine/Makefile
index 3197042c8409..3a695822b8cd 100644
--- a/games/amphetamine/Makefile
+++ b/games/amphetamine/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amphetamine
-PORTVERSION= 0.8.8
+PORTVERSION= 0.8.9
CATEGORIES= games
MASTER_SITES= http://www.dataway.ch/~lukasl/amph/files/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -14,11 +14,11 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= sobomax@FreeBSD.org
-LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl10
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12
DATAVERSION= 0.8.6
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
USE_XPM= yes
@@ -27,7 +27,7 @@ USE_GMAKE= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
post-install:
- @(cd ${WRKDIR}/amph && ${TAR} -c -f - * ) \
- | (cd ${PREFIX}/share/amph && ${TAR} --unlink -x -f -)
+ @(cd ${WRKDIR}/amph && ${TAR} -c -f - * ) \
+ | (cd ${PREFIX}/share/amph && ${TAR} --unlink -x -f -)
.include <bsd.port.mk>
diff --git a/games/amphetamine/distinfo b/games/amphetamine/distinfo
index 8e36c5f60452..78ef51d79579 100644
--- a/games/amphetamine/distinfo
+++ b/games/amphetamine/distinfo
@@ -1,2 +1,2 @@
-MD5 (amphetamine-0.8.8.tar.bz2) = fa4bfc4ce6a7a8b23038d29f9fbfc640
+MD5 (amphetamine-0.8.9.tar.bz2) = d5a727874cddb6447331e5834be16826
MD5 (amphetamine-data-0.8.6.tar.bz2) = ed5f2a05b76918d3a624b38ba37dda0b
diff --git a/games/amphetamine/files/patch-aa b/games/amphetamine/files/patch-aa
index 42b7c6a08b4a..da6c08b725e9 100644
--- a/games/amphetamine/files/patch-aa
+++ b/games/amphetamine/files/patch-aa
@@ -1,24 +1,29 @@
---- Makefile.orig Sun Feb 27 05:45:57 2000
-+++ Makefile Mon Apr 30 01:16:01 2001
-@@ -5,14 +5,14 @@
- # User settings
+
+$FreeBSD$
+
+--- Makefile.orig Wed Mar 28 12:11:39 2001
++++ Makefile Fri Oct 5 19:43:34 2001
+@@ -3,8 +3,8 @@
#===============
+ # Install Paths
-PREFIX := /usr/local
-INSTALL_DIR := ${PREFIX}/games/amph
-+#PREFIX := /usr/local
++PREFIX ?= /usr/local
+INSTALL_DIR := ${PREFIX}/share/amph
- # Linux or SPARC
- TARGET_ARCH := Linux
-
+ # Endianess:
+ # LITTLE_ENDIAN (for Intel)
+@@ -14,7 +14,7 @@
+ # Libraries
USE_LIB_XPM := TRUE
--SDL_HEADERS := `sdl-config --cflags`
-+SDL_HEADERS := `$(SDL_CONFIG) --cflags`
- # For framerate dislpay (doesn't work yet)
- USE_LIB_SGE := FLASE
-@@ -24,7 +24,7 @@
+-SDL_CONFIG := sdl-config
++SDL_CONFIG ?= sdl-config
+ SDL_HEADERS := $(shell $(SDL_CONFIG) --cflags)
+ SDL_LIBS := $(shell $(SDL_CONFIG) --libs)
+
+@@ -27,7 +27,7 @@
# Directories to search for header files
@@ -27,7 +32,7 @@
# makemake variables
-@@ -34,13 +34,13 @@
+@@ -37,13 +37,13 @@
# C
@@ -45,17 +50,8 @@
%.o : %.cpp
${CXX} ${CPPFLAGS} -c $< ${CXXFLAGS} -o $@
-@@ -65,7 +65,7 @@
-
- # linker
-
--LOADLIBES := -lm `sdl-config --libs`
-+LOADLIBES := -lm `$(SDL_CONFIG) --libs`
-
- ifeq ($(USE_LIB_XPM),TRUE)
+@@ -76,7 +76,7 @@
LOADLIBES := $(LOADLIBES) -lXpm -lXt
-@@ -75,7 +75,7 @@
- LOADLIBES := $(LOADLIBES) -lSGE
endif
-LDFLAGS = -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib
@@ -63,7 +59,7 @@
.PHONY : default
default : amph
-@@ -83,9 +83,9 @@
+@@ -84,9 +84,9 @@
.PHONY : install
install: amph
@./mkinstalldirs ${INSTALL_DIR}
@@ -76,7 +72,7 @@
# This is what makemake added
-@@ -203,7 +203,7 @@
+@@ -204,7 +204,7 @@
./src/Surface.o: ./src/AmpHead.hpp ./src/Clut.hpp ./src/ConstVal.hpp ./src/Graphfil.hpp ./src/Shape.hpp ./src/ShapeLd.hpp ./src/Surface.hpp ./src/System.hpp /usr/include/limits.h /usr/include/math.h /usr/include/stdio.h /usr/include/stdlib.h