aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
commitc7c32639cce504dbfefa9d1a09034d60600acaca (patch)
tree542278ecb4449b3df78960fd5f6cf7d8be50914f /games
parent42aab3eb75f5152697ee03e5e8457ce58906e2c1 (diff)
downloadports-c7c32639cce504dbfefa9d1a09034d60600acaca.tar.gz
ports-c7c32639cce504dbfefa9d1a09034d60600acaca.zip
Convert my ports to new options helpers
Notes
Notes: svn path=/head/; revision=395231
Diffstat (limited to 'games')
-rw-r--r--games/hex-a-hop/Makefile43
-rw-r--r--games/trophy/Makefile8
-rw-r--r--games/warmux/Makefile48
3 files changed, 31 insertions, 68 deletions
diff --git a/games/hex-a-hop/Makefile b/games/hex-a-hop/Makefile
index 512d351a25ed..b554a9a3cd23 100644
--- a/games/hex-a-hop/Makefile
+++ b/games/hex-a-hop/Makefile
@@ -20,41 +20,28 @@ LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= PANGO SOUND NLS DEBUG
OPTIONS_DEFAULT= SOUND
+
+DEBUG_CONFIGURE_ENABLE= debug
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENV= ac_cv_header_libintl_h=yes
+NLS_CONFIGURE_ENV_OFF= ac_cv_header_libintl_h=no
+NLS_LDFLAGS= -lintl
+
PANGO_DESC= Use sdl_pango instead of sdl_ttf
+PANGO_USE= SDL=pango
+PANGO_USE_OFF= SDL=ttf
+PANGO_CONFIGURE_ENABLE= sdlttf
+
SOUND_DESC= Sound support
+SOUND_USE= SDL=mixer
+SOUND_CONFIGURE_ENABLE= sound
DESKTOP_ENTRIES="Hex-a-Hop" "${COMMENT}" \
"${DATADIR}/icon.bmp" \
"hex-a-hop" "LogicGame;Game;" false
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+=--disable-debug
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ENV+= ac_cv_header_libintl_h=yes
-LDFLAGS+= -lintl
-.else
-CONFIGURE_ENV+= ac_cv_header_libintl_h=no
-.endif
-
-.if ${PORT_OPTIONS:MPANGO}
-USE_SDL+= pango
-CONFIGURE_ARGS+=--disable-sdlttf
-.else
-USE_SDL+= ttf
-.endif
-
-.if ${PORT_OPTIONS:MSOUND}
-USE_SDL+= mixer
-.else
-CONFIGURE_ARGS+=--disable-sound
-.endif
-
-post-patch: .SILENT
+post-patch:
${REINPLACE_CMD} -E '/CFLAGS|CXXFLAGS/s/-g//' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index bb13f7bc9fbc..84021081c2d3 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -24,16 +24,12 @@ PORTDOCS= AUTHORS COPYING ChangeLog README TODO
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-pre-configure:
+post-patch:
${REINPLACE_CMD} -e "/^icondir =/s,icons,pixmaps," \
${WRKSRC}/resources/Makefile.in
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR} && \
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
index 467415a1065d..ab69c7c6000e 100644
--- a/games/warmux/Makefile
+++ b/games/warmux/Makefile
@@ -14,21 +14,30 @@ COMMENT= Turn-based artillery game with free software mascots
LIB_DEPENDS= libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26 \
libcurl.so:${PORTSDIR}/ftp/curl
-CONFLICTS_INSTALL= wormux-*
-
GNU_CONFIGURE= yes
CONFIGURE_ENV= cxx_present=yes
USES= dos2unix gmake pkgconfig tar:bzip2
USE_SDL= sdl image mixer ttf gfx net
DOS2UNIX_GLOB= fixed_class.h
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:R}
+
OPTIONS_DEFINE= FRIBIDI SERVER NLS DEBUG
+OPTIONS_SUB= yes
+
+DEBUG_CONFIGURE_ENABLE= debug logging
+
FRIBIDI_DESC= Enable bi-directional unicode support
-SERVER_DESC= Enable dedicated server
+FRIBIDI_LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi
+FRIBIDI_CONFIGURE_ENABLE= fribidi
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:R}
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+NLS_CPPFLAGS+= -I${LOCALBASE}/include
+NLS_LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
+SERVER_DESC= Enable dedicated server
+SERVER_CONFIGURE_ENABLE= servers
post-patch:
${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/Makefile.in \
@@ -36,33 +45,4 @@ post-patch:
${REINPLACE_CMD} -e "s,warmux_files.desktop,," ${WRKSRC}/data/Makefile.in
${FIND} -d ${WRKSRC}/data/ -name "*.*~" -delete
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug \
- --enable-logging
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSERVER}
-PLIST_SUB+= SERVER=""
-CONFIGURE_ARGS+= --enable-servers
-.else
-PLIST_SUB+= SERVER="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MFRIBIDI}
-LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
-CONFIGURE_ARGS+= --enable-fribidi
-.else
-CONFIGURE_ARGS+= --disable-fribidi
-.endif
-
.include <bsd.port.mk>