aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-06-16 04:45:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-06-16 04:45:44 +0000
commitcfb91fbfaa09e5c0504362851dd20d2b64b146dd (patch)
treedaa1200b2fd85a94b17c4708656f79eb6f2cb99a /games
parent7f242f3ed9bb3b2ae80a25deb9c8b1d6126c2637 (diff)
downloadports-cfb91fbfaa09e5c0504362851dd20d2b64b146dd.tar.gz
ports-cfb91fbfaa09e5c0504362851dd20d2b64b146dd.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/openttd/Makefile2
-rw-r--r--games/openttd/files/patch-Makefile29
2 files changed, 29 insertions, 2 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 165785154a03..ba4202c6d5fd 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -34,8 +34,6 @@ MAKE_ARGS+= DEDICATED=1
.endif
post-extract:
- @${REINPLACE_CMD} -e 's|-O2 $$(WARNING_DISPLAY)|${CFLAGS} $$(WARNING_DISPLAY)|' \
- ${WRKSRC}/Makefile
.if defined(WITH_DEDICATED_SERVER_ONLY)
@${REINPLACE_CMD} -e 's|^WITH_SDL|#WITH_SDL|' ${WRKSRC}/makefiledir/Makefile.libdetection
.endif
diff --git a/games/openttd/files/patch-Makefile b/games/openttd/files/patch-Makefile
new file mode 100644
index 000000000000..21d9e648b6a4
--- /dev/null
+++ b/games/openttd/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig Mon Mar 27 02:32:00 2006
++++ Makefile Fri Jun 16 04:30:11 2006
+@@ -240,7 +240,7 @@
+ ifndef WIN32
+ ifndef MORPHOS
+ ifndef OSX
+- LDFLAGS+=-lpthread
++ LDFLAGS+=${PTHREAD_LIBS}
+ endif
+ endif
+ endif
+@@ -297,7 +297,7 @@
+ # GNU make can only test for (in)equality
+ # this is a workaround to test for >=
+ ifeq ($(shell expr $(CC_VERSION) \>= 29), 1)
+- CFLAGS += -O -Wall -Wno-multichar -Wsign-compare -Wstrict-prototypes -Wundef
++ CFLAGS += -Wall -Wno-multichar -Wsign-compare -Wstrict-prototypes -Wundef
+ CFLAGS += -Wwrite-strings -Wpointer-arith
+ endif
+ ifeq ($(shell expr $(CC_VERSION) \>= 30), 1)
+@@ -350,8 +350,6 @@
+ ifdef MORPHOS
+ BASECFLAGS += -I/gg/os-include -O2 -noixemul -fstrict-aliasing -fexpensive-optimizations
+ BASECFLAGS += -mcpu=604 -fno-inline -mstring -mmultiple
+-else
+-BASECFLAGS += -O2
+ endif
+ ifndef PROFILE
+ ifndef IRIX