aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-09 23:29:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-09 23:29:36 +0000
commite3467398dafcc1325f4d9528993b95670e9e3eb2 (patch)
tree1e36ace61b152668133c364466644a5d67bd9986 /games
parent1108488ebad588d6187fda8ebae1af1b7c7a1fd3 (diff)
downloadports-e3467398dafcc1325f4d9528993b95670e9e3eb2.tar.gz
ports-e3467398dafcc1325f4d9528993b95670e9e3eb2.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/koth/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/koth/Makefile b/games/koth/Makefile
index 470f2806bfba..13c591ab9817 100644
--- a/games/koth/Makefile
+++ b/games/koth/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= ggi.2:${PORTSDIR}/graphics/libggi
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
PLIST_FILES= bin/kclever-ai bin/kmoron-ai bin/koth bin/koths
MAN6= kclever-ai.6 kmoron-ai.6 koth.6 koths.6
@@ -25,4 +26,7 @@ MAN6= kclever-ai.6 kmoron-ai.6 koth.6 koths.6
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lggi|-lggi ${PTHREAD_LIBS}|' ${WRKSRC}/configure
+
.include <bsd.port.mk>