aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-02 00:01:09 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-02 00:01:09 +0000
commitf70d809275aae3c31736ab8b6ac40d524e21444d (patch)
tree439b1324ca4ae4415a91c121755ffeba06145180 /games
parent657a8390f9be5be58afe69682c7be4a4321b1c34 (diff)
downloadports-f70d809275aae3c31736ab8b6ac40d524e21444d.tar.gz
ports-f70d809275aae3c31736ab8b6ac40d524e21444d.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/pydance/Makefile14
-rw-r--r--games/pydance/distinfo6
-rw-r--r--games/pydance/files/patch-fontfx.py13
-rw-r--r--games/pydance/pkg-plist8
4 files changed, 20 insertions, 21 deletions
diff --git a/games/pydance/Makefile b/games/pydance/Makefile
index 6806a79a564b..bab7fff6b7be 100644
--- a/games/pydance/Makefile
+++ b/games/pydance/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= pydance
-PORTVERSION= 1.0.3
-PORTREVISION= 4
+PORTVERSION= 1.1.0
CATEGORIES= games
-MASTER_SITES= \
+MASTER_SITES= http://people.freebsd.org/~sylvio/pydance/ \
+ http://icculus.org/pyddr/ \
http://offload1.icculus.org/pyddr/ \
- http://www.icculus.org/pyddr/ \
http://www.informatik.uni-frankfurt.de/~polzer/distfiles/
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz ${SONGS}
DIST_SUBDIR= pydance
@@ -27,13 +26,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_NOEGGINFO= yes
-.if !defined(WITHOUT_PYDANCE_SONGS)
PLIST_SUB= SONGS=""
SONGS= forkbomb.ogg forkbomb.dance forkbomb-bg.jpg forkbomb-banner.png 6jan.ogg 6jan.dance 6jan-bg.jpg 6jan-banner.png synrg.ogg synrg.dance synrg-bg.png pydance-cdtitle.png
-.else
-PLIST_SUB= SONGS="@comment "
-SONGS=
-.endif
SUB_FILES= pkg-message
@@ -56,10 +50,8 @@ do-install:
cd ${WRKSRC} && ${INSTALL_MAN} docs/man/pydance.6 ${MANPREFIX}/man/man6/
${LN} -sf ${PREFIX}/share/games/pydance/pydance.py ${PREFIX}/bin/pydance
cd ${WRKSRC} && ${INSTALL_DATA} pydance.posix.cfg ${PREFIX}/etc/pydance.cfg.sample
-.if !defined(WITHOUT_PYDANCE_SONGS)
for SONG in ${SONGS}; do ${INSTALL_DATA} ${_DISTDIR}/$$SONG ${PREFIX}/share/games/pydance/songs; done
${MV} ${PREFIX}/share/games/pydance/songs/pydance-cdtitle.png ${PREFIX}/share/games/pydance/songs/pydance.png
-.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/games/pydance/distinfo b/games/pydance/distinfo
index 2d48859ad61a..5d5ef3f9924c 100644
--- a/games/pydance/distinfo
+++ b/games/pydance/distinfo
@@ -1,6 +1,6 @@
-MD5 (pydance/pydance-1.0.3.tar.gz) = 070ba1b4f1b11bc7d8959941064051e7
-SHA256 (pydance/pydance-1.0.3.tar.gz) = 4100fc7cc8e029434c6f2ca1e4d417543e6e1a546032bba0b63e127cc1e73cfc
-SIZE (pydance/pydance-1.0.3.tar.gz) = 6531541
+MD5 (pydance/pydance-1.1.0.tar.gz) = 04d65c365a0b02df9506170dae6294b8
+SHA256 (pydance/pydance-1.1.0.tar.gz) = 665decdb3d9e0b2feee1e1d84d443277a8a5ce5c9a07c21056fe6e76ffc96d30
+SIZE (pydance/pydance-1.1.0.tar.gz) = 8950798
MD5 (pydance/forkbomb.ogg) = 0ca7527a0b792fe0b597322d69e675d7
SHA256 (pydance/forkbomb.ogg) = 11a771a5cfa32f8f298e6e91311b1c947848cbdc068402f674c489dad2c74a09
SIZE (pydance/forkbomb.ogg) = 1418973
diff --git a/games/pydance/files/patch-fontfx.py b/games/pydance/files/patch-fontfx.py
index a562a1e8105a..3bfa9e9ebe8a 100644
--- a/games/pydance/files/patch-fontfx.py
+++ b/games/pydance/files/patch-fontfx.py
@@ -1,6 +1,6 @@
---- fontfx.py.orig Wed Feb 14 02:45:59 2007
-+++ fontfx.py Wed Feb 14 02:50:23 2007
-@@ -144,7 +144,7 @@
+--- fontfx.py.orig 2008-12-30 13:04:11.000000000 -0200
++++ fontfx.py 2010-02-05 23:37:31.000000000 -0200
+@@ -141,7 +141,7 @@
self.bgcolor = bgcolor
self.offcolor = [c^40 for c in color]
self.notcolor = [c^0xFF for c in color]
@@ -9,13 +9,12 @@
self.text.set_colorkey(1, RLEACCEL)
self.outline = self.textHollow(font, message, color)
self.bar = pygame.Surface(self.text.get_size())
-@@ -155,7 +155,7 @@
+@@ -152,7 +152,7 @@
self.ratio = width / 100.0
-
+
def textHollow(self, font, message, fontcolor):
-- base = font.render(message, 0, fontcolor, self.notcolor)
+- base = font.render(message, False, fontcolor, self.notcolor)
+ base = font.render(message, True, fontcolor, self.notcolor)
size = base.get_width() + 2, base.get_height() + 2
img = pygame.Surface(size, 16)
img.fill(self.notcolor)
-
diff --git a/games/pydance/pkg-plist b/games/pydance/pkg-plist
index 56e4a4715410..39f84f4544c8 100644
--- a/games/pydance/pkg-plist
+++ b/games/pydance/pkg-plist
@@ -27,11 +27,13 @@ share/games/pydance/endless.py
share/games/pydance/error.py
share/games/pydance/fileparsers.py
share/games/pydance/fontfx.py
+share/games/pydance/fonttheme.py
share/games/pydance/games.py
share/games/pydance/gameselect.py
share/games/pydance/gfxtheme.py
share/games/pydance/grades.py
share/games/pydance/gradescreen.py
+share/games/pydance/i18n.py
share/games/pydance/images/bg.png
share/games/pydance/images/button.png
share/games/pydance/images/courseselect-bg.png
@@ -39,6 +41,7 @@ share/games/pydance/images/endless-bg.png
share/games/pydance/images/error-bg.png
share/games/pydance/images/gameselect-bg.png
share/games/pydance/images/go.png
+share/games/pydance/images/go_ca.png
share/games/pydance/images/grade-bg.png
share/games/pydance/images/indicator.png
share/games/pydance/images/menu-bg.png
@@ -54,6 +57,7 @@ share/games/pydance/images/rating-d.png
share/games/pydance/images/rating-ee.png
share/games/pydance/images/rating-f.png
share/games/pydance/images/ready.png
+share/games/pydance/images/ready_ca.png
share/games/pydance/images/select-3p.png
share/games/pydance/images/select-4p.png
share/games/pydance/images/select-5p.png
@@ -128,6 +132,9 @@ share/games/pydance/themes/dj/djenzay/rankings/secondchances.ogg
share/games/pydance/themes/dj/djenzay/rankings/sure.ogg
share/games/pydance/themes/dj/djenzay/rankings/tobe.ogg
share/games/pydance/themes/dj/none/djtheme.cfg
+share/games/pydance/themes/font/default.cfg
+share/games/pydance/themes/font/VL-PGothic-Regular.ttf
+share/games/pydance/themes/font/VL PGothic.cfg
share/games/pydance/themes/gfx/32x32/ddresque.zip
share/games/pydance/themes/gfx/32x32/default/arr_c_c_0.png
share/games/pydance/themes/gfx/32x32/default/arr_c_c_1.png
@@ -364,6 +371,7 @@ share/games/pydance/util.py
@dirrm share/games/pydance/themes/gfx/32x32/default
@dirrm share/games/pydance/themes/gfx/32x32
@dirrm share/games/pydance/themes/gfx
+@dirrm share/games/pydance/themes/font
@dirrm share/games/pydance/themes/dj/none
@dirrm share/games/pydance/themes/dj/djenzay/rankings
@dirrm share/games/pydance/themes/dj/djenzay/positive