aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-02-28 02:30:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-02-28 02:30:24 +0000
commit0b2a25f03d70915bde472089e7180cf37749a887 (patch)
treec942b535c6c32716080f3fa216c4de030187ccf2 /games
parent55d7c6ad26f6215787b49508414825a2839070c6 (diff)
downloadports-0b2a25f03d70915bde472089e7180cf37749a887.tar.gz
ports-0b2a25f03d70915bde472089e7180cf37749a887.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/mkhexgrid/Makefile10
-rw-r--r--games/mkhexgrid/files/patch-Makefile14
-rw-r--r--games/mkhexgrid/files/patch-mkhexgrid.cpp11
3 files changed, 27 insertions, 8 deletions
diff --git a/games/mkhexgrid/Makefile b/games/mkhexgrid/Makefile
index eb5047ed691e..42374b09d6e6 100644
--- a/games/mkhexgrid/Makefile
+++ b/games/mkhexgrid/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mkhexgrid
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://www.nomic.net/~uckelman/mkhexgrid/releases/ \
http://aaron.daltons.ca/freebsd/
@@ -24,18 +24,12 @@ USE_GMAKE= yes
PORTDOCS= mkhexgrid.html
PLIST_FILES= bin/mkhexgrid
-post-patch:
- @${REINPLACE_CMD} -e 's:^LDFLAGS=:LDFLAGS=-L${LOCALBASE}/lib :' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's:^CPPFLAGS=:CPPFLAGS=-I${LOCALBASE}/include :' ${WRKSRC}/Makefile
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mkhexgrid ${PREFIX}/bin
-
-post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/mkhexgrid.html ${DOCSDIR}
- @${ECHO} "Documentation has been installed in ${DOCSDIR}."
+ @${ECHO} "Documentation has been installed into ${DOCSDIR}."
.endif
.include <bsd.port.mk>
diff --git a/games/mkhexgrid/files/patch-Makefile b/games/mkhexgrid/files/patch-Makefile
new file mode 100644
index 000000000000..bc096b4d1aec
--- /dev/null
+++ b/games/mkhexgrid/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig 2007-01-10 16:37:42.000000000 +0300
++++ Makefile 2009-02-28 05:17:28.000000000 +0300
+@@ -8,9 +8,8 @@
+ DISTDIR=mkhexgrid-$(VERSION)
+ RPMDIR=/home/uckelman/rpmbuild
+
+-CC=g++
+-CPPFLAGS=-c -g -O2 -W -Wall -DVERSION='"$(VERSION)"'
+-LDFLAGS=-lm -lstdc++ -lgd
++CPPFLAGS=-I${LOCALBASE}/include -c -W -Wall -DVERSION='"$(VERSION)"'
++LDFLAGS=-L${LOCALBASE}/lib -lm -lstdc++ -lgd
+
+ FILES=grid.h \
+ grid.cpp \
diff --git a/games/mkhexgrid/files/patch-mkhexgrid.cpp b/games/mkhexgrid/files/patch-mkhexgrid.cpp
new file mode 100644
index 000000000000..52923ce098e7
--- /dev/null
+++ b/games/mkhexgrid/files/patch-mkhexgrid.cpp
@@ -0,0 +1,11 @@
+--- mkhexgrid.cpp.orig 2007-01-10 16:37:42.000000000 +0300
++++ mkhexgrid.cpp 2009-02-28 05:14:36.000000000 +0300
+@@ -148,7 +148,7 @@
+ Grid g(opt);
+ g.draw();
+ }
+- catch (exception &e) {
++ catch (std::exception &e) {
+ cerr << argv[0] << ": " << e.what() << endl;
+ exit(1);
+ }