aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-24 01:09:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-24 01:09:04 +0000
commit979f2e64d107dcccfc5498a55a611a45225061c0 (patch)
tree9b7a2226bf357f3b8ce71b7a062ba014eec0f9e3 /games
parent1f4a77507a09e9f0b1b2ae1306c6367f45152c4a (diff)
downloadports-979f2e64d107dcccfc5498a55a611a45225061c0.tar.gz
ports-979f2e64d107dcccfc5498a55a611a45225061c0.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/tmw/Makefile32
-rw-r--r--games/tmw/distinfo2
-rw-r--r--games/tmw/files/patch-configure11
-rw-r--r--games/tmw/pkg-descr12
-rw-r--r--games/tmw/pkg-plist110
6 files changed, 168 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ade679d68564..c4c059ef96ab 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -557,6 +557,7 @@
SUBDIR += tinymux
SUBDIR += tkmoo
SUBDIR += tksol
+ SUBDIR += tmw
SUBDIR += tomatoes
SUBDIR += tome
SUBDIR += toppler
diff --git a/games/tmw/Makefile b/games/tmw/Makefile
new file mode 100644
index 000000000000..404b17ace092
--- /dev/null
+++ b/games/tmw/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tmw
+# Date created: 12 Oktober 2005
+# Whom: Tobias Gion
+#
+# $FreeBSD$
+#
+
+PORTNAME= tmw
+PORTVERSION= 0.0.17
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= themanaworld
+#DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz
+
+MAINTAINER= freebsd@gionet.de
+COMMENT= A free open source 2D MMORPG in development
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ png.5:${PORTSDIR}/graphics/png \
+ curl.3:${PORTSDIR}/ftp/curl \
+ physfs-1.0.1:${PORTSDIR}/devel/physfs \
+ guichan.0:${PORTSDIR}/devel/guichan
+
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_SDL= sdl image mixer net
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${SDL_CONFIG} --cflags` -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CXXFLAGS="-lpthread"
+
+.include <bsd.port.mk>
diff --git a/games/tmw/distinfo b/games/tmw/distinfo
new file mode 100644
index 000000000000..5e821d920c91
--- /dev/null
+++ b/games/tmw/distinfo
@@ -0,0 +1,2 @@
+MD5 (tmw-0.0.17.tar.gz) = a69aced4c0ccb56440d3e254cc7c028a
+SIZE (tmw-0.0.17.tar.gz) = 1927591
diff --git a/games/tmw/files/patch-configure b/games/tmw/files/patch-configure
new file mode 100644
index 000000000000..a951a45de833
--- /dev/null
+++ b/games/tmw/files/patch-configure
@@ -0,0 +1,11 @@
+--- /work/a/ports/NEW/tmw/work/tmw-0.0.17/configure.orig Sun Oct 2 13:27:45 2005
++++ /work/a/ports/NEW/tmw/work/tmw-0.0.17/configure Thu Nov 24 00:58:05 2005
+@@ -6363,7 +6363,7 @@
+
+ # Search for sdl-config
+ # Extract the first word of "sdl-config", so it can be a program name with args.
+-set dummy sdl-config; ac_word=$2
++set dummy `basename ${SDL_CONFIG}`; ac_word=$2
+ echo "$as_me:$LINENO: checking for $ac_word" >&5
+ echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+ if test "${ac_cv_path_LIBSDL_CONFIG+set}" = set; then
diff --git a/games/tmw/pkg-descr b/games/tmw/pkg-descr
new file mode 100644
index 000000000000..eaa01ce40568
--- /dev/null
+++ b/games/tmw/pkg-descr
@@ -0,0 +1,12 @@
+The Mana World (TMW) is a serious effort to create an innovative free and
+open source MMORPG. TMW uses 2D graphics and aims to create a large and
+diverse interactive world. It is licensed under the GPL, making sure this
+game can't ever run away from you.
+
+The project includes the development of both a client and a server,
+as well as the development of an online world.
+
+WWW: http://themanaworld.org/
+
+- Tobias Gion
+info@gionet.de
diff --git a/games/tmw/pkg-plist b/games/tmw/pkg-plist
new file mode 100644
index 000000000000..06c83a0e2a17
--- /dev/null
+++ b/games/tmw/pkg-plist
@@ -0,0 +1,110 @@
+bin/tmw
+share/applications/tmw.desktop
+share/pixmaps/tmw.png
+share/tmw/data/graphics/gui/attack_target.png
+share/tmw/data/graphics/gui/bg_quad_dis.png
+share/tmw/data/graphics/gui/browserfont.png
+share/tmw/data/graphics/gui/button.png
+share/tmw/data/graphics/gui/button_disabled.png
+share/tmw/data/graphics/gui/buttonhi.png
+share/tmw/data/graphics/gui/buttonpress.png
+share/tmw/data/graphics/gui/checkbox.png
+share/tmw/data/graphics/gui/deepbox.png
+share/tmw/data/graphics/gui/fixedfont.png
+share/tmw/data/graphics/gui/hits_blue.png
+share/tmw/data/graphics/gui/hits_red.png
+share/tmw/data/graphics/gui/hits_yellow.png
+share/tmw/data/graphics/gui/hscroll_left_default.png
+share/tmw/data/graphics/gui/hscroll_left_highlight.png
+share/tmw/data/graphics/gui/hscroll_left_pressed.png
+share/tmw/data/graphics/gui/hscroll_right_default.png
+share/tmw/data/graphics/gui/hscroll_right_highlight.png
+share/tmw/data/graphics/gui/hscroll_right_pressed.png
+share/tmw/data/graphics/gui/menuitemD.png
+share/tmw/data/graphics/gui/menuitemF.png
+share/tmw/data/graphics/gui/menuitemN.png
+share/tmw/data/graphics/gui/menuitemP.png
+share/tmw/data/graphics/gui/mouse.png
+share/tmw/data/graphics/gui/radioin.png
+share/tmw/data/graphics/gui/radioout.png
+share/tmw/data/graphics/gui/resize.png
+share/tmw/data/graphics/gui/rpgfont_wider.png
+share/tmw/data/graphics/gui/sansserif8.png
+share/tmw/data/graphics/gui/selection.png
+share/tmw/data/graphics/gui/slider.png
+share/tmw/data/graphics/gui/thickborder.png
+share/tmw/data/graphics/gui/vscroll_blue.png
+share/tmw/data/graphics/gui/vscroll_down_default.png
+share/tmw/data/graphics/gui/vscroll_down_highlight.png
+share/tmw/data/graphics/gui/vscroll_down_pressed.png
+share/tmw/data/graphics/gui/vscroll_grey.png
+share/tmw/data/graphics/gui/vscroll_red.png
+share/tmw/data/graphics/gui/vscroll_up_default.png
+share/tmw/data/graphics/gui/vscroll_up_highlight.png
+share/tmw/data/graphics/gui/vscroll_up_pressed.png
+share/tmw/data/graphics/images/login_wallpaper.png
+share/tmw/data/graphics/images/minimap_new_1-1.png
+share/tmw/data/graphics/images/minimap_new_2-1.png
+share/tmw/data/graphics/images/minimap_new_3-1.png
+share/tmw/data/graphics/images/minimap_new_5-1.png
+share/tmw/data/graphics/sprites/emotions.png
+share/tmw/data/graphics/sprites/items.png
+share/tmw/data/graphics/sprites/monster0.png
+share/tmw/data/graphics/sprites/monster1.png
+share/tmw/data/graphics/sprites/monster10.png
+share/tmw/data/graphics/sprites/monster2.png
+share/tmw/data/graphics/sprites/monster3.png
+share/tmw/data/graphics/sprites/monster4.png
+share/tmw/data/graphics/sprites/monster5.png
+share/tmw/data/graphics/sprites/monster6.png
+share/tmw/data/graphics/sprites/monster7.png
+share/tmw/data/graphics/sprites/monster8.png
+share/tmw/data/graphics/sprites/monster9.png
+share/tmw/data/graphics/sprites/npcs.png
+share/tmw/data/graphics/sprites/player_male_base.png
+share/tmw/data/graphics/sprites/player_male_hair.png
+share/tmw/data/graphics/sprites/weapons.png
+share/tmw/data/graphics/tiles/arena.png
+share/tmw/data/graphics/tiles/cave.png
+share/tmw/data/graphics/tiles/collision.png
+share/tmw/data/graphics/tiles/desert1.png
+share/tmw/data/graphics/tiles/desert2.png
+share/tmw/data/graphics/tiles/desert_x2.png
+share/tmw/data/graphics/tiles/desert_x3.png
+share/tmw/data/graphics/tiles/inn.png
+share/tmw/data/graphics/tiles/mountain.png
+share/tmw/data/help/about.txt
+share/tmw/data/help/changes.txt
+share/tmw/data/help/commands.txt
+share/tmw/data/help/header.txt
+share/tmw/data/help/index.txt
+share/tmw/data/help/skills.txt
+share/tmw/data/help/support.txt
+share/tmw/data/help/team.txt
+share/tmw/data/icons/tmw-icon.ico
+share/tmw/data/icons/tmw-icon.png
+share/tmw/data/icons/tmw-icon.xpm
+share/tmw/data/items.xml
+share/tmw/data/maps/new_1-1.tmx.gz
+share/tmw/data/maps/new_2-1.tmx.gz
+share/tmw/data/maps/new_3-1.tmx.gz
+share/tmw/data/maps/new_4-1.tmx.gz
+share/tmw/data/maps/new_5-1.tmx.gz
+share/tmw/data/maps/new_6-1.tmx.gz
+share/tmw/data/maps/new_7-1.tmx.gz
+share/tmw/data/maps/new_8-1.tmx.gz
+share/tmw/data/sfx/bow_shoot_1.ogg
+share/tmw/data/sfx/fist-swish.ogg
+share/tmw/data/sfx/levelup.ogg
+@dirrm share/applications
+@dirrm share/tmw/data/sfx
+@dirrm share/tmw/data/maps
+@dirrm share/tmw/data/icons
+@dirrm share/tmw/data/help
+@dirrm share/tmw/data/graphics/tiles
+@dirrm share/tmw/data/graphics/sprites
+@dirrm share/tmw/data/graphics/images
+@dirrm share/tmw/data/graphics/gui
+@dirrm share/tmw/data/graphics
+@dirrm share/tmw/data
+@dirrm share/tmw