aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-13 00:00:22 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-13 00:00:22 +0000
commitb4af7b9ed1ee71d1b29d34241fb6cd18ad083625 (patch)
treeac6c1f433aa79f30101b293c9b023f37d1320fdd /games
parentb8047b6ca487279741e0aa522ef4b5dd5475edd6 (diff)
downloadports-b4af7b9ed1ee71d1b29d34241fb6cd18ad083625.tar.gz
ports-b4af7b9ed1ee71d1b29d34241fb6cd18ad083625.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/p5-Algorithm-Pair-Best/Makefile28
-rw-r--r--games/p5-Algorithm-Pair-Best/distinfo3
-rw-r--r--games/p5-Algorithm-Pair-Best/pkg-descr15
-rw-r--r--games/p5-Algorithm-Pair-Best/pkg-plist7
5 files changed, 54 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 5f8d912b00f3..f36d76d49f1c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -469,6 +469,7 @@
SUBDIR += openmortal
SUBDIR += openttd
SUBDIR += orbital_eunuchs_sniper
+ SUBDIR += p5-Algorithm-Pair-Best
SUBDIR += p5-Algorithm-Pair-Swiss
SUBDIR += p5-Games-AlphaBeta
SUBDIR += p5-Games-Bingo
diff --git a/games/p5-Algorithm-Pair-Best/Makefile b/games/p5-Algorithm-Pair-Best/Makefile
new file mode 100644
index 000000000000..35c4946c6097
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Best/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Algorithm-Pair-Best
+# Date created: 12 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Pair-Best
+PORTVERSION= 1.010
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl module to generate tournament pairings
+
+MAN3= Algorithm::Pair::Best.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/p5-Algorithm-Pair-Best/distinfo b/games/p5-Algorithm-Pair-Best/distinfo
new file mode 100644
index 000000000000..c9c831660ea9
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Best/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-Pair-Best-1.010.tar.gz) = edfbb60e32747dbe2149c4bda6f940eb
+SHA256 (Algorithm-Pair-Best-1.010.tar.gz) = 07af8905d5f1fda343b6c86e91bbf3bbf34b698b01a105e1912dce235fda4fb1
+SIZE (Algorithm-Pair-Best-1.010.tar.gz) = 10796
diff --git a/games/p5-Algorithm-Pair-Best/pkg-descr b/games/p5-Algorithm-Pair-Best/pkg-descr
new file mode 100644
index 000000000000..ea5d8ddb4f8b
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Best/pkg-descr
@@ -0,0 +1,15 @@
+After creating an Algorithm::Pair::Best->new object, add a list of items
+(players) to be paired. add connects the new items into a linked list. The
+linked list must consist of an even number of items or you'll get an error
+when you try to pick the pairs.
+
+Pairings are determined partially by the original order items were added,
+but more importantly, items are paired based on scores which are
+determined by an info hash used to attach any random data to the item, and
+user supplied functions to provide a score for each item in relation to
+other items. It may be convenient to add access methods to the
+Algorithm::Pair::Best package from the main namespace (see the scoreSubs
+option to new below for an example).
+
+WWW: http://search.cpan.org/dist/Algorithm-Pair-Best
+Author: Reid Augustin <reid@HelloSix.com>
diff --git a/games/p5-Algorithm-Pair-Best/pkg-plist b/games/p5-Algorithm-Pair-Best/pkg-plist
new file mode 100644
index 000000000000..d1aaf97c6ce3
--- /dev/null
+++ b/games/p5-Algorithm-Pair-Best/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Algorithm/Pair/Best.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair/Best/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair/Best
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Pair
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
+@dirrmtry %%SITE_PERL%%/Algorithm/Pair
+@dirrmtry %%SITE_PERL%%/Algorithm