aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2009-03-24 21:03:29 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2009-03-24 21:03:29 +0000
commit6e15e2879a76aab495042a14f991e7a357906560 (patch)
tree29145ae4334f84810004ac35933a1435fe4cffa9 /games
parent3ada39dfc3cda0cff3ee2339c31da185923c448e (diff)
downloadports-6e15e2879a76aab495042a14f991e7a357906560.tar.gz
ports-6e15e2879a76aab495042a14f991e7a357906560.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-enemyterritory-omni-bot-0660/Makefile12
-rw-r--r--games/linux-enemyterritory-omni-bot-0660/distinfo6
-rw-r--r--games/linux-enemyterritory-omni-bot-0660/pkg-plist57
-rw-r--r--games/linux-enemyterritory-omni-bot/Makefile3
5 files changed, 34 insertions, 45 deletions
diff --git a/games/Makefile b/games/Makefile
index 420fd510cd32..655e44331cc7 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -451,6 +451,7 @@
SUBDIR += linux-enemyterritory-fortress
SUBDIR += linux-enemyterritory-jaymod
SUBDIR += linux-enemyterritory-omni-bot
+ SUBDIR += linux-enemyterritory-omni-bot-0660
SUBDIR += linux-enemyterritory-shrub
SUBDIR += linux-enemyterritory-tce
SUBDIR += linux-etqw-demo-server
diff --git a/games/linux-enemyterritory-omni-bot-0660/Makefile b/games/linux-enemyterritory-omni-bot-0660/Makefile
index eb46b55f936f..52840f5dc187 100644
--- a/games/linux-enemyterritory-omni-bot-0660/Makefile
+++ b/games/linux-enemyterritory-omni-bot-0660/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= omni-bot
-PORTVERSION= 0.710
+PORTVERSION= 0.660
CATEGORIES= games linux
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= alepulver
@@ -18,6 +18,8 @@ COMMENT= Omni-Bot is a bot for Enemy Territory
RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+CONFLICTS= linux-enemyterritory-omni-bot-0.[7-9]*
+
USE_ZIP= yes
USE_LINUX= yes
NO_WRKSUBDIR= yes
@@ -37,12 +39,16 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
.endfor
${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/omni-bot/* ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/omni-bot/omnibot_et.so ${DATADIR}
+ cd ${WRKSRC}/omni-bot && ${CP} -R et global_scripts ${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/omnibot/qagame.mp.i386.so ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/omnibot/omnibot_et.pk3 ${DATADIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
+. for f in *.txt omni-bot/*.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+ ${CP} -R ${WRKSRC}/omni-bot/docs ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-omni-bot-0660/distinfo b/games/linux-enemyterritory-omni-bot-0660/distinfo
index f54aa5199c51..5a61e4a3e4bf 100644
--- a/games/linux-enemyterritory-omni-bot-0660/distinfo
+++ b/games/linux-enemyterritory-omni-bot-0660/distinfo
@@ -1,3 +1,3 @@
-MD5 (omni-bot-0.71.zip) = b8368331ac721059eb2c2ae703f101d9
-SHA256 (omni-bot-0.71.zip) = 5a65bc7a1d7eaa25fb9493323ea226259f4ba3945a9204f5d325520133ae288e
-SIZE (omni-bot-0.71.zip) = 7282485
+MD5 (omni-bot-0.66.zip) = dfda672510de92287c487f610b925bc2
+SHA256 (omni-bot-0.66.zip) = 8e9b16b70e06ea4c75ec422f1ecbfbcfd9b6e1184d0eac852cb350d5929646b8
+SIZE (omni-bot-0.66.zip) = 6259760
diff --git a/games/linux-enemyterritory-omni-bot-0660/pkg-plist b/games/linux-enemyterritory-omni-bot-0660/pkg-plist
index 3a4950671300..90bfe387a19d 100644
--- a/games/linux-enemyterritory-omni-bot-0660/pkg-plist
+++ b/games/linux-enemyterritory-omni-bot-0660/pkg-plist
@@ -2,70 +2,49 @@ bin/et-omni-bot
bin/etded-omni-bot
%%DATADIR%%/et/nav/et_custom.zip
%%DATADIR%%/et/nav/et_official.zip
+%%DATADIR%%/et/scripts/ammo_goal.gm
%%DATADIR%%/et/scripts/def_bot.gm
%%DATADIR%%/et/scripts/difficulty.gm
+%%DATADIR%%/et/scripts/disguise_goal.gm
+%%DATADIR%%/et/scripts/dispenseammo_goal.gm
+%%DATADIR%%/et/scripts/dispensehealth_goal.gm
+%%DATADIR%%/et/scripts/escortvehicle_goal.gm
%%DATADIR%%/et/scripts/et_autoexec.gm
%%DATADIR%%/et/scripts/et_commands.gm
%%DATADIR%%/et/scripts/et_navconfig.gm
-%%DATADIR%%/et/scripts/et_sounds.gm
%%DATADIR%%/et/scripts/et_utilities.gm
-%%DATADIR%%/et/scripts/goals/goals.zip
-%%DATADIR%%/et/scripts/testmap/adlernest_test.gm
-%%DATADIR%%/et/scripts/testmap/ae_sniper_challenge_test.gm
-%%DATADIR%%/et/scripts/testmap/battery_test.gm
-%%DATADIR%%/et/scripts/testmap/braundorf_b4_test.gm
-%%DATADIR%%/et/scripts/testmap/caen_test.gm
-%%DATADIR%%/et/scripts/testmap/cathedral_final_test.gm
-%%DATADIR%%/et/scripts/testmap/dubrovnik_final_test.gm
-%%DATADIR%%/et/scripts/testmap/et_ice_test.gm
-%%DATADIR%%/et/scripts/testmap/falcon2_test.gm
-%%DATADIR%%/et/scripts/testmap/frostbite_test.gm
-%%DATADIR%%/et/scripts/testmap/fueldump_test.gm
-%%DATADIR%%/et/scripts/testmap/goldendunk_a2_test.gm
-%%DATADIR%%/et/scripts/testmap/goldrush_test.gm
-%%DATADIR%%/et/scripts/testmap/mlb_daybreak_test.gm
-%%DATADIR%%/et/scripts/testmap/oasis_test.gm
-%%DATADIR%%/et/scripts/testmap/radar_test.gm
-%%DATADIR%%/et/scripts/testmap/railgun_test.gm
-%%DATADIR%%/et/scripts/testmap/resurrection_test.gm
-%%DATADIR%%/et/scripts/testmap/rommel_final_test.gm
-%%DATADIR%%/et/scripts/testmap/sw_goldrush_te_test.gm
-%%DATADIR%%/et/scripts/testmap/tc_venice_rc2_test.gm
-%%DATADIR%%/et/scripts/testmap/temple_final_test.gm
-%%DATADIR%%/et/scripts/testmap/v2base_test.gm
-%%DATADIR%%/et/scripts/testmap/venice_test.gm
+%%DATADIR%%/et/scripts/health_goal.gm
+%%DATADIR%%/et/scripts/makemapgm.gm
+%%DATADIR%%/et/scripts/mountvehicle_goal.gm
+%%DATADIR%%/et/scripts/poisoned.gm
+%%DATADIR%%/et/scripts/ridevehicle_goal.gm
+%%DATADIR%%/et/scripts/sample.gm
+%%DATADIR%%/et/scripts/testbot.gm
+%%DATADIR%%/et/scripts/testmap.gm
+%%DATADIR%%/et/scripts/useswitch_goal.gm
%%DATADIR%%/et/scripts/weapons/weapons.zip
-%%DATADIR%%/et/user/omni-bot.cfg
%%DATADIR%%/global_scripts/commands.gm
-%%DATADIR%%/global_scripts/functions.gm
-%%DATADIR%%/global_scripts/goals/goal_testbot.gm
-%%DATADIR%%/global_scripts/makegm.gm
-%%DATADIR%%/global_scripts/server_manager.gm
-%%DATADIR%%/global_scripts/testbot.gm
+%%DATADIR%%/global_scripts/config.gm
+%%DATADIR%%/global_scripts/testdebugger.gm
%%DATADIR%%/global_scripts/testdebugwindows.gm
%%DATADIR%%/global_scripts/testfilesystem.gm
-%%DATADIR%%/global_scripts/testmap.gm
%%DATADIR%%/global_scripts/testmath.gm
%%DATADIR%%/global_scripts/testmisc.gm
%%DATADIR%%/global_scripts/testrequire.gm
%%DATADIR%%/global_scripts/utilities.gm
%%DATADIR%%/global_scripts/weapons/weapon_sample.gm
-%%DATADIR%%/gui/default_font.bmp
%%DATADIR%%/omnibot_et.pk3
%%DATADIR%%/omnibot_et.so
%%DATADIR%%/qagame.mp.i386.so
%%PORTDOCS%%%%DOCSDIR%%/credits.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/Omni-bot Wiki.pdf
%%PORTDOCS%%%%DOCSDIR%%/install.de.txt
%%PORTDOCS%%%%DOCSDIR%%/install.en.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/gui
@dirrm %%DATADIR%%/global_scripts/weapons
-@dirrm %%DATADIR%%/global_scripts/goals
@dirrm %%DATADIR%%/global_scripts
-@dirrm %%DATADIR%%/et/user
@dirrm %%DATADIR%%/et/scripts/weapons
-@dirrm %%DATADIR%%/et/scripts/testmap
-@dirrm %%DATADIR%%/et/scripts/goals
@dirrm %%DATADIR%%/et/scripts
@dirrm %%DATADIR%%/et/nav
@dirrm %%DATADIR%%/et
diff --git a/games/linux-enemyterritory-omni-bot/Makefile b/games/linux-enemyterritory-omni-bot/Makefile
index eb46b55f936f..fdd24a7d9b5b 100644
--- a/games/linux-enemyterritory-omni-bot/Makefile
+++ b/games/linux-enemyterritory-omni-bot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= omni-bot
PORTVERSION= 0.710
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= alepulver
@@ -18,6 +19,8 @@ COMMENT= Omni-Bot is a bot for Enemy Territory
RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+CONFLICTS= linux-enemyterritory-omni-bot-0.[1-6]*
+
USE_ZIP= yes
USE_LINUX= yes
NO_WRKSUBDIR= yes