aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-13 16:38:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-13 16:38:42 +0000
commitb29202298b76aaa42bf02acc43efed96f69fea71 (patch)
tree877cf7a5dae703e54d87d82d6839fbf907e65305 /games
parent15ad88cd94766749b90987b8ac2cd8ceb302cc82 (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/planeshift/Makefile124
-rw-r--r--games/planeshift/distinfo3
-rw-r--r--games/planeshift/files/patch-autogen.sh16
-rw-r--r--games/planeshift/files/pkg-message.in94
-rw-r--r--games/planeshift/files/planeshift.in8
-rw-r--r--games/planeshift/files/psserver.in8
-rw-r--r--games/planeshift/files/pssetup.in8
-rw-r--r--games/planeshift/files/updater.in8
-rw-r--r--games/planeshift/pkg-descr21
-rw-r--r--games/planeshift/pkg-plist377
11 files changed, 0 insertions, 668 deletions
diff --git a/games/Makefile b/games/Makefile
index 8caa71f49403..304f7f0de23c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -623,7 +623,6 @@
SUBDIR += pioneers
SUBDIR += pipenightdreams
SUBDIR += pipepanic
- SUBDIR += planeshift
SUBDIR += plee-the-bear
SUBDIR += plonx
SUBDIR += plutocracy
diff --git a/games/planeshift/Makefile b/games/planeshift/Makefile
deleted file mode 100644
index effba3215871..000000000000
--- a/games/planeshift/Makefile
+++ /dev/null
@@ -1,124 +0,0 @@
-# New ports collection makefile for: planeshift
-# Date created: 2006-03-17
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
-# $FreeBSD$
-#
-
-PORTNAME= planeshift
-PORTVERSION= 0.3.017
-PORTREVISION= 4
-CATEGORIES= games
-MASTER_SITES= http://alex.foxybanana.com/freebsd/
-
-MAINTAINER= acm@FreeBSD.org
-COMMENT= First 3D MMORPG to be free for players
-
-BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam \
- cs-config:${PORTSDIR}/graphics/crystalspace-devel \
- cel-config:${PORTSDIR}/graphics/crystalentitylayer-devel \
- ${LOCALBASE}/lib/libbfd.a:${PORTSDIR}/devel/libbfd
-LIB_DEPENDS= cal3d.12:${PORTSDIR}/graphics/cal3d \
- curl.5:${PORTSDIR}/ftp/curl
-
-USE_BZIP2= yes
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:15:env autoconf:262:env
-
-DEPRECATED= Depends on broken, expired port
-EXPIRATION_DATE=2009-01-19
-
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_LIBS}
-LDFLAGS+= -L${LOCALBASE}/lib
-CRYSTAL= ${LOCALBASE}
-CEL= ${LOCALBASE}
-CONFIGURE_ARGS= --enable-cpu-specific-optimizations=no
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" CRYSTAL="${CRYSTAL}" CEL="${CEL}"
-SUB_FILES= pkg-message planeshift pssetup updater psserver
-PLANEDIR= lib/${PORTNAME}
-PLIST_SUB= PLANEDIR=${PLANEDIR}
-INSTALL_PSDATA= ${INSTALL} ${COPY} ${_SHROWNGRP} -m 0644
-
-JAM_CMD= jam
-JAM_ARGS= -qa
-
-OPTIONS= MYSQL "MySQL support for server mode " off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MYSQL)
-CONFIGURE_ARGS+= --with-mysqlclient
-USE_MYSQL= yes
-LIB_DEPENDS+= WN.2:${PORTSDIR}/textproc/wordnet
-PLIST_SUB+= MYSQL="" \
- EXAMPLE=""
-MYSQL_FLAG= true
-.else
-CONFIGURE_ARGS+= --with-mysqlclient=no
-PLIST_SUB+= MYSQL="@comment " \
- EXAMPLE="@comment "
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e 's|%%AUTOHEADER%%|${AUTOHEADER}|g' -e 's|%%AUTOCONF%%|${AUTOCONF}|g' \
- ${WRKSRC}/autogen.sh
- @cd ${WRKSRC}/src && \
- ${FIND} * -type f -name "*.c" -exec \
- ${REINPLACE_CMD} -i "" -e 's|malloc.h|stdlib.h|g' "{}" \;
- @cd ${WRKSRC} && \
- ${FIND} * -type f -name ".cvsignore" -print0 | \
- ${XARGS} -0 ${RM} -R
-
-pre-configure:
- @cd ${WRKSRC} && ${SH} autogen.sh
-
-do-build:
- @cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${JAM_CMD} ${JAM_ARGS}
-
-post-build:
- @${REINPLACE_CMD} -e 's|<mirror id="1" name="local" url="http://192.168.2.19/updater/" />| \
- <mirror id="1" name="mir1" url="http://psmirror.pfdev.net/psupdater/" \
- repository="repository.zip" files="" /> \n \
- <mirror id="2" name="mir2" url="http://planeshift.mirror.thumbnail.cz/psupdater/" \
- repository="repository.zip" files="" /> \n \
- <mirror id="3" name="mir3" url="http://www.psmirror.org/psupdater/" \
- repository="repository.zip" files="" /> \n \
- <mirror id="4" name="mir4" url="http://psmirror.u24.solone.net/psupdater/" \
- repository="repository.zip" files="" /> \n \
- <mirror id="5" name="backp" url="http://laanx.fragnetics.com/updater_hidden/" \
- repository="repository.zip" files="" />|g' ${WRKSRC}/updaterconfig.xml
-
- @${REINPLACE_CMD} -e 's|<module>docs</module>|<!-- <module>docs</module> -->|g' -e \
- 's|<module>root</module>|<!-- <module>root</module> -->|g' ${WRKSRC}/updaterconfig.xml
-do-install:
- @${MKDIR} ${PREFIX}/${PLANEDIR}
-.for FILE in ase_2_spr eedit paws_generic pawseditor psclient psnpcclient psserver pssetup texparse updater
- ${INSTALL_PROGRAM} ${WRKSRC}/${FILE} ${PREFIX}/${PLANEDIR}
-.endfor
-
-.for FILE in *.cfg *.xml
- ${INSTALL_PSDATA} ${WRKSRC}/${FILE} ${PREFIX}/${PLANEDIR}
-.endfor
-
-.for DIRE in art data
- @${MKDIR} ${PREFIX}/${PLANEDIR}/${DIRE}
- @cd ${WRKSRC}/${DIRE} && \
- ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${PLANEDIR}/${DIRE}/{}" \; && \
- ${FIND} * -type f -exec ${INSTALL_PSDATA} "{}" "${PREFIX}/${PLANEDIR}/${DIRE}/{}" \;
-.endfor
-
-.if defined(MYSQL_FLAG)
- ${INSTALL_SCRIPT} ${WRKDIR}/psserver ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/dbmysql.so ${PREFIX}/${PLANEDIR}
- @${MKDIR} ${EXAMPLESDIR}
- @cd ${WRKSRC}/src/server/database/mysql && \
- ${FIND} * -name "*.sql" -exec ${INSTALL_DATA} "{}" "${EXAMPLESDIR}/{}" \;
-.endif
-
- @${INSTALL_SCRIPT} ${WRKDIR}/planeshift ${WRKDIR}/updater ${WRKDIR}/pssetup ${PREFIX}/bin
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/games/planeshift/distinfo b/games/planeshift/distinfo
deleted file mode 100644
index e2071e8f2b71..000000000000
--- a/games/planeshift/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (planeshift-0.3.017.tar.bz2) = 0c6565363914c0199dbb01188980fca6
-SHA256 (planeshift-0.3.017.tar.bz2) = 0aa9803ceadaeff7c876c3f04eb5f666a42de5172bc998a1365cd5f37576bda4
-SIZE (planeshift-0.3.017.tar.bz2) = 10173903
diff --git a/games/planeshift/files/patch-autogen.sh b/games/planeshift/files/patch-autogen.sh
deleted file mode 100644
index 9d87c9911597..000000000000
--- a/games/planeshift/files/patch-autogen.sh
+++ /dev/null
@@ -1,16 +0,0 @@
---- autogen.sh.orig Fri Mar 17 22:07:40 2006
-+++ autogen.sh Fri Mar 17 16:52:53 2006
-@@ -13,11 +13,11 @@
- cat $i >> $MACROFILE
- done
-
--autoheader
-+%%AUTOHEADER%%
- rc=$?
-
- if test $rc -eq 0; then
-- autoconf
-+ %%AUTOCONF%%
- rc=$?
- fi
-
diff --git a/games/planeshift/files/pkg-message.in b/games/planeshift/files/pkg-message.in
deleted file mode 100644
index 2ef39aa73f49..000000000000
--- a/games/planeshift/files/pkg-message.in
+++ /dev/null
@@ -1,94 +0,0 @@
-#################################################################################
-
-CLIENT ONLY
------------
-
-1) Need to download all necessary files for planeshift (art and data directory).
-
- # updater --auto
-
- This download 200M aprox.
-
-2) Modify psclient.cfg
-
- ; Change this line
- Planeshift.GUI.Skin.Selected = cvs
- ; to
- Planeshift.GUI.Skin.Selected = default
-
- ; Uncomment this line
- SndSys.Driver = crystalspace.sndsys.software.driver.oss
- ; and add this, this line avoid a crash when planeshift is starting
- SndSys.Driver.OSS.SoundBufferms = 150
-
-3) For play online, you need create an account
-
- http://laanx.fragnetics.com/register/
-
-4) Edit planeshift.cfg file and modify these lines:
-
- ; Change values if you want.
- Video.ScreenWidth = 800
- Video.ScreenHeight = 600
- ; Performs better in 32 bit display mode
- Video.ScreenDepth = 32
- Video.FullScreen = true
- Planeshift.Connection.User = PlaneshiftAccount
-
-5) Start planeshift using root account once.
-6) Finally you can start planeshift using simple user account
-7) Enjoy it ;)
-
-SERVER ONLY
------------
-
-1) Start MySQL server
-
- # sh /usr/local/etc/rc.d/mysql-server start
-
-2) Login MySQL console
-
- # mysql -u username -ppassword
-
- default username is root with no password
-
-3) Create database and user account
-
- mysql>create database planeshift;
- mysql>GRANT ALL PRIVILEGES ON *.* TO planeshift@localhost IDENTIFIED BY \
- 'planeshift' WITH GRANT OPTION;
- mysql>quit
-
- # cd %%EXAMPLESDIR%%
-
- # mysql -u planeshift -pplaneshift
-
- mysql> use planeshift;
- mysql> source create_all.sql;
- mysql> quit
-
-4) Copy worldnet's dict directory to planeshift's data directory
-
- # cd %%LOCALBASE%%/share/WordNet
- # mkdir %%LOCALBASE%%/lib/planeshift/data/dict
- # cp * %%LOCALBASE%%/lib/planeshift/data/dict
-
-5) Start planeshift server
-
- # psserver
-
- Type the following in "PS Server" prompt:
-
- loadmap npcroom
- spawn
- ready
-
-6) Planeshift client can use these accounts for login
-
- Vengeance/keith
- acraig/andrew
- guest/guest
-
-7) Enjoy it ;)
-
-#################################################################################
diff --git a/games/planeshift/files/planeshift.in b/games/planeshift/files/planeshift.in
deleted file mode 100644
index eacedaf03d13..000000000000
--- a/games/planeshift/files/planeshift.in
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-export CRYSTAL=%%LOCALBASE%%/lib/planeshift
-export CEL=%%LOCALBASE%%/lib/cel
-export CSCONFPATH=%%LOCALBASE%%/etc/crystalspace
-
-cd %%PREFIX%%/lib/planeshift
-exec ./psclient $1
diff --git a/games/planeshift/files/psserver.in b/games/planeshift/files/psserver.in
deleted file mode 100644
index 76b2bfa1c383..000000000000
--- a/games/planeshift/files/psserver.in
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-export CRYSTAL=%%LOCALBASE%%/lib/planeshift
-export CEL=%%LOCALBASE%%/lib/cel
-export CSCONFPATH=%%LOCALBASE%%/etc/crystalspace
-
-cd %%PREFIX%%/lib/planeshift
-exec ./psserver $1
diff --git a/games/planeshift/files/pssetup.in b/games/planeshift/files/pssetup.in
deleted file mode 100644
index 870c8777d418..000000000000
--- a/games/planeshift/files/pssetup.in
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-export CRYSTAL=%%LOCALBASE%%/lib/planeshift
-export CEL=%%LOCALBASE%%/lib/cel
-export CSCONFPATH=%%LOCALBASE%%/etc/crystalspace
-
-cd %%PREFIX%%/lib/planeshift
-exec ./pssetup $1
diff --git a/games/planeshift/files/updater.in b/games/planeshift/files/updater.in
deleted file mode 100644
index 72baff7b1c72..000000000000
--- a/games/planeshift/files/updater.in
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-export CRYSTAL=%%LOCALBASE%%/lib/planeshift
-export CEL=%%LOCALBASE%%/lib/cel
-export CSCONFPATH=%%LOCALBASE%%/etc/crystalspace
-
-cd %%PREFIX%%/lib/planeshift
-exec ./updater $1
diff --git a/games/planeshift/pkg-descr b/games/planeshift/pkg-descr
deleted file mode 100644
index 384602e82c06..000000000000
--- a/games/planeshift/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-The objective of the PlaneShift is to create a virtual fantasy world in which a
-player can start as a peasant in search of fame and become a hero. First of all
-PlaneShift is a Role Playing Game. Be sure to read our Roleplay guidelines or
-you will not be able to play this game. We will focus our efforts in the
-reproduction of a real world with politics, economy, many non-player-characters
-controlled by the server that will bring to life our world even without players
-connected!
-
-We want to give FREE access to everyone, without the need to either purchase
-the game or pay a monthly fee. Servers and bandwidth will be donated by
-sponsors.
-
-Our virtual world is persistent, and this means you can connect to it at every
-hour of day or night and you will always find players and npcs wandering our
-realms. You will be able to disconnect and reconnect again, the server saves
-the actual status of your character including his possessions.
-
-You will use a client program to interact with our world, that enables you to
-have a 3D view of the surroundings.
-
-WWW: http://www.planeshift.it
diff --git a/games/planeshift/pkg-plist b/games/planeshift/pkg-plist
deleted file mode 100644
index 368b91761e86..000000000000
--- a/games/planeshift/pkg-plist
+++ /dev/null
@@ -1,377 +0,0 @@
-bin/planeshift
-%%MYSQL%%bin/psserver
-bin/pssetup
-bin/updater
-%%PLANEDIR%%/art/README
-%%PLANEDIR%%/art/apps.zip
-%%PLANEDIR%%/art/characters.zip
-%%PLANEDIR%%/art/eedit.zip
-%%PLANEDIR%%/art/effects/marker01.dds
-%%PLANEDIR%%/art/effects/raindrop.dds
-%%PLANEDIR%%/art/effects/snow.dds
-%%PLANEDIR%%/art/music/ComplexWind3.ogg
-%%PLANEDIR%%/art/music/README
-%%PLANEDIR%%/art/music/effects/PS_Thunder1.wav
-%%PLANEDIR%%/art/music/effects/PS_Thunder2.wav
-%%PLANEDIR%%/art/music/effects/PS_Thunder3.wav
-%%PLANEDIR%%/art/music/effects/PS_Thunder4.wav
-%%PLANEDIR%%/art/music/effects/PS_Thunder5.wav
-%%PLANEDIR%%/art/music/effects/PS_heavyrain.ogg
-%%PLANEDIR%%/art/music/effects/PS_lightrain.ogg
-%%PLANEDIR%%/art/music/effects/Storm_exclamation.wav
-%%PLANEDIR%%/art/music/effects/attack3.ogg
-%%PLANEDIR%%/art/music/effects/chaching.wav
-%%PLANEDIR%%/art/music/effects/gasps8.wav
-%%PLANEDIR%%/art/music/effects/halleluj.wav
-%%PLANEDIR%%/art/music/effects/heal1.ogg
-%%PLANEDIR%%/art/music/effects/heal2.ogg
-%%PLANEDIR%%/art/music/effects/ouch!.wav
-%%PLANEDIR%%/art/music/effects/sucks.wav
-%%PLANEDIR%%/art/music/gui/ccreate/back.wav
-%%PLANEDIR%%/art/music/gui/ccreate/decstat.wav
-%%PLANEDIR%%/art/music/gui/ccreate/incstat.wav
-%%PLANEDIR%%/art/music/gui/ccreate/infotext.wav
-%%PLANEDIR%%/art/music/gui/ccreate/next.wav
-%%PLANEDIR%%/art/music/gui/ccreate/quit.wav
-%%PLANEDIR%%/art/music/gui/jingle_splash.ogg
-%%PLANEDIR%%/art/music/gui/menu/btconn.wav
-%%PLANEDIR%%/art/music/gui/menu/btcreate.wav
-%%PLANEDIR%%/art/music/gui/menu/btndown.wav
-%%PLANEDIR%%/art/music/gui/menu/btquit.wav
-%%PLANEDIR%%/art/music/torch_test.wav
-%%PLANEDIR%%/art/npcs.zip
-%%PLANEDIR%%/art/pawseditor.zip
-%%PLANEDIR%%/art/psclient-setup.zip
-%%PLANEDIR%%/art/racelib.xml
-%%PLANEDIR%%/art/runes/README
-%%PLANEDIR%%/art/runes/azure/air.dds
-%%PLANEDIR%%/art/runes/azure/bond.dds
-%%PLANEDIR%%/art/runes/azure/dome.dds
-%%PLANEDIR%%/art/runes/azure/fly.dds
-%%PLANEDIR%%/art/runes/azure/gas.dds
-%%PLANEDIR%%/art/runes/azure/humanoid.dds
-%%PLANEDIR%%/art/runes/azure/mind.dds
-%%PLANEDIR%%/art/runes/azure/sleep.dds
-%%PLANEDIR%%/art/runes/azure/sound.dds
-%%PLANEDIR%%/art/sfxfiles.dtd
-%%PLANEDIR%%/art/shaders/colorize.xml
-%%PLANEDIR%%/art/shaders/particle_basic.xml
-%%PLANEDIR%%/art/skins/cvs.zip
-%%PLANEDIR%%/art/soundlib.xml
-%%PLANEDIR%%/art/sounds/gui/bttn_cancel.ogg
-%%PLANEDIR%%/art/sounds/gui/bttn_ok.ogg
-%%PLANEDIR%%/art/sounds/gui/bttn_quit.ogg
-%%PLANEDIR%%/art/sounds/gui/bttn_scrolldown.ogg
-%%PLANEDIR%%/art/sounds/gui/bttn_scrollup.ogg
-%%PLANEDIR%%/art/sounds/gui/bttn_shortcut.ogg
-%%PLANEDIR%%/art/sounds/gui/bttn_toolbar.ogg
-%%PLANEDIR%%/art/things/items.zip
-%%PLANEDIR%%/art/things/potions.zip
-%%PLANEDIR%%/art/things/weapons.zip
-%%PLANEDIR%%/art/world/lighting.xml
-%%PLANEDIR%%/art/world/npcroom.zip
-%%PLANEDIR%%/art/world/npcroom1.zip
-%%PLANEDIR%%/art/world/npcroom2.zip
-%%PLANEDIR%%/art/world/npcroom_corr.zip
-%%PLANEDIR%%/art/world/podium.zip
-%%PLANEDIR%%/art/world/sound.xml
-%%PLANEDIR%%/ase_2_spr
-%%PLANEDIR%%/data/config/setupwindow.xml
-%%PLANEDIR%%/data/config/skinwindow.xml
-%%PLANEDIR%%/data/eedit/camera.xml
-%%PLANEDIR%%/data/eedit/editeffect.xml
-%%PLANEDIR%%/data/eedit/eedit.xml
-%%PLANEDIR%%/data/eedit/error.xml
-%%PLANEDIR%%/data/eedit/filenavigation.xml
-%%PLANEDIR%%/data/eedit/fps.xml
-%%PLANEDIR%%/data/eedit/imagelist.xml
-%%PLANEDIR%%/data/eedit/inputbox/editanchor.xml
-%%PLANEDIR%%/data/eedit/inputbox/editanchorkeyframe.xml
-%%PLANEDIR%%/data/eedit/inputbox/float.xml
-%%PLANEDIR%%/data/eedit/inputbox/list.xml
-%%PLANEDIR%%/data/eedit/inputbox/newanchor.xml
-%%PLANEDIR%%/data/eedit/inputbox/newanchorkeyframe.xml
-%%PLANEDIR%%/data/eedit/inputbox/string.xml
-%%PLANEDIR%%/data/eedit/inputbox/vec3.xml
-%%PLANEDIR%%/data/eedit/inputbox/yesno.xml
-%%PLANEDIR%%/data/eedit/keys.xml
-%%PLANEDIR%%/data/eedit/keys_def.xml
-%%PLANEDIR%%/data/eedit/loadeffect.xml
-%%PLANEDIR%%/data/eedit/loadmap.xml
-%%PLANEDIR%%/data/eedit/position.xml
-%%PLANEDIR%%/data/eedit/render.xml
-%%PLANEDIR%%/data/eedit/shortcuts.xml
-%%PLANEDIR%%/data/eedit/target.xml
-%%PLANEDIR%%/data/effects/examples/obj_quad.eff
-%%PLANEDIR%%/data/effects/examples/obj_spire.eff
-%%PLANEDIR%%/data/effects/examples/obj_star.eff
-%%PLANEDIR%%/data/effects/misc/entitylabel.eff
-%%PLANEDIR%%/data/effects/misc/marker.eff
-%%PLANEDIR%%/data/effects/misc/target.eff
-%%PLANEDIR%%/data/gui/activemagicwindow.xml
-%%PLANEDIR%%/data/gui/birth.xml
-%%PLANEDIR%%/data/gui/bookwriting.xml
-%%PLANEDIR%%/data/gui/borderlist.xml
-%%PLANEDIR%%/data/gui/buddy.xml
-%%PLANEDIR%%/data/gui/configcamera.xml
-%%PLANEDIR%%/data/gui/configchat.xml
-%%PLANEDIR%%/data/gui/configchatfilter.xml
-%%PLANEDIR%%/data/gui/configchattabs.xml
-%%PLANEDIR%%/data/gui/configdetails.xml
-%%PLANEDIR%%/data/gui/configentityinter.xml
-%%PLANEDIR%%/data/gui/configentitylabels.xml
-%%PLANEDIR%%/data/gui/configkeys.xml
-%%PLANEDIR%%/data/gui/configmouse.xml
-%%PLANEDIR%%/data/gui/configpvp.xml
-%%PLANEDIR%%/data/gui/configsound.xml
-%%PLANEDIR%%/data/gui/configwindow.xml
-%%PLANEDIR%%/data/gui/containerdesc.xml
-%%PLANEDIR%%/data/gui/control.xml
-%%PLANEDIR%%/data/gui/control_styles.xml
-%%PLANEDIR%%/data/gui/craft.xml
-%%PLANEDIR%%/data/gui/credits_config.xml
-%%PLANEDIR%%/data/gui/creditswindow.xml
-%%PLANEDIR%%/data/gui/charcreate.xml
-%%PLANEDIR%%/data/gui/chardescwindow.xml
-%%PLANEDIR%%/data/gui/charpick.xml
-%%PLANEDIR%%/data/gui/chat.xml
-%%PLANEDIR%%/data/gui/chatmenu.xml
-%%PLANEDIR%%/data/gui/childhood.xml
-%%PLANEDIR%%/data/gui/detailwindow.xml
-%%PLANEDIR%%/data/gui/eedit.xml
-%%PLANEDIR%%/data/gui/exchange.xml
-%%PLANEDIR%%/data/gui/filenavigation.xml
-%%PLANEDIR%%/data/gui/fingering.xml
-%%PLANEDIR%%/data/gui/gameboard.xml
-%%PLANEDIR%%/data/gui/glyph.xml
-%%PLANEDIR%%/data/gui/gmaddeditaction.xml
-%%PLANEDIR%%/data/gui/gmguiwindow.xml
-%%PLANEDIR%%/data/gui/gmspawn.xml
-%%PLANEDIR%%/data/gui/group.xml
-%%PLANEDIR%%/data/gui/guildwindow.xml
-%%PLANEDIR%%/data/gui/helpwindow.xml
-%%PLANEDIR%%/data/gui/ignorewindow.xml
-%%PLANEDIR%%/data/gui/illumination.xml
-%%PLANEDIR%%/data/gui/infowindow.xml
-%%PLANEDIR%%/data/gui/interact.xml
-%%PLANEDIR%%/data/gui/inventory.xml
-%%PLANEDIR%%/data/gui/itemdesc.xml
-%%PLANEDIR%%/data/gui/lifeevents.xml
-%%PLANEDIR%%/data/gui/loadwindow.xml
-%%PLANEDIR%%/data/gui/loginwindow.xml
-%%PLANEDIR%%/data/gui/loot.xml
-%%PLANEDIR%%/data/gui/merchant.xml
-%%PLANEDIR%%/data/gui/money.xml
-%%PLANEDIR%%/data/gui/ok.xml
-%%PLANEDIR%%/data/gui/parents.xml
-%%PLANEDIR%%/data/gui/paths.xml
-%%PLANEDIR%%/data/gui/paws_generic.xml
-%%PLANEDIR%%/data/gui/petition.xml
-%%PLANEDIR%%/data/gui/petitiongm.xml
-%%PLANEDIR%%/data/gui/petstatwindow.xml
-%%PLANEDIR%%/data/gui/questnotebook.xml
-%%PLANEDIR%%/data/gui/questrewardwindow.xml
-%%PLANEDIR%%/data/gui/quitinfo.xml
-%%PLANEDIR%%/data/gui/readbook.xml
-%%PLANEDIR%%/data/gui/shortcutwindow.xml
-%%PLANEDIR%%/data/gui/skillwindow.xml
-%%PLANEDIR%%/data/gui/smallinventory.xml
-%%PLANEDIR%%/data/gui/spell_effect.xml
-%%PLANEDIR%%/data/gui/spellcancelwindow.xml
-%%PLANEDIR%%/data/gui/spellwindow.xml
-%%PLANEDIR%%/data/gui/splash.xml
-%%PLANEDIR%%/data/gui/styles.xml
-%%PLANEDIR%%/data/gui/summary.xml
-%%PLANEDIR%%/data/gui/tutorial.xml
-%%PLANEDIR%%/data/gui/widgetconfigwindow.xml
-%%PLANEDIR%%/data/gui/yesno.xml
-%%PLANEDIR%%/data/gui/zodiacs.xml
-%%PLANEDIR%%/data/guikeys.xml
-%%PLANEDIR%%/data/help.xml
-%%PLANEDIR%%/data/npcbehave.xml
-%%PLANEDIR%%/data/npcdefs.xml
-%%PLANEDIR%%/data/options/camera_def.xml
-%%PLANEDIR%%/data/options/controls_def.xml
-%%PLANEDIR%%/data/options/chat_def.xml
-%%PLANEDIR%%/data/options/entityinter_def.xml
-%%PLANEDIR%%/data/options/entitylabels_def.xml
-%%PLANEDIR%%/data/options/mouse_def.xml
-%%PLANEDIR%%/data/options/pvp_def.xml
-%%PLANEDIR%%/data/options/shortcutcommands_def.xml
-%%PLANEDIR%%/data/options/sound_def.xml
-%%PLANEDIR%%/data/partview/colorprops.xml
-%%PLANEDIR%%/data/partview/emitterprops.xml
-%%PLANEDIR%%/data/partview/environmentprops.xml
-%%PLANEDIR%%/data/partview/forceprops.xml
-%%PLANEDIR%%/data/partview/imagelist.xml
-%%PLANEDIR%%/data/partview/materialprops.xml
-%%PLANEDIR%%/data/partview/materiallist.xml
-%%PLANEDIR%%/data/partview/menubar.xml
-%%PLANEDIR%%/data/partview/otherprops.xml
-%%PLANEDIR%%/data/partview/particleprops.xml
-%%PLANEDIR%%/data/partview/pscollapsable.xml
-%%PLANEDIR%%/data/partview/pslist.xml
-%%PLANEDIR%%/data/partview/psscrollpane.xml
-%%PLANEDIR%%/data/partview/stateprops.xml
-%%PLANEDIR%%/data/partview/systemprops.xml
-%%PLANEDIR%%/data/pawseditor/filenavigation.xml
-%%PLANEDIR%%/data/pawseditor/imagelist.xml
-%%PLANEDIR%%/data/pawseditor/keys_def.xml
-%%PLANEDIR%%/data/pawseditor/pebackground.xml
-%%PLANEDIR%%/data/pawseditor/pemenu.xml
-%%PLANEDIR%%/data/pawseditor/peskinselector.xml
-%%PLANEDIR%%/data/pawseditor/pewidgettree.xml
-%%PLANEDIR%%/data/phonics.xml
-%%PLANEDIR%%/data/prefs.xml
-%%PLANEDIR%%/data/pvp_regions.xml
-%%PLANEDIR%%/data/races/descriptions.xml
-%%PLANEDIR%%/data/races/quickpaths.xml
-%%PLANEDIR%%/data/rpgrules.xml
-%%PLANEDIR%%/data/schemas/effects.xsd
-%%PLANEDIR%%/data/schemas/sounds.xsd
-%%PLANEDIR%%/data/servers.xml
-%%PLANEDIR%%/data/ttf/arial.ttf
-%%PLANEDIR%%/data/ttf/ariali.ttf
-%%PLANEDIR%%/data/ttf/becker-m.ttf
-%%PLANEDIR%%/data/ttf/comic.ttf
-%%PLANEDIR%%/data/ttf/cour.ttf
-%%PLANEDIR%%/data/ttf/cupandtalon.ttf
-%%PLANEDIR%%/data/ttf/readme.txt
-%%PLANEDIR%%/data/ttf/scurlock.ttf
-%%PLANEDIR%%/data/ttf/verdana.ttf
-%%PLANEDIR%%/data/updater/serverlist.xml
-%%PLANEDIR%%/data/updater/updateroptions.xml
-%%PLANEDIR%%/data/updater/updaterwindow.xml
-%%PLANEDIR%%/data/zoneinfo.xml
-%%MYSQL%%%%PLANEDIR%%/dbmysql.so
-%%PLANEDIR%%/eedit
-%%PLANEDIR%%/eedit.cfg
-%%PLANEDIR%%/npcclient.cfg
-%%PLANEDIR%%/partview.cfg
-%%PLANEDIR%%/paws_generic
-%%PLANEDIR%%/paws_generic.cfg
-%%PLANEDIR%%/pawseditor
-%%PLANEDIR%%/pawseditor.cfg
-%%PLANEDIR%%/planeshift.cfg
-%%PLANEDIR%%/psclient
-%%PLANEDIR%%/psclient.cfg
-%%PLANEDIR%%/psnpcclient
-%%PLANEDIR%%/psserver
-%%PLANEDIR%%/psserver.cfg
-%%PLANEDIR%%/pssetup
-%%PLANEDIR%%/pssetup.cfg
-%%PLANEDIR%%/psupdater.cfg
-%%PLANEDIR%%/texparse
-%%PLANEDIR%%/updater
-%%PLANEDIR%%/updaterconfig.xml
-%%PLANEDIR%%/vfs.cfg
-%%EXAMPLE%%share/examples/planeshift/accessrules.sql
-%%EXAMPLE%%share/examples/planeshift/accounts.sql
-%%EXAMPLE%%share/examples/planeshift/action_locations.sql
-%%EXAMPLE%%share/examples/planeshift/alliances.sql
-%%EXAMPLE%%share/examples/planeshift/armorvsweapon.sql
-%%EXAMPLE%%share/examples/planeshift/bad_names.sql
-%%EXAMPLE%%share/examples/planeshift/bans.sql
-%%EXAMPLE%%share/examples/planeshift/command_access.sql
-%%EXAMPLE%%share/examples/planeshift/commonstrings.sql
-%%EXAMPLE%%share/examples/planeshift/create_all.sql
-%%EXAMPLE%%share/examples/planeshift/char_adv.sql
-%%EXAMPLE%%share/examples/planeshift/char_create_affinity.sql
-%%EXAMPLE%%share/examples/planeshift/char_creation.sql
-%%EXAMPLE%%share/examples/planeshift/char_skills.sql
-%%EXAMPLE%%share/examples/planeshift/char_traits.sql
-%%EXAMPLE%%share/examples/planeshift/character_quests.sql
-%%EXAMPLE%%share/examples/planeshift/character_relationships.sql
-%%EXAMPLE%%share/examples/planeshift/characters.sql
-%%EXAMPLE%%share/examples/planeshift/deletechar.sql
-%%EXAMPLE%%share/examples/planeshift/deletenpc.sql
-%%EXAMPLE%%share/examples/planeshift/deletenpc_mb.sql
-%%EXAMPLE%%share/examples/planeshift/drop.sql
-%%EXAMPLE%%share/examples/planeshift/factions.sql
-%%EXAMPLE%%share/examples/planeshift/familiar_types.sql
-%%EXAMPLE%%share/examples/planeshift/gm_command_log.sql
-%%EXAMPLE%%share/examples/planeshift/guildlevels.sql
-%%EXAMPLE%%share/examples/planeshift/guilds.sql
-%%EXAMPLE%%share/examples/planeshift/hunt_locations.sql
-%%EXAMPLE%%share/examples/planeshift/item_animations.sql
-%%EXAMPLE%%share/examples/planeshift/item_categories.sql
-%%EXAMPLE%%share/examples/planeshift/item_instances.sql
-%%EXAMPLE%%share/examples/planeshift/item_stats.sql
-%%EXAMPLE%%share/examples/planeshift/loot_modifiers.sql
-%%EXAMPLE%%share/examples/planeshift/loot_rule_details.sql
-%%EXAMPLE%%share/examples/planeshift/loot_rules.sql
-%%EXAMPLE%%share/examples/planeshift/merchant_item_cats.sql
-%%EXAMPLE%%share/examples/planeshift/migration.sql
-%%EXAMPLE%%share/examples/planeshift/movement.sql
-%%EXAMPLE%%share/examples/planeshift/natural_resources.sql
-%%EXAMPLE%%share/examples/planeshift/npc_bad_text.sql
-%%EXAMPLE%%share/examples/planeshift/npc_disallowed_words.sql
-%%EXAMPLE%%share/examples/planeshift/npc_kas.sql
-%%EXAMPLE%%share/examples/planeshift/npc_responses.sql
-%%EXAMPLE%%share/examples/planeshift/npc_spawn_ranges.sql
-%%EXAMPLE%%share/examples/planeshift/npc_spawn_rules.sql
-%%EXAMPLE%%share/examples/planeshift/npc_synonyms.sql
-%%EXAMPLE%%share/examples/planeshift/npc_trigger_groups.sql
-%%EXAMPLE%%share/examples/planeshift/npc_triggers.sql
-%%EXAMPLE%%share/examples/planeshift/petitions.sql
-%%EXAMPLE%%share/examples/planeshift/player_spells.sql
-%%EXAMPLE%%share/examples/planeshift/progress_events.sql
-%%EXAMPLE%%share/examples/planeshift/quest_scripts.sql
-%%EXAMPLE%%share/examples/planeshift/quests.sql
-%%EXAMPLE%%share/examples/planeshift/race_info.sql
-%%EXAMPLE%%share/examples/planeshift/sc_location_type.sql
-%%EXAMPLE%%share/examples/planeshift/sc_locations.sql
-%%EXAMPLE%%share/examples/planeshift/sc_npc_definitions.sql
-%%EXAMPLE%%share/examples/planeshift/sc_waypoint_links.sql
-%%EXAMPLE%%share/examples/planeshift/sc_waypoints.sql
-%%EXAMPLE%%share/examples/planeshift/sectors.sql
-%%EXAMPLE%%share/examples/planeshift/security_levels.sql
-%%EXAMPLE%%share/examples/planeshift/server_options.sql
-%%EXAMPLE%%share/examples/planeshift/skills.sql
-%%EXAMPLE%%share/examples/planeshift/spell_glyphs.sql
-%%EXAMPLE%%share/examples/planeshift/spells.sql
-%%EXAMPLE%%share/examples/planeshift/tips.sql
-%%EXAMPLE%%share/examples/planeshift/trade_autocontainers.sql
-%%EXAMPLE%%share/examples/planeshift/trade_combinations.sql
-%%EXAMPLE%%share/examples/planeshift/trade_constraints.sql
-%%EXAMPLE%%share/examples/planeshift/trade_patterns.sql
-%%EXAMPLE%%share/examples/planeshift/trade_processes.sql
-%%EXAMPLE%%share/examples/planeshift/trade_transformations.sql
-%%EXAMPLE%%share/examples/planeshift/trainer_skills.sql
-%%EXAMPLE%%share/examples/planeshift/traits.sql
-%%EXAMPLE%%share/examples/planeshift/tribe_members.sql
-%%EXAMPLE%%share/examples/planeshift/tribes.sql
-%%EXAMPLE%%share/examples/planeshift/upgrade_schema.sql
-%%EXAMPLE%%share/examples/planeshift/ways.sql
-@dirrmtry %%PLANEDIR%%/art/effects
-@dirrmtry %%PLANEDIR%%/art/music/effects
-@dirrmtry %%PLANEDIR%%/art/music/gui/ccreate
-@dirrmtry %%PLANEDIR%%/art/music/gui/menu
-@dirrmtry %%PLANEDIR%%/art/music/gui
-@dirrmtry %%PLANEDIR%%/art/music
-@dirrmtry %%PLANEDIR%%/art/runes/azure
-@dirrmtry %%PLANEDIR%%/art/runes
-@dirrmtry %%PLANEDIR%%/art/shaders
-@dirrmtry %%PLANEDIR%%/art/skins
-@dirrmtry %%PLANEDIR%%/art/sounds/gui
-@dirrmtry %%PLANEDIR%%/art/sounds
-@dirrmtry %%PLANEDIR%%/art/things
-@dirrmtry %%PLANEDIR%%/art/world
-@dirrmtry %%PLANEDIR%%/art
-@dirrmtry %%PLANEDIR%%/data/config
-@dirrmtry %%PLANEDIR%%/data/eedit/inputbox
-@dirrmtry %%PLANEDIR%%/data/eedit
-@dirrmtry %%PLANEDIR%%/data/effects/examples
-@dirrmtry %%PLANEDIR%%/data/effects/misc
-@dirrmtry %%PLANEDIR%%/data/effects
-@dirrmtry %%PLANEDIR%%/data/gui
-@dirrmtry %%PLANEDIR%%/data/options
-@dirrmtry %%PLANEDIR%%/data/partview
-@dirrmtry %%PLANEDIR%%/data/pawseditor
-@dirrmtry %%PLANEDIR%%/data/races
-@dirrmtry %%PLANEDIR%%/data/schemas
-@dirrmtry %%PLANEDIR%%/data/ttf
-@dirrmtry %%PLANEDIR%%/data/updater
-@dirrmtry %%PLANEDIR%%/data
-@unexec rmdir %D/%%PLANEDIR%% >/dev/null 2>&1 || echo "Remove manually the extra files into data and art directories (200M aprox.). Also you could move data and art directory to some backup directory."
-%%EXAMPLE%%@dirrm share/examples/planeshift