aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-03-15 16:27:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-03-15 16:27:41 +0000
commitcb9c0cd46f06701842fe0f719f7a5e49b836d13d (patch)
tree94654cd729d1fa1e185e4c3cbfacc94011b6709e /games
parent2c605a93fc6960d3224f5fe78c58bdfa77516eb2 (diff)
downloadports-cb9c0cd46f06701842fe0f719f7a5e49b836d13d.tar.gz
ports-cb9c0cd46f06701842fe0f719f7a5e49b836d13d.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile2
-rw-r--r--games/tesseract-data/Makefile32
-rw-r--r--games/tesseract-data/distinfo2
-rw-r--r--games/tesseract-data/pkg-descr3
-rw-r--r--games/tesseract/Makefile75
-rw-r--r--games/tesseract/distinfo2
-rw-r--r--games/tesseract/files/tess_wrapper.in4
-rw-r--r--games/tesseract/pkg-descr10
8 files changed, 130 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 892c3db5baee..f597475c735f 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -956,6 +956,8 @@
SUBDIR += teeworlds
SUBDIR += teg
SUBDIR += tenebrae
+ SUBDIR += tesseract
+ SUBDIR += tesseract-data
SUBDIR += tetrinet
SUBDIR += tetrinet-x
SUBDIR += tetrons
diff --git a/games/tesseract-data/Makefile b/games/tesseract-data/Makefile
new file mode 100644
index 000000000000..bc74b604195a
--- /dev/null
+++ b/games/tesseract-data/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= tesseract
+DISTVERSION= 2014_05_12
+CATEGORIES= games
+MASTER_SITES= http://download.tuxfamily.org/${PORTNAME}/
+DISTNAME= ${PORTNAME}_${DISTVERSION}_first_edition_linux
+PKGNAMESUFFIX= -game-data
+
+MAINTAINER= operator@myrechenzentrum.net
+COMMENT= Data files for Tesseract first-person shooter
+
+LICENSE= DejaVu OTHER
+LICENSE_COMB= multi
+LICENSE_NAME_DejaVu= Bitstream Vera and Arev fonts license
+LICENSE_FILE_DejaVu= ${WRKSRC}/media/interface/font/default.txt
+LICENSE_PERMS_DejaVu= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_NAME_OTHER= Various licenses for textures, sounds, etc.
+LICENSE_TEXT_OTHER= See info.txt files under media/ directory
+LICENSE_PERMS_OTHER= dist-mirror pkg-mirror auto-accept
+
+USES= tar:xz
+NO_ARCH= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PORTDATA= config media screenshot
+
+do-install:
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \
+ "${PORTDATA}" ${STAGEDIR}${DATADIR})
+
+.include <bsd.port.mk>
diff --git a/games/tesseract-data/distinfo b/games/tesseract-data/distinfo
new file mode 100644
index 000000000000..106ac8dc6b20
--- /dev/null
+++ b/games/tesseract-data/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tesseract_2014_05_12_first_edition_linux.tar.xz) = 8d6e07dd154a40a3f593e52289335c036f06cf90a0ebc400c4650adb3395a0f4
+SIZE (tesseract_2014_05_12_first_edition_linux.tar.xz) = 249009328
diff --git a/games/tesseract-data/pkg-descr b/games/tesseract-data/pkg-descr
new file mode 100644
index 000000000000..98a56a79eee6
--- /dev/null
+++ b/games/tesseract-data/pkg-descr
@@ -0,0 +1,3 @@
+Data files for Tesseract first-person shooter.
+
+WWW: http://www.tesseract.gg
diff --git a/games/tesseract/Makefile b/games/tesseract/Makefile
new file mode 100644
index 000000000000..0743a233cb36
--- /dev/null
+++ b/games/tesseract/Makefile
@@ -0,0 +1,75 @@
+# $FreeBSD$
+
+PORTNAME= tesseract
+DISTVERSION= 2014_05_12
+CATEGORIES= games
+MASTER_SITES= http://download.tuxfamily.org/${PORTNAME}/
+PKGNAMESUFFIX= -game
+DISTNAME= ${PORTNAME}_${DISTVERSION}_first_edition_linux
+
+MAINTAINER= operator@myrechenzentrum.net
+COMMENT= Smooth FPS with map editing, instagib, DM and CTF
+
+LICENSE= ZLIB
+
+LIB_DEPENDS= libenet.so:net/enet
+RUN_DEPENDS= ${PKGBASE}-data>=${DISTVERSION}:${PKGORIGIN}-data
+
+USES= gmake pkgconfig tar:xz
+EXCLUDE= bin_unix config media screenshot src/enet src/lib\* src/xcode
+EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/src
+ALL_TARGET= # empty
+SUB_FILES= tess_wrapper
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=CLIENT DEDICATED
+OPTIONS_MULTI= FLAVOR
+OPTIONS_MULTI_FLAVOR=CLIENT DEDICATED MASTER
+
+CLIENT_DESC= Build client
+CLIENT_USE= GL=gl SDL=image2,mixer2 XORG=x11
+CLIENT_ALL_TARGET= client
+CLIENT_PLIST_FILES= bin/tess_client libexec/tess_client
+CLIENT_DESKTOP_ENTRIES= "Tesseract" \
+ "" \
+ "${DATADIR}/media/interface/cube.png" \
+ "tess_client" \
+ "Game;Shooter;" \
+ ""
+
+DEDICATED_DESC= Build dedicated server
+DEDICATED_ALL_TARGET= server
+DEDICATED_PLIST_FILES= bin/tess_server libexec/tess_server
+
+MASTER_DESC= Build master server
+MASTER_ALL_TARGET= master
+MASTER_PLIST_FILES= bin/tess_master libexec/tess_master
+
+post-patch:
+ @${REINPLACE_CMD} -e '/OBJS.*PCH/d' \
+ -e '/-fomit-frame-pointer/d' \
+ -e 's,-I/usr/X11R6/include,,' \
+ -e 's,-L/usr/X11R6/lib,,' \
+ -e 's,libenet ,,' \
+ -e 's,-Ienet/include,`pkg-config --cflags libenet`,' \
+ -e 's,-Lenet -lenet,`pkg-config --libs libenet`,' \
+ ${BUILD_WRKSRC}/Makefile
+
+do-install:
+ for f in ${PLIST_FILES:Mbin/*}; do \
+ ${INSTALL_SCRIPT} ${WRKDIR}/tess_wrapper \
+ ${STAGEDIR}${PREFIX}/$$f; \
+ done
+ for f in ${PLIST_FILES:Mlibexec/*}; do \
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/$${f##*/} \
+ ${STAGEDIR}${PREFIX}/$${f%/*}; \
+ done
+
+do-install-DOCS-on:
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \
+ . ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>
diff --git a/games/tesseract/distinfo b/games/tesseract/distinfo
new file mode 100644
index 000000000000..106ac8dc6b20
--- /dev/null
+++ b/games/tesseract/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tesseract_2014_05_12_first_edition_linux.tar.xz) = 8d6e07dd154a40a3f593e52289335c036f06cf90a0ebc400c4650adb3395a0f4
+SIZE (tesseract_2014_05_12_first_edition_linux.tar.xz) = 249009328
diff --git a/games/tesseract/files/tess_wrapper.in b/games/tesseract/files/tess_wrapper.in
new file mode 100644
index 000000000000..8aa8c0b1522e
--- /dev/null
+++ b/games/tesseract/files/tess_wrapper.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd ${TESS_DATA="%%DATADIR%%"}
+exec %%PREFIX%%/libexec/${0##*/} ${TESS_OPTIONS="-u~/.tesseract"} "$@"
diff --git a/games/tesseract/pkg-descr b/games/tesseract/pkg-descr
new file mode 100644
index 000000000000..e52fa9a5b59a
--- /dev/null
+++ b/games/tesseract/pkg-descr
@@ -0,0 +1,10 @@
+Tesseract is a first-person shooter game focused on instagib deathmatch
+and capture-the-flag gameplay as well as cooperative in-game map editing.
+
+Tesseract provides a unique open-source engine derived from Cube 2
+Sauerbraten technology but with upgraded modern rendering techniques.
+The new rendering features include fully dynamic omnidirectional
+shadows, global illumination, HDR lighting, deferred shading,
+morphological/temporal/multisample anti-aliasing, and much more.
+
+WWW: http://www.tesseract.gg