aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-11-26 15:21:52 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-11-26 15:21:52 +0000
commit7acc6ba7438948e752ee6fb6d8cc6dd535437eed (patch)
tree24cf6f3af8b2aa17d41615db5f8472c6eac39edb /games
parent4594352eea060d36f65797080aa3b9fe2ef1c321 (diff)
downloadports-7acc6ba7438948e752ee6fb6d8cc6dd535437eed.tar.gz
ports-7acc6ba7438948e752ee6fb6d8cc6dd535437eed.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/frotz/Makefile28
-rw-r--r--games/frotz/distinfo2
-rw-r--r--games/frotz/files/patch-aa84
-rw-r--r--games/frotz/pkg-descr2
-rw-r--r--games/frotz/pkg-plist9
5 files changed, 75 insertions, 50 deletions
diff --git a/games/frotz/Makefile b/games/frotz/Makefile
index c09534b0af34..948856391d34 100644
--- a/games/frotz/Makefile
+++ b/games/frotz/Makefile
@@ -5,27 +5,25 @@
# $FreeBSD$
#
-PORTNAME= frotz
-PORTVERSION= 2.32
-CATEGORIES= games
-MASTER_SITES= ftp://ftp.gmd.de/if-archive/infocom/interpreters/frotz/
-DISTNAME= UnixFrotz232R2Std10
+PORTNAME= frotz
+PORTVERSION= 2.40
+CATEGORIES= games
+MASTER_SITES= http://www.cs.csubak.edu/~dgriffi/frotz/files/ \
+ ftp://ftp.gmd.de/if-archive/infocom/interpreters/frotz/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-ALL_TARGET=
-WRKSRC= ${WRKDIR}/frotz-2.32
+ALL_TARGET= # empty
-MAN6= frotz.6
+MAN6= frotz.6
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/frotz.6 ${PREFIX}/man/man6
-
+ ${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/frotz.6 ${PREFIX}/man/man6
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/frotz
-.for file in Readme.unix Todo
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/frotz
+ @${MKDIR} ${PREFIX}/share/doc/frotz
+.for file in AUTHORS BUGS ChangeLog HOW_TO_PLAY INSTALL README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/frotz
.endfor
.endif
diff --git a/games/frotz/distinfo b/games/frotz/distinfo
index e84d0ed45219..26d2a1d24b28 100644
--- a/games/frotz/distinfo
+++ b/games/frotz/distinfo
@@ -1 +1 @@
-MD5 (UnixFrotz232R2Std10.tar.gz) = 5c40f4a9da46a65cd0fd09821bf93538
+MD5 (frotz-2.40.tar.gz) = b19fa5528e6a5ea13afeecf8b38cccc3
diff --git a/games/frotz/files/patch-aa b/games/frotz/files/patch-aa
index 57c7a147e028..be4350ccca1a 100644
--- a/games/frotz/files/patch-aa
+++ b/games/frotz/files/patch-aa
@@ -1,39 +1,61 @@
---- Makefile.orig Fri Oct 17 16:11:10 1997
-+++ Makefile Sun Jun 7 18:26:02 1998
-@@ -1,7 +1,7 @@
-
- # Define your c compiler. I recommend gcc if you've got it.
- #CC = cc
+--- Makefile.orig Sat Nov 11 20:50:16 2000
++++ Makefile Wed Nov 22 21:16:35 2000
+@@ -1,26 +1,26 @@
+ #Define your C compiler. I recommend gcc if you have it.
-CC = gcc
+#CC = gcc
+ #CC = cc
# Define your optimization flags. Most compilers understand -O and -O2,
- # Debugging (don't use)
-@@ -43,7 +43,8 @@
- # have that option.
- #
- #DEFS = -DUSE_GETOPT_H -DCOLOR_SUPPORT -DEMACS_EDITING
--DEFS =
-+DEFS = -DCOLOR_SUPPORT -DEMACS_EDITING -DUSE_NCURSES_H -DUSE_NOTHING \
-+ -DUSE_UNISTD_H
-
- # This should point to the location of your curses or ncurses include file
- # if it's in a non-standard place.
-@@ -57,7 +58,7 @@
- #CURSES = -lncurses
- #LIB = -L/5usr/lib
- LIB =
--CURSES = -lcurses
-+CURSES = -lncurses
+ # Standard (note: Solaris on UltraSparc using gcc 2.8.x might not like this.)
+-OPTS = -O2
++#OPTS = -O2
+ # Pentium with gcc 2.7.0 or better
+ #OPTS = -O2 -fomit-frame-pointer -malign-functions=2 -malign-loops=2 \
+ #-malign-jumps=2
+
+ # Define where you want Frotz to be installed. Usually this is /usr/local
+-PREFIX = /usr/local
++#PREFIX = /usr/local
+ #PREFIX =
- # Nothing under this line should need to be changed.
+ # Define where you want Frotz to look for frotz.conf.
+-CONFIG_DIR = /usr/local/etc
++CONFIG_DIR = ${PREFIX}/etc
+ #CONFIG_DIR = /etc
+ #CONFIG_DIR = /usr/pkg/etc
+ #CONFIG_DIR =
+
+ # Uncomment this if you want color support. Usually this requires ncurses.
+-#COLOR_DEFS = -DCOLOR_SUPPORT
++COLOR_DEFS = -DCOLOR_SUPPORT
+
+ # Uncomment this if you have an OSS soundcard driver and want classical
+ # Infocom sound support.
+@@ -28,7 +28,7 @@
+
+ # This should point to the location of your curses.h or ncurses.h include
+ # file if your compiler doesn't know about it.
+-INCL = -I/usr/local/include
++#INCL = -I/usr/local/include
+ #INCL = -I/usr/pkg/include
+ #INCL = -I/usr/freeware/include
+ #INCL = -I/5usr/include
+@@ -37,7 +37,7 @@
+ # This should define the location and name of whatever curses library you're
+ # linking with. Usually, this isn't necessary if /etc/ld.so.conf is set
+ # up correctly.
+-LIB = -L/usr/local/lib
++#LIB = -L/usr/local/lib
+ #LIB = -L/usr/pkg/lib
+ #LIB = -L/usr/freeware/lib
+ #LIB = -L/5usr/lib
+@@ -81,7 +81,7 @@
+ COMP_DEFS = $(OPT_DEFS) $(COLOR_DEFS) $(SOUND_DEFS) $(SOUNDCARD) \
+ $(MEMMOVE_DEF)
-@@ -66,7 +67,7 @@
- text.o ux_init.o ux_input.o ux_pic.o ux_screen.o ux_sample.o \
- ux_text.o variable.o
+-CFLAGS = $(OPTS) $(COMP_DEFS) $(INCL)
++CFLAGS += $(OPTS) $(COMP_DEFS) $(INCL)
--CFLAGS = $(OPTS) $(DEFS) $(INCL)
-+CFLAGS+= $(DEFS)
- frotz: $(OBJECTS)
- $(CC) -o frotz $(OBJECTS) $(LIB) $(CURSES)
+ $(BINNAME): soundcard.h $(OBJECTS)
diff --git a/games/frotz/pkg-descr b/games/frotz/pkg-descr
index 5c02e7ce265b..233c76ec2be3 100644
--- a/games/frotz/pkg-descr
+++ b/games/frotz/pkg-descr
@@ -7,4 +7,4 @@ to transfer the story files. There is an increasing number
of new games available on the Internet. Check the if-archive
at ftp.gmd.de.
-WWW: http://www.geocities.com/SiliconValley/Heights/3222/frotz.html
+WWW: http://www.cs.csubak.edu/~dgriffi/frotz/
diff --git a/games/frotz/pkg-plist b/games/frotz/pkg-plist
index e38ca887f98b..351c941c9736 100644
--- a/games/frotz/pkg-plist
+++ b/games/frotz/pkg-plist
@@ -1,4 +1,9 @@
bin/frotz
-share/doc/frotz/Readme.unix
-share/doc/frotz/Todo
+share/doc/frotz/AUTHORS
+share/doc/frotz/BUGS
+share/doc/frotz/ChangeLog
+share/doc/frotz/HOW_TO_PLAY
+share/doc/frotz/INSTALL
+share/doc/frotz/README
+share/doc/frotz/TODO
@dirrm share/doc/frotz