aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-08 20:16:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-08 20:16:03 +0000
commitb6ad96d98b250dbf604d5f2be94684612089a9e0 (patch)
treecac36e9c189c99fc5ae0e556ed35a42ee3e4b904 /games
parent81dc8d94e3409a2ae3760e85e0b0fb4f92c5aba6 (diff)
downloadports-b6ad96d98b250dbf604d5f2be94684612089a9e0.tar.gz
ports-b6ad96d98b250dbf604d5f2be94684612089a9e0.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/openalchemist/Makefile37
-rw-r--r--games/openalchemist/distinfo6
-rw-r--r--games/openalchemist/files/patch-Makefile41
-rw-r--r--games/openalchemist/files/patch-includes-piece.h17
-rw-r--r--games/openalchemist/pkg-plist10
5 files changed, 40 insertions, 71 deletions
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index 79e2d3d7b1ea..de53973993b6 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openalchemist
-PORTVERSION= 0.2.2
+PORTVERSION= 0.3
CATEGORIES= games
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -15,14 +15,37 @@ MAINTAINER= ganael.laplanche@martymac.com
COMMENT= Tetris-like game
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib
+LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
-USE_GNOME= pkgconfig
-MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}" \
- DATADIR="${DATADIR}"
+USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:262
+# Necessary to find pkg.m4 (PKG_CHECK_MODULES)
+ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+USE_GNOME= pkgconfig pygtk2
+USE_XORG= xxf86vm xi x11 xmu xext xdamage xfixes xau xdmcp xt sm ice
+USE_GL= gl glu
+USE_SDL= sdl gfx
+USE_ICONV= yes
+
+PORTDOCS= AUTHORS CODE-LICENSE COPYING ChangeLog GRAPHICS-LICENSE README TODO
-# Allow relocation of skins (by default, must be in the skins/ sub-dir)
post-patch:
- @${REINPLACE_CMD} -E -e 's|CL_System::get_exe_path\(\) \+ "skins/|"${DATADIR}/skins/|g' ${WRKSRC}/src/*.cpp
+ @${REINPLACE_CMD} -E -e 's|^%|#|g' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -E -e 's|^dist_pkgdata_DATA =.*|dist_pkgdata_DATA = data/* skins/aqua.zip skins/brushed.zip skins/vectoriel.zip|g' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -E -e 's|^#!/usr/bin/python|#!${LOCALBASE}/bin/python|g' ${WRKSRC}/openalchemist-config
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/games/openalchemist/distinfo b/games/openalchemist/distinfo
index 42d86d7b5b60..c41acb4c2d15 100644
--- a/games/openalchemist/distinfo
+++ b/games/openalchemist/distinfo
@@ -1,3 +1,3 @@
-MD5 (openalchemist-0.2.2-src.tar.gz) = 1fe3e74e100906258396694f40a8e7cd
-SHA256 (openalchemist-0.2.2-src.tar.gz) = 11c60f4e53fe42f349fe248eea09cfa8a984ff395c533d9874d8ccbd293ec1cc
-SIZE (openalchemist-0.2.2-src.tar.gz) = 2472519
+MD5 (openalchemist-0.3-src.tar.gz) = 3107b699d63d5ae7cbf65ddc9872c49a
+SHA256 (openalchemist-0.3-src.tar.gz) = 6f869ba8424f1f861a021b595c2b78b6e5740f56758f19b00f3bc7dc9105cc89
+SIZE (openalchemist-0.3-src.tar.gz) = 5936792
diff --git a/games/openalchemist/files/patch-Makefile b/games/openalchemist/files/patch-Makefile
deleted file mode 100644
index 81ca550e7f16..000000000000
--- a/games/openalchemist/files/patch-Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
---- Makefile.orig 2006-09-03 20:17:13.000000000 +0200
-+++ Makefile 2008-04-30 19:57:29.216855616 +0200
-@@ -1,12 +1,10 @@
- PACKAGES = clanCore-0.8 clanDisplay-0.8 clanApp-0.8 clanGL-0.8 clanSDL-0.8
--LIBS = `pkg-config --libs $(PACKAGES)`
--OPTIONS = -Iincludes -Wall -g
-+LIBS = `pkg-config --libs $(PACKAGES)` $(PTHREAD_LIBS)
-+OPTIONS = -Iincludes -I/usr/local/include -Wall -g
- LINKER_OPTIONS = #-u malloc -lefence
- STATIC_LIBS = `pkg-config --libs $(PACKAGES) --static`
- CFLAGS = `pkg-config --cflags $(PACKAGES)`
-
--INSTALL_DIR = /usr/local/games/openalchemist
--
- all: openalchemist skins/aqua.zip skins/brushed.zip
- @echo "OK"
-
-@@ -83,18 +81,11 @@
- -rm skins/brushed.zip
-
- install: openalchemist
-- mkdir $(INSTALL_DIR)
-- mkdir $(INSTALL_DIR)/skins
-- cp openalchemist $(INSTALL_DIR)/
-- cp skins/aqua.zip $(INSTALL_DIR)/skins/aqua.zip
-- cp skins/brushed.zip $(INSTALL_DIR)/skins/brushed.zip
-- ln -s $(INSTALL_DIR)/openalchemist /usr/local/bin/openalchemist
--
--uninstall: $(INSTALL_DIR)
-- rm $(INSTALL_DIR)/* -R
-- rmdir $(INSTALL_DIR)
-- rm /usr/local/bin/openalchemist
--
-+ install -d -o root -g wheel -m 755 $(PREFIX)/bin
-+ install -d -o root -g wheel -m 755 $(DATADIR)/skins
-+ install -s -o root -g wheel -m 555 openalchemist $(PREFIX)/bin/
-+ install -o root -g wheel -m 444 skins/aqua.zip $(DATADIR)/skins/aqua.zip
-+ install -o root -g wheel -m 444 skins/brushed.zip $(DATADIR)/skins/brushed.zip
-
- static: includes/*.h bin/misc.o bin/main.o bin/game.o bin/key_events.o bin/detect_to_destroy.o bin/detect_to_fall.o bin/drawing.o bin/hightscores.o bin/pause.o bin/preferences.o bin/skins-selector.o skins/aqua.zip skins/brushed.zip
- @echo "On assemble le fichier final"
diff --git a/games/openalchemist/files/patch-includes-piece.h b/games/openalchemist/files/patch-includes-piece.h
deleted file mode 100644
index df77222a0af5..000000000000
--- a/games/openalchemist/files/patch-includes-piece.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- includes/piece.h.orig 2008-03-18 17:51:15.254937990 +0100
-+++ includes/piece.h 2008-03-18 17:51:38.315878696 +0100
-@@ -81,12 +81,12 @@
- }
-
- // Methods to display - be carefull, if current_prite is not initialized
-- void Piece::draw(CL_GraphicContext* context = 0)
-+ void draw(CL_GraphicContext* context = 0)
- {
- current_sprite -> draw(x, y, context);
- }
-
-- void Piece::draw_mini(CL_GraphicContext* context = 0)
-+ void draw_mini(CL_GraphicContext* context = 0)
- {
- mini_sprite -> draw(x, y, context);
- }
diff --git a/games/openalchemist/pkg-plist b/games/openalchemist/pkg-plist
index af306d6a8e65..61bce013ddbf 100644
--- a/games/openalchemist/pkg-plist
+++ b/games/openalchemist/pkg-plist
@@ -1,5 +1,9 @@
bin/openalchemist
-%%DATADIR%%/skins/aqua.zip
-%%DATADIR%%/skins/brushed.zip
-@dirrm %%DATADIR%%/skins
+bin/openalchemist-config
+%%DATADIR%%/loading.png
+%%DATADIR%%/logo.png
+%%DATADIR%%/logo_svg.svg
+%%DATADIR%%/aqua.zip
+%%DATADIR%%/brushed.zip
+%%DATADIR%%/vectoriel.zip
@dirrm %%DATADIR%%