aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2007-08-25 18:09:49 +0000
committerGreg Lewis <glewis@FreeBSD.org>2007-08-25 18:09:49 +0000
commite9b36c2745bb4d0b086e3c9c60337120fe675324 (patch)
tree9afafed8aa1daed3a440d050424980b682cb9463 /games
parentd29c72cbce73a997d8a86dd6e4714f4e4b2d5aa7 (diff)
downloadports-e9b36c2745bb4d0b086e3c9c60337120fe675324.tar.gz
ports-e9b36c2745bb4d0b086e3c9c60337120fe675324.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/slashem-tty/Makefile3
-rw-r--r--games/slashem-tty/files/patch-config.h2
-rw-r--r--games/slashem-tty/files/patch-makefile.top2
-rw-r--r--games/unnethack/Makefile3
-rw-r--r--games/unnethack/files/patch-config.h2
-rw-r--r--games/unnethack/files/patch-makefile.top2
6 files changed, 8 insertions, 6 deletions
diff --git a/games/slashem-tty/Makefile b/games/slashem-tty/Makefile
index 43a93079554a..664a84cdd5b0 100644
--- a/games/slashem-tty/Makefile
+++ b/games/slashem-tty/Makefile
@@ -22,10 +22,11 @@ SUB_FILES+= pkg-deinstall
MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
+MAKE_ENV+= DATADIR="${DATADIR}"
post-patch:
${REINPLACE_CMD} -e \
- "s@%%PREFIX%%@${PREFIX}@g" ${WRKSRC}/include/config.h
+ "s@%%DATADIR%%@${DATADIR}@g" ${WRKSRC}/include/config.h
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
diff --git a/games/slashem-tty/files/patch-config.h b/games/slashem-tty/files/patch-config.h
index 1d9ceca5348d..aeae766ed175 100644
--- a/games/slashem-tty/files/patch-config.h
+++ b/games/slashem-tty/files/patch-config.h
@@ -33,7 +33,7 @@ $FreeBSD$
# define HACKDIR "nethackdir" /* nethack directory */
# else
-# define HACKDIR "."
-+# define HACKDIR "%%PREFIX%%/share/slashem" /* nethack directory */
++# define HACKDIR "%%DATADIR%%" /* nethack directory */
# endif
# endif
diff --git a/games/slashem-tty/files/patch-makefile.top b/games/slashem-tty/files/patch-makefile.top
index b832d5afe042..1e365b96c6c0 100644
--- a/games/slashem-tty/files/patch-makefile.top
+++ b/games/slashem-tty/files/patch-makefile.top
@@ -32,7 +32,7 @@ $FreeBSD$
# Defs. for non file areas support.
-GAMEDIR = $(PREFIX)/local/slashemdir
-+GAMEDIR = $(PREFIX)/share/${GAME}
++GAMEDIR = $(DATADIR)
VARDIR = $(GAMEDIR)
FILE_AREA_VAR = $(VARDIR)
FILE_AREA_SAVE = $(VARDIR)/save
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index 43a93079554a..664a84cdd5b0 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -22,10 +22,11 @@ SUB_FILES+= pkg-deinstall
MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
+MAKE_ENV+= DATADIR="${DATADIR}"
post-patch:
${REINPLACE_CMD} -e \
- "s@%%PREFIX%%@${PREFIX}@g" ${WRKSRC}/include/config.h
+ "s@%%DATADIR%%@${DATADIR}@g" ${WRKSRC}/include/config.h
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
diff --git a/games/unnethack/files/patch-config.h b/games/unnethack/files/patch-config.h
index 1d9ceca5348d..aeae766ed175 100644
--- a/games/unnethack/files/patch-config.h
+++ b/games/unnethack/files/patch-config.h
@@ -33,7 +33,7 @@ $FreeBSD$
# define HACKDIR "nethackdir" /* nethack directory */
# else
-# define HACKDIR "."
-+# define HACKDIR "%%PREFIX%%/share/slashem" /* nethack directory */
++# define HACKDIR "%%DATADIR%%" /* nethack directory */
# endif
# endif
diff --git a/games/unnethack/files/patch-makefile.top b/games/unnethack/files/patch-makefile.top
index b832d5afe042..1e365b96c6c0 100644
--- a/games/unnethack/files/patch-makefile.top
+++ b/games/unnethack/files/patch-makefile.top
@@ -32,7 +32,7 @@ $FreeBSD$
# Defs. for non file areas support.
-GAMEDIR = $(PREFIX)/local/slashemdir
-+GAMEDIR = $(PREFIX)/share/${GAME}
++GAMEDIR = $(DATADIR)
VARDIR = $(GAMEDIR)
FILE_AREA_VAR = $(VARDIR)
FILE_AREA_SAVE = $(VARDIR)/save