aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-17 22:47:50 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-17 22:47:50 +0000
commite9cb0e0ba325f236bbd6d76368c45dd8708b7069 (patch)
treeb75cc24de263cba191e90851d04cdd19db6aa48b /games
parent19a6e51b22954673826f209480ba4fbd283eb1f8 (diff)
downloadports-e9cb0e0ba325f236bbd6d76368c45dd8708b7069.tar.gz
ports-e9cb0e0ba325f236bbd6d76368c45dd8708b7069.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/alephone/Makefile8
-rw-r--r--games/asc/Makefile4
-rw-r--r--games/fgfs-base/Makefile8
-rw-r--r--games/flightgear-data/Makefile8
-rw-r--r--games/flightgear/Makefile8
-rw-r--r--games/rtb/Makefile8
6 files changed, 39 insertions, 5 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index 8f677a4475c5..9ea6be5a6dd3 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -22,6 +22,12 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${PERL} -pi -e 's,^#include \"network_modem.h\".*,,' \
${WRKSRC}/Source_Files/Network/network.cpp \
@@ -32,4 +38,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/asc/Makefile b/games/asc/Makefile
index eb352b690e91..145be0e79edc 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -35,6 +35,10 @@ OPTIONS= MUSIC "Install extra music files" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if defined(WITH_MUSIC)
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} frontiers.mp3 time_to_strike.mp3 machine_wars.mp3
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/games/fgfs-base/Makefile b/games/fgfs-base/Makefile
index 5d16ec5d7e91..2852beed6f88 100644
--- a/games/fgfs-base/Makefile
+++ b/games/fgfs-base/Makefile
@@ -40,6 +40,12 @@ CONFIGURE_ARGS= --with-threads
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -53,4 +59,4 @@ do-install:
@(cd ${WRKSRC}/data && ${FIND} . -type f |\
${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/flightgear-data/Makefile b/games/flightgear-data/Makefile
index 5d16ec5d7e91..2852beed6f88 100644
--- a/games/flightgear-data/Makefile
+++ b/games/flightgear-data/Makefile
@@ -40,6 +40,12 @@ CONFIGURE_ARGS= --with-threads
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -53,4 +59,4 @@ do-install:
@(cd ${WRKSRC}/data && ${FIND} . -type f |\
${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 5d16ec5d7e91..2852beed6f88 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -40,6 +40,12 @@ CONFIGURE_ARGS= --with-threads
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -53,4 +59,4 @@ do-install:
@(cd ${WRKSRC}/data && ${FIND} . -type f |\
${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 03a2b485b0d5..e1e13d6f03e5 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -29,6 +29,12 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -37,4 +43,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/RealTimeBattle.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>