aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-07-04 13:12:01 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-07-04 13:12:01 +0000
commit9bb659e4ba4b9671f771eb67045a09f536ed2758 (patch)
tree24fa05f025abed429a560b5b0f234a789b9a4da9 /games
parentcf9fe05398248394ab1b747d8f2b6bf5c82af363 (diff)
downloadports-9bb659e4ba4b9671f771eb67045a09f536ed2758.tar.gz
ports-9bb659e4ba4b9671f771eb67045a09f536ed2758.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/vamos/Makefile14
-rw-r--r--games/vamos/distinfo4
-rw-r--r--games/vamos/files/patch-configure20
-rw-r--r--games/vamos/files/patch-include::vamos::geometry::Ac3d.h10
-rw-r--r--games/vamos/files/patch-include::vamos::geometry::Three_Vetor.h10
-rw-r--r--games/vamos/files/patch-track::Road_Segment.cc10
-rw-r--r--games/vamos/pkg-plist17
7 files changed, 28 insertions, 57 deletions
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index 24873eec6855..8e7d0b41807a 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= vamos
-PORTVERSION= 0.5.3
+PORTVERSION= 0.5.4
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,6 +23,7 @@ LIB_DEPENDS= cppunit-1.10.2:${PORTSDIR}/devel/cppunit \
USE_GL= yes
USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -33,9 +34,9 @@ INSTALLS_SHLIB= yes
INFO= vamos
-CPPFLAGS= -I${LOCALBASE}/include/libpng -I${X11BASE}/include \
- ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lusbhid -lGL -lGLU -lglut \
+CPPFLAGS= -I${LOCALBASE}/include/libpng -I${LOCALBASE}/include \
+ -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lusbhid \
${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
@@ -47,4 +48,9 @@ BROKEN= "Does not compile on 4.x (port and dependencies need recent C++ compile
post-extract:
@${RM} -f ${WRKSRC}/doc/*.info*
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^AM_CXXFLAGS|#AM_CXXFLAGS|g ; \
+ s|-ldl||g'
+
.include <bsd.port.post.mk>
diff --git a/games/vamos/distinfo b/games/vamos/distinfo
index a41465e7bce8..6fbae1c3a8f3 100644
--- a/games/vamos/distinfo
+++ b/games/vamos/distinfo
@@ -1,2 +1,2 @@
-MD5 (vamos-0.5.3.tar.gz) = d104f41d5da3ac5d2a25eedf4a193422
-SIZE (vamos-0.5.3.tar.gz) = 1455204
+MD5 (vamos-0.5.4.tar.gz) = c6247a0b70583d021b6dbec10609c67d
+SIZE (vamos-0.5.4.tar.gz) = 1465833
diff --git a/games/vamos/files/patch-configure b/games/vamos/files/patch-configure
index 4340b02640f2..74d34a466807 100644
--- a/games/vamos/files/patch-configure
+++ b/games/vamos/files/patch-configure
@@ -1,14 +1,6 @@
---- configure.orig Tue Oct 12 11:11:25 2004
-+++ configure Tue Nov 2 19:29:17 2004
-@@ -8722,7 +8722,6 @@
- fi
-
- LIBS="$LIBS -L$x_libraries"
--CXXFLAGS="-gstabs+ -Wall -pedantic"
-
-
- ac_ext=cc
-@@ -11352,81 +11351,6 @@
+--- configure.orig Thu Jun 30 10:58:52 2005
++++ configure Sat Jul 2 13:59:13 2005
+@@ -11364,81 +11364,6 @@
opengl_LIBS="$LIBS $x_suffix"
@@ -90,11 +82,11 @@
echo "$as_me:$LINENO: checking for glutGetModifiers in -lglut" >&5
echo $ECHO_N "checking for glutGetModifiers in -lglut... $ECHO_C" >&6
if test "${ac_cv_lib_glut_glutGetModifiers+set}" = set; then
-@@ -11500,7 +11424,6 @@
+@@ -11512,7 +11437,6 @@
fi
- fi
-
- LIBS="$LIBS $x_suffix"
else
+
+
diff --git a/games/vamos/files/patch-include::vamos::geometry::Ac3d.h b/games/vamos/files/patch-include::vamos::geometry::Ac3d.h
deleted file mode 100644
index 9382b1d8a500..000000000000
--- a/games/vamos/files/patch-include::vamos::geometry::Ac3d.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- include/vamos/geometry/Ac3d.h.orig Fri Sep 26 11:25:48 2003
-+++ include/vamos/geometry/Ac3d.h Fri Oct 3 18:09:20 2003
-@@ -25,6 +25,7 @@
-
- #include <GL/gl.h>
-
-+#include <fstream>
- #include <string>
- #include <vector>
-
diff --git a/games/vamos/files/patch-include::vamos::geometry::Three_Vetor.h b/games/vamos/files/patch-include::vamos::geometry::Three_Vetor.h
deleted file mode 100644
index 1d18e02249aa..000000000000
--- a/games/vamos/files/patch-include::vamos::geometry::Three_Vetor.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- include/vamos/geometry/Three_Vector.h.orig Thu Feb 3 12:17:54 2005
-+++ include/vamos/geometry/Three_Vector.h Sat Feb 5 20:11:47 2005
-@@ -19,6 +19,7 @@
- #define _THREE_VECTOR_H_
-
- #include <iostream>
-+#include <cmath>
-
- // A three-element vector. Useful for representing physical quantites
- // like position, veocity or force.
diff --git a/games/vamos/files/patch-track::Road_Segment.cc b/games/vamos/files/patch-track::Road_Segment.cc
deleted file mode 100644
index a315c5369996..000000000000
--- a/games/vamos/files/patch-track::Road_Segment.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- track/Road_Segment.cc.orig Mon Oct 27 10:15:10 2003
-+++ track/Road_Segment.cc Mon Nov 10 02:10:01 2003
-@@ -21,6 +21,7 @@
-
- #include <GL/glut.h>
-
-+#include <algorithm>
- #include <cmath>
- #include <cassert>
-
diff --git a/games/vamos/pkg-plist b/games/vamos/pkg-plist
index 79639dbc3cf0..fd51fc4b109a 100644
--- a/games/vamos/pkg-plist
+++ b/games/vamos/pkg-plist
@@ -4,13 +4,13 @@ include/vamos/body/Brake.h
include/vamos/body/Car.h
include/vamos/body/Clutch.h
include/vamos/body/Contact_Point.h
+include/vamos/body/Dashboard.h
include/vamos/body/Differential.h
include/vamos/body/Drivetrain.h
include/vamos/body/Engine.h
include/vamos/body/Exerter.h
include/vamos/body/Frame.h
include/vamos/body/Fuel_Tank.h
-include/vamos/body/Gauge.h
include/vamos/body/Gl_Car.h
include/vamos/body/Particle.h
include/vamos/body/Rigid_Body.h
@@ -18,22 +18,21 @@ include/vamos/body/Suspension.h
include/vamos/body/Tire.h
include/vamos/body/Transmission.h
include/vamos/body/Wheel.h
-include/vamos/geometry/Ac3d.h
include/vamos/geometry/Constants.h
include/vamos/geometry/Conversions.h
-include/vamos/geometry/Gl_Texture_Image.h
-include/vamos/geometry/Handle.h
include/vamos/geometry/Inertia_Tensor.h
include/vamos/geometry/Interpolator.h
include/vamos/geometry/Linear_Interpolator.h
include/vamos/geometry/Material.h
-include/vamos/geometry/Sample.h
include/vamos/geometry/Spline.h
-include/vamos/geometry/Texture_Image.h
include/vamos/geometry/Three_Matrix.h
include/vamos/geometry/Three_Vector.h
-include/vamos/geometry/Two_Point.h
+include/vamos/geometry/Two_Vector.h
include/vamos/geometry/XML_Parser.h
+include/vamos/media/Ac3d.h
+include/vamos/media/Sample.h
+include/vamos/media/Texture_Image.h
+include/vamos/track/Gl_Road_Segment.h
include/vamos/track/Road_Segment.h
include/vamos/track/Strip_Track.h
include/vamos/track/Track.h
@@ -48,6 +47,9 @@ lib/libvamos-body.so.0
lib/libvamos-geometry.a
lib/libvamos-geometry.so
lib/libvamos-geometry.so.0
+lib/libvamos-media.a
+lib/libvamos-media.so
+lib/libvamos-media.so.0
lib/libvamos-track.a
lib/libvamos-track.so
lib/libvamos-track.so.0
@@ -171,6 +173,7 @@ lib/libvamos-world.so.0
@dirrm %%DATADIR%%
@dirrm include/vamos/world
@dirrm include/vamos/track
+@dirrm include/vamos/media
@dirrm include/vamos/geometry
@dirrm include/vamos/body
@dirrm include/vamos