aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-02 14:08:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-02 14:08:38 +0000
commit015046aa09a75cb832342151dff48a04cb4b0675 (patch)
tree8217e92b0109f48806a75cbd3400f4ce384b31c3 /games
parentdc78890adfc3cd5356d3ce7c171042a339152b5b (diff)
downloadports-015046aa09a75cb832342151dff48a04cb4b0675.tar.gz
ports-015046aa09a75cb832342151dff48a04cb4b0675.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile2
-rw-r--r--games/linux-steam/Makefile30
-rw-r--r--games/linux-steam/distinfo1
-rw-r--r--games/linux-steam/pkg-descr19
-rw-r--r--games/linux-steam/pkg-message21
-rw-r--r--games/linux-steam/pkg-plist2
6 files changed, 74 insertions, 1 deletions
diff --git a/games/Makefile b/games/Makefile
index e8cf406556c7..875103456e76 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -236,6 +236,7 @@
SUBDIR += lincity
SUBDIR += linux-nwserver
SUBDIR += linux-q3ademo
+ SUBDIR += linux-steam
SUBDIR += linux_nwnclient
SUBDIR += linux_nwndata
SUBDIR += lm-solve
@@ -370,7 +371,6 @@
SUBDIR += spider
SUBDIR += ssamtse
SUBDIR += starlanes
- SUBDIR += steam
SUBDIR += stvef-paks
SUBDIR += stvef-server
SUBDIR += sxsame
diff --git a/games/linux-steam/Makefile b/games/linux-steam/Makefile
new file mode 100644
index 000000000000..b58dde3e7969
--- /dev/null
+++ b/games/linux-steam/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: hlstats
+# Date created: 29 December 2003
+# Whom: hideki
+#
+# $FreeBSD$
+#
+
+PORTNAME= steam
+PORTVERSION= 1.0
+CATEGORIES= games linux
+MASTER_SITES= http://hlstats.neojapangz.com/files/
+PKGNAMEPREFIX= linux-
+
+MAINTAINER= hido@neojapangz.com
+COMMENT= Half Life dedicated server running on steam
+
+IS_INTERACTIVE= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
+USE_LINUX= yes
+
+do-build:
+ @ ${CHMOD} +x ${WRKDIR}/hldsupdatetool.bin && cd ${WRKDIR} && ./hldsupdatetool.bin
+ @ ${CAT} pkg-message | ${SED} 's|%%PREFIX%%|${PREFIX}|' > ${PKGMESSAGE}
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/${PORTNAME}
+ @ ${CP} ${WRKDIR}/${PORTNAME} ${PREFIX}/${PORTNAME}/
+ @ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/linux-steam/distinfo b/games/linux-steam/distinfo
new file mode 100644
index 000000000000..eb9848504e9f
--- /dev/null
+++ b/games/linux-steam/distinfo
@@ -0,0 +1 @@
+MD5 (steam-1.0.tar.gz) = 3d32775d1cf34ff8c9c938312e5128b8
diff --git a/games/linux-steam/pkg-descr b/games/linux-steam/pkg-descr
new file mode 100644
index 000000000000..f184a22e1426
--- /dev/null
+++ b/games/linux-steam/pkg-descr
@@ -0,0 +1,19 @@
+Steam is Valve's new way of getting games into your hands ASAP. Games like
+Half-Life, Counter-Strike, and Counter-Strike Condition Zero
+are all being made available through Steam.
+
+Steam games are automatically kept up-to-date with the latest content
+and revisions. Steam also includes an instant-message client which
+even works while you're in-game.
+
+At its core, Steam is a distributed file system and shared set of technology
+components that can be implemented into any software application.
+
+With Steam, developers are given integrated tools for direct-content
+publishing, flexible billing, ensured-version
+control, anti-cheating, anti-piracy, and more.
+
+WWW: http://www.steampowered.com/
+
+- Hideki
+hido@neojapangz.com
diff --git a/games/linux-steam/pkg-message b/games/linux-steam/pkg-message
new file mode 100644
index 000000000000..51c58bc40490
--- /dev/null
+++ b/games/linux-steam/pkg-message
@@ -0,0 +1,21 @@
+##################################################################
+# To get started goto %%PREFIX%%/steam #
+# and type the following to create a steam-user. #
+# ./steam -create <username> <password> <question> <answer> #
+# Example #
+# ./steam -create johndoe l337cr3w nameofmygun M4A1 #
+# #
+# Once you have a steam-user account or if you have a registered #
+# account already type the following to start updating your HLDS #
+# ./steam -update <game> <installdir> <username> [<password> [Y]]#
+# example #
+# ./steam -update cstrike . johndoe l337cr3w Y #
+# #
+# Once your server has been updated type the following #
+# to test your server. #
+# ./hlds_run -game cstrike +maxplayers 10 +map de_dust #
+# #
+# For instructions on configuring your server goto #
+# http://server.counter-strike.net #
+# #
+##################################################################
diff --git a/games/linux-steam/pkg-plist b/games/linux-steam/pkg-plist
new file mode 100644
index 000000000000..f9cf2635a5a8
--- /dev/null
+++ b/games/linux-steam/pkg-plist
@@ -0,0 +1,2 @@
+steam/steam
+@dirrm steam