aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-02-26 03:06:56 +0000
committerWill Andrews <will@FreeBSD.org>2001-02-26 03:06:56 +0000
commit14577903ab270dfd5a81a967c2dc345549e3e7d2 (patch)
tree87f89553a2d43025c0c5af29b1d037a9b30618ed /games
parent5bd279f79324976f179d578a519323bb35993ce2 (diff)
downloadports-14577903ab270dfd5a81a967c2dc345549e3e7d2.tar.gz
ports-14577903ab270dfd5a81a967c2dc345549e3e7d2.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/xjump/Makefile35
-rw-r--r--games/xjump/distinfo1
-rw-r--r--games/xjump/pkg-comment1
-rw-r--r--games/xjump/pkg-descr7
-rw-r--r--games/xjump/pkg-message14
-rw-r--r--games/xjump/pkg-plist1
7 files changed, 60 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index eeedee2d6ada..feb017231b58 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -240,6 +240,7 @@
SUBDIR += xisola
SUBDIR += xjewel
SUBDIR += xjig
+ SUBDIR += xjump
SUBDIR += xjumpjump
SUBDIR += xkobo
SUBDIR += xkoules
diff --git a/games/xjump/Makefile b/games/xjump/Makefile
new file mode 100644
index 000000000000..3eacafa98ef5
--- /dev/null
+++ b/games/xjump/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xjump
+# Date created: Sun 25 Feb 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= xjump
+PORTVERSION= 2.7
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.freesoftware.com/pub/linux/debian/${MASTER_SITE_SUBDIR}/ \
+ ftp://ftp.jp.debian.org/debian/${MASTER_SITE_SUBDIR}/ \
+ ftp://ftp-linux.cc.gatech.edu/pub/linux/distributions/debian/${MASTER_SITE_SUBDIR}/ \
+ ftp://ftp.de.debian.org/debian/${MASTER_SITE_SUBDIR}/ \
+ ftp://ftp.debian.org/debian/${MASTER_SITE_SUBDIR}/
+MASTER_SITE_SUBDIR= dists/stable/main/source/games
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/g}
+ALL_TARGET= xjump
+
+pre-build:
+ ${PERL} -pi -e "s@gcc -O2@${CC} ${CFLAGS}@g; \
+ s@/var/lib/games/xjump@/var/games@g; \
+ s@\)/record@\)/xjump.record@g; \
+ s@2755@2775@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} -g games ${WRKSRC}/xjump ${PREFIX}/bin
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/xjump/distinfo b/games/xjump/distinfo
new file mode 100644
index 000000000000..292019352d17
--- /dev/null
+++ b/games/xjump/distinfo
@@ -0,0 +1 @@
+MD5 (xjump_2.7.tar.gz) = c97684eb7ac603a8a3f2a28ba76d3321
diff --git a/games/xjump/pkg-comment b/games/xjump/pkg-comment
new file mode 100644
index 000000000000..59f56d03bf68
--- /dev/null
+++ b/games/xjump/pkg-comment
@@ -0,0 +1 @@
+A simple X game where one tries to jump up as many levels as possible
diff --git a/games/xjump/pkg-descr b/games/xjump/pkg-descr
new file mode 100644
index 000000000000..ccaa25f64fe2
--- /dev/null
+++ b/games/xjump/pkg-descr
@@ -0,0 +1,7 @@
+XJump is a cool game based on simple X graphics where the object is to
+get the player up as many levels as possible. Quite possibly one of
+the most addictive games out there.
+
+Author: Masato Taruishi <taru@debian.or.jp>
+
+--will
diff --git a/games/xjump/pkg-message b/games/xjump/pkg-message
new file mode 100644
index 000000000000..e01065d362a9
--- /dev/null
+++ b/games/xjump/pkg-message
@@ -0,0 +1,14 @@
+
+--- NOTICE ---
+xjump is set to use /var/games/xjump.record for its scorekeeping.
+However, due to security concerns, xjump is not installed setgid
+games, and thus cannot write this file. In order to enable keeping
+scores, you will need to run these commands:
+
+ 1) touch /var/games/xjump.record
+ 2) chmod 664 /var/games/xjump.record
+ 3) chmod 2755 ${PREFIX}/bin/xjump
+
+where ${PREFIX} is the prefix that xjump was installed under,
+which is usually /usr/X11R6.
+
diff --git a/games/xjump/pkg-plist b/games/xjump/pkg-plist
new file mode 100644
index 000000000000..38244f72b038
--- /dev/null
+++ b/games/xjump/pkg-plist
@@ -0,0 +1 @@
+bin/xjump