aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-22 19:16:47 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-22 19:16:47 +0000
commit53fb1c446184a0b0e65a08a4b71314b3ab342507 (patch)
treeb38c0418076cc127ea35897f6ee8311403538933 /games
parentc5622a1d635662d97dee92567867b762e60a1464 (diff)
downloadports-53fb1c446184a0b0e65a08a4b71314b3ab342507.tar.gz
ports-53fb1c446184a0b0e65a08a4b71314b3ab342507.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/uhexen2-extras/Makefile77
1 files changed, 28 insertions, 49 deletions
diff --git a/games/uhexen2-extras/Makefile b/games/uhexen2-extras/Makefile
index aafdd58e52e2..ba775373f868 100644
--- a/games/uhexen2-extras/Makefile
+++ b/games/uhexen2-extras/Makefile
@@ -5,7 +5,9 @@ PORTNAME= uhexen2
PORTVERSION= 1.4.1
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/HoT%20-%20Other%20content/extra%20data
+MASTER_SITES= SF/${PORTNAME}/HoT%20-%20Other%20content/extra%20data \
+ SF/${PORTNAME}/HoT%20-%20Other%20content/hexen2%20mods:mods \
+ SF/${PORTNAME}/HoT%20-%20Other%20content/hexenworld%20mods:hw_mods
PKGNAMESUFFIX= -extras
EXTRACT_SUFX= .tgz
DISTFILES= #
@@ -21,69 +23,46 @@ NO_BUILD= yes
OPTIONS_MULTI= EXTRA
OPTIONS_MULTI_EXTRA= HEXEN2_DEMOS HEXEN2_LITS HEXEN2_MODS HW_MODS
OPTIONS_DEFAULT= HEXEN2_DEMOS HEXEN2_LITS HEXEN2_MODS HW_MODS
-HEXEN2_DEMOS_DESC= Install pre-recorded demos for Hexen II
-HEXEN2_LITS_DESC= Install colored light data for Hexen II
-HEXEN2_MODS_DESC= Install several mods for Hexen II
-HW_MODS_DESC= Install several mods for HexenWorld
+OPTIONS_SUB= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+HEXEN2_DEMOS_DESC= Install pre-recorded demos for Hexen II
+HEXEN2_DEMOS_DISTFILES= hexen2-demos${EXTRACT_SUFX}
-.if ${PORT_OPTIONS:MHEXEN2_DEMOS}
-DISTFILES+= hexen2-demos${EXTRACT_SUFX}
-PLIST_SUB+= HEXEN2_DEMOS=""
-.else
-PLIST_SUB+= HEXEN2_DEMOS="@comment "
-.endif
+HEXEN2_LITS_DESC= Install colored light data for Hexen II
+HEXEN2_LITS_DISTFILES= hexen2-lit_files${EXTRACT_SUFX}
-.if ${PORT_OPTIONS:MHEXEN2_LITS}
-DISTFILES+= hexen2-lit_files${EXTRACT_SUFX}
-PLIST_SUB+= HEXEN2_LITS=""
-.else
-PLIST_SUB+= HEXEN2_LITS="@comment "
-.endif
+HEXEN2_MODS_DESC= Install several mods for Hexen II
+HEXEN2_MODS_DISTFILES= apocbot-0.2.0${EXTRACT_SUFX}:mods \
+ fo4d${EXTRACT_SUFX}:mods \
+ hcbots-1.0.4${EXTRACT_SUFX}:mods
-.if ${PORT_OPTIONS:MHEXEN2_MODS}
-MASTER_SITES+= SF/${PORTNAME}/HoT%20-%20Other%20content/hexen2%20mods:mods
-DISTFILES+= apocbot-0.2.0${EXTRACT_SUFX}:mods \
- fo4d${EXTRACT_SUFX}:mods \
- hcbots-1.0.4${EXTRACT_SUFX}:mods
-PLIST_SUB+= HEXEN2_MODS=""
-.else
-PLIST_SUB+= HEXEN2_MODS="@comment "
-.endif
+HW_MODS_DESC= Install several mods for HexenWorld
+HW_MODS_DISTFILES= dungeonbreak${EXTRACT_SUFX}:hw_mods \
+ hexarena${EXTRACT_SUFX}:hw_mods \
+ hwctf${EXTRACT_SUFX}:hw_mods \
+ rivalkingdoms${EXTRACT_SUFX}:hw_mods \
+ siege${EXTRACT_SUFX}:hw_mods
-.if ${PORT_OPTIONS:MHW_MODS}
-MASTER_SITES+= SF/${PORTNAME}/HoT%20-%20Other%20content/hexenworld%20mods:hw_mods
-DISTFILES+= dungeonbreak${EXTRACT_SUFX}:hw_mods \
- hexarena${EXTRACT_SUFX}:hw_mods \
- hwctf${EXTRACT_SUFX}:hw_mods \
- rivalkingdoms${EXTRACT_SUFX}:hw_mods \
- siege${EXTRACT_SUFX}:hw_mods
-PLIST_SUB+= HW_MODS=""
-.else
-PLIST_SUB+= HW_MODS="@comment "
-.endif
+.include <bsd.port.options.mk>
do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/data1
.if ${PORT_OPTIONS:MHEXEN2_DEMOS}
- ${INSTALL_DATA} ${WRKDIR}/data1/*demo* ${DATADIR}/data1
+ ${INSTALL_DATA} ${WRKDIR}/data1/*demo* ${STAGEDIR}${DATADIR}/data1
.endif
.if ${PORT_OPTIONS:MHEXEN2_LITS}
- ${MKDIR} ${DATADIR}/data1/maps
- ${INSTALL_DATA} ${WRKDIR}/data1/maps/*.lit ${DATADIR}/data1/maps
+ @${MKDIR} ${STAGEDIR}${DATADIR}/data1/maps
+ ${INSTALL_DATA} ${WRKDIR}/data1/maps/*.lit ${STAGEDIR}${DATADIR}/data1/maps
.endif
.if ${PORT_OPTIONS:MHEXEN2_MODS}
-.for f in apocbot fo4d hcbots
- @(cd ${WRKDIR} && ${COPYTREE_SHARE} ${f} ${DATADIR})
-.endfor
+ (cd ${WRKDIR} && ${COPYTREE_SHARE} "apocbot fo4d hcbots" \
+ ${STAGEDIR}${DATADIR})
.endif
.if ${PORT_OPTIONS:MHW_MODS}
-.for f in db hexarena hwctf rk siege
- @(cd ${WRKDIR} && ${COPYTREE_SHARE} ${f} ${DATADIR})
-.endfor
+ (cd ${WRKDIR} && ${COPYTREE_SHARE} "db hexarena hwctf rk siege" \
+ ${STAGEDIR}${DATADIR})
.for f in hexarena hwctf rk siege
- ${INSTALL_DATA} ${WRKDIR}/data1/${f}.cfg ${DATADIR}/data1
+ ${INSTALL_DATA} ${WRKDIR}/data1/${f}.cfg ${STAGEDIR}${DATADIR}/data1
.endfor
.endif