aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-02-22 01:35:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-02-22 01:35:01 +0000
commit9f00ec9711ee4ffd2621b7ac350233ce832f4e98 (patch)
tree58fdf7fc4ae281b9fd8603b1cbe24cb88cb8d206 /games
parent9e09065d1878a8849ce2445240ab683ce9afd430 (diff)
downloadports-9f00ec9711ee4ffd2621b7ac350233ce832f4e98.tar.gz
ports-9f00ec9711ee4ffd2621b7ac350233ce832f4e98.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/ggz-kde-client/Makefile28
-rw-r--r--games/ggz-kde-client/distinfo3
-rw-r--r--games/ggz-kde-client/files/patch-configure11
-rw-r--r--games/ggz-kde-client/pkg-descr20
-rw-r--r--games/ggz-kde-client/pkg-plist239
6 files changed, 302 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 257d9575e2b0..a7222587c3e3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -207,6 +207,7 @@
SUBDIR += ggz-client-libs
SUBDIR += ggz-gtk-client
SUBDIR += ggz-gtk-games
+ SUBDIR += ggz-kde-client
SUBDIR += ggz-sdl-games
SUBDIR += ggz-txt-client
SUBDIR += gillo
diff --git a/games/ggz-kde-client/Makefile b/games/ggz-kde-client/Makefile
new file mode 100644
index 000000000000..867d579c3f38
--- /dev/null
+++ b/games/ggz-kde-client/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ggz-kde-client
+# Date created: Feb. 19, 2006
+# Whom: yinjieh
+#
+# $FreeBSD$
+#
+
+PORTNAME= ggz-kde-client
+PORTVERSION= 0.0.12
+CATEGORIES= games
+MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
+ http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}
+
+MAINTAINER= yinjieh@csie.nctu.edu.tw
+COMMENT= The GGZ Gaming Zone - KDE Client
+
+LIB_DEPENDS= ggzcore.8:${PORTSDIR}/games/ggz-client-libs
+
+GNU_CONFIGURE= yes
+USE_GCC= 3.3+
+USE_GMAKE= yes
+USE_KDELIBS_VER= 3
+
+MAN6= compcal.6 ggzap.6 keepalivecontrol.6 \
+ kggz.6 kgrubby.6 shadowbridge.6
+
+.include <bsd.port.mk>
diff --git a/games/ggz-kde-client/distinfo b/games/ggz-kde-client/distinfo
new file mode 100644
index 000000000000..79d0c7a9fb3f
--- /dev/null
+++ b/games/ggz-kde-client/distinfo
@@ -0,0 +1,3 @@
+MD5 (ggz-kde-client-0.0.12.tar.gz) = 2053476462033c15f828edd4d403c6e0
+SHA256 (ggz-kde-client-0.0.12.tar.gz) = 41691983936867d2e58b93a25d297174fa5be28d3486191698822bf4736b7992
+SIZE (ggz-kde-client-0.0.12.tar.gz) = 1811920
diff --git a/games/ggz-kde-client/files/patch-configure b/games/ggz-kde-client/files/patch-configure
new file mode 100644
index 000000000000..b4349ebcd20f
--- /dev/null
+++ b/games/ggz-kde-client/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sun Feb 19 10:38:31 2006
++++ configure Sun Feb 19 10:38:51 2006
+@@ -33869,7 +33869,7 @@
+ #define WITH_HOWL 1
+ _ACEOF
+
+- HOWL_INCLUDES="-I/usr/include/howl"
++ HOWL_INCLUDES="-I/usr/include/howl -I/usr/local/include/howl"
+ LIB_HOWL="-lhowl -lpthread"
+
+
diff --git a/games/ggz-kde-client/pkg-descr b/games/ggz-kde-client/pkg-descr
new file mode 100644
index 000000000000..c6427c3295d4
--- /dev/null
+++ b/games/ggz-kde-client/pkg-descr
@@ -0,0 +1,20 @@
+================================================================
+The GGZ Gaming Zone - KDE Frontends and Clients - Version 0.0.12
+================================================================
+
+Content of GGZ-KDE:
+ - GGZCore++, a high-level C++ API for handling online games,
+ largely based on the ggzcore C library.
+ - KGGZ, the well-known frontend. It provides a chat and is
+ configurable.
+ - GGZap, a GGZ quick launcher which can put itself into the taskbar.
+ - KCMGGZ, a set of configuration dialogs for the KDE control center.
+ - KIO_GGZ, a KIO slave to browse GGZ servers.
+ - KIO_GGZMeta, another KIO slave which provides a general interface
+ to meta servers of any kind (including the GGZ meta server).
+ - ShadowBride, a graphical game protocol sniffing tool.
+ - Keepalive Control, utility to administer Keepalive servers
+ - Competition Calendar, a viewer for game schedules and results
+ - KGrubby, a graphical configuration tool for grubby, the chatbot
+
+WWW: http://www.ggzgamingzone.org/
diff --git a/games/ggz-kde-client/pkg-plist b/games/ggz-kde-client/pkg-plist
new file mode 100644
index 000000000000..1e97b4166bc5
--- /dev/null
+++ b/games/ggz-kde-client/pkg-plist
@@ -0,0 +1,239 @@
+bin/compcal
+bin/ggzap
+bin/keepalivecontrol
+bin/kggz
+bin/kgrubby
+bin/shadowbridge
+lib/kde3/libkcm_ggz.la
+lib/kde3/libkcm_ggz.so
+lib/kde3/libkcm_ggz.so.0
+lib/kde3/libkcm_ggz_default.la
+lib/kde3/libkcm_ggz_default.so
+lib/kde3/libkcm_ggz_default.so.0
+lib/kde3/libkcm_ggz_games.la
+lib/kde3/libkcm_ggz_games.so
+lib/kde3/libkcm_ggz_games.so.0
+lib/kde3/libkcm_ggz_ggzd.la
+lib/kde3/libkcm_ggz_ggzd.so
+lib/kde3/libkcm_ggz_ggzd.so.0
+lib/kde3/libkcm_ggz_metaserver.la
+lib/kde3/libkcm_ggz_metaserver.so
+lib/kde3/libkcm_ggz_metaserver.so.0
+lib/kde3/libkio_ggz.la
+lib/kde3/libkio_ggz.so
+lib/kde3/libkio_ggz.so.0
+lib/kde3/libkio_ggzmeta.la
+lib/kde3/libkio_ggzmeta.so
+lib/kde3/libkio_ggzmeta.so.0
+share/applications/compcal.desktop
+share/applications/ggzap.desktop
+share/applications/kcmggz.desktop
+share/applications/keepalivecontrol.desktop
+share/applications/kggz.desktop
+share/applications/kgrubby.desktop
+share/applications/shadowbridge.desktop
+share/apps/compcal/event.png
+share/apps/keepalivecontrol/avatars.png
+share/apps/keepalivecontrol/frozenworld.png
+share/apps/keepalivecontrol/normalworld.png
+share/apps/keepalivecontrol/worlds.png
+share/apps/kggz/ggzap/redgear.png
+share/apps/kggz/ggzap/redgearmask.png
+share/apps/kggz/ggzap/tray.png
+share/apps/kggz/ggzap/trayradar.mng
+share/apps/kggz/help/ggz.png
+share/apps/kggz/help/goto.png
+share/apps/kggz/help/help.html
+share/apps/kggz/help/index.html
+share/apps/kggz/images/grubbybig.png
+share/apps/kggz/images/icons/browser.png
+share/apps/kggz/images/icons/cancel.png
+share/apps/kggz/images/icons/chat.png
+share/apps/kggz/images/icons/connect.png
+share/apps/kggz/images/icons/disconnect.png
+share/apps/kggz/images/icons/games/CCheckers.png
+share/apps/kggz/images/icons/games/CChess.png
+share/apps/kggz/images/icons/games/Checkers.png
+share/apps/kggz/images/icons/games/Chess.png
+share/apps/kggz/images/icons/games/Combat.png
+share/apps/kggz/images/icons/games/Copenhagen.png
+share/apps/kggz/images/icons/games/Dots.png
+share/apps/kggz/images/icons/games/Escape.png
+share/apps/kggz/images/icons/games/Freelords.png
+share/apps/kggz/images/icons/games/GGZCards.png
+share/apps/kggz/images/icons/games/Geekgame.png
+share/apps/kggz/images/icons/games/Hastings.png
+share/apps/kggz/images/icons/games/Hnefatafl.png
+share/apps/kggz/images/icons/games/Kamikaze.png
+share/apps/kggz/images/icons/games/Keepalive.png
+share/apps/kggz/images/icons/games/Krosswater.png
+share/apps/kggz/images/icons/games/LaPocha.png
+share/apps/kggz/images/icons/games/Muehle.png
+share/apps/kggz/images/icons/games/NetSpades.png
+share/apps/kggz/images/icons/games/Reversi.png
+share/apps/kggz/images/icons/games/TEG.png
+share/apps/kggz/images/icons/games/TicTacToe.png
+share/apps/kggz/images/icons/games/Widelands.png
+share/apps/kggz/images/icons/games/lounge.png
+share/apps/kggz/images/icons/games/notinstalled.png
+share/apps/kggz/images/icons/grubby.png
+share/apps/kggz/images/icons/info.png
+share/apps/kggz/images/icons/join.png
+share/apps/kggz/images/icons/langame.png
+share/apps/kggz/images/icons/launch.png
+share/apps/kggz/images/icons/metaserver.png
+share/apps/kggz/images/icons/module.png
+share/apps/kggz/images/icons/players.png
+share/apps/kggz/images/icons/players/admin.png
+share/apps/kggz/images/icons/players/banned.png
+share/apps/kggz/images/icons/players/bot.png
+share/apps/kggz/images/icons/players/botgrubby.png
+share/apps/kggz/images/icons/players/buddy.png
+share/apps/kggz/images/icons/players/guest.png
+share/apps/kggz/images/icons/players/lag0.png
+share/apps/kggz/images/icons/players/lag1.png
+share/apps/kggz/images/icons/players/lag2.png
+share/apps/kggz/images/icons/players/lag3.png
+share/apps/kggz/images/icons/players/lag4.png
+share/apps/kggz/images/icons/players/lag5.png
+share/apps/kggz/images/icons/players/player.png
+share/apps/kggz/images/icons/players/team-founder.png
+share/apps/kggz/images/icons/players/team-member.png
+share/apps/kggz/images/icons/players/you.png
+share/apps/kggz/images/icons/pref.png
+share/apps/kggz/images/icons/preferences.png
+share/apps/kggz/images/icons/quit.png
+share/apps/kggz/images/icons/server.png
+share/apps/kggz/images/icons/serverred.png
+share/apps/kggz/images/icons/startserver.png
+share/apps/kggz/images/icons/startup.png
+share/apps/kggz/images/icons/stopserver.png
+share/apps/kggz/images/icons/tables.png
+share/apps/kggz/images/icons/update.png
+share/apps/kggz/images/icons/watcher_off.png
+share/apps/kggz/images/icons/watcher_on.png
+share/apps/kggz/images/icons/watcher_room.png
+share/apps/kggz/images/splash/kggzsplash.png
+share/apps/kggz/images/splash/kggzsplash.svg
+share/apps/kggz/kcmggz/icons/game.png
+share/apps/kggz/kcmggz/icons/game_console.png
+share/apps/kggz/kcmggz/icons/game_gnome.png
+share/apps/kggz/kcmggz/icons/game_grubby.png
+share/apps/kggz/kcmggz/icons/game_kde.png
+share/apps/kggz/kcmggz/icons/game_sdl.png
+share/apps/kggz/kcmggz/icons/game_x11.png
+share/apps/kggz/kcmggz/icons/gear.png
+share/apps/kggz/shadowbridge/admin.png
+share/apps/kggz/shadowbridge/incoming.png
+share/apps/kggz/shadowbridge/outgoing.png
+share/apps/kgrubby/kgrubby.png
+share/config/compcalrc
+share/config/kggzrc
+share/doc/HTML/de/kggz/chatview.png
+share/doc/HTML/de/kggz/common
+share/doc/HTML/de/kggz/connection.png
+share/doc/HTML/de/kggz/grubby.png
+share/doc/HTML/de/kggz/index.cache.bz2
+share/doc/HTML/de/kggz/index.docbook
+share/doc/HTML/de/kggz/launch.png
+share/doc/HTML/de/kggz/motd.png
+share/doc/HTML/de/kggz/panel.png
+share/doc/HTML/de/kggz/profiles.png
+share/doc/HTML/en/kggz/chatview.png
+share/doc/HTML/en/kggz/common
+share/doc/HTML/en/kggz/connection.png
+share/doc/HTML/en/kggz/grubby.png
+share/doc/HTML/en/kggz/index.cache.bz2
+share/doc/HTML/en/kggz/index.docbook
+share/doc/HTML/en/kggz/launch.png
+share/doc/HTML/en/kggz/motd.png
+share/doc/HTML/en/kggz/panel.png
+share/doc/HTML/en/kggz/profiles.png
+share/doc/HTML/en/kioslave/ggz.docbook
+share/doc/HTML/en/kioslave/ggz.html
+share/doc/HTML/en/kioslave/ggzmeta.docbook
+share/doc/HTML/en/kioslave/ggzmeta.html
+share/doc/ggzcore++/README.ggzcore++
+share/doc/ggzcore++/html/GGZCore.html
+share/doc/ggzcore++/html/GGZCoreCommon_h.html
+share/doc/ggzcore++/html/GGZCoreConf.html
+share/doc/ggzcore++/html/GGZCoreConf_h.html
+share/doc/ggzcore++/html/GGZCoreConfio.html
+share/doc/ggzcore++/html/GGZCoreConfio_h.html
+share/doc/ggzcore++/html/GGZCoreGame.html
+share/doc/ggzcore++/html/GGZCoreGame_h.html
+share/doc/ggzcore++/html/GGZCoreGametype.html
+share/doc/ggzcore++/html/GGZCoreGametype_h.html
+share/doc/ggzcore++/html/GGZCoreModule.html
+share/doc/ggzcore++/html/GGZCoreModule_h.html
+share/doc/ggzcore++/html/GGZCorePlayer.html
+share/doc/ggzcore++/html/GGZCorePlayer_h.html
+share/doc/ggzcore++/html/GGZCoreRoom.html
+share/doc/ggzcore++/html/GGZCoreRoom_h.html
+share/doc/ggzcore++/html/GGZCoreServer.html
+share/doc/ggzcore++/html/GGZCoreServer_h.html
+share/doc/ggzcore++/html/GGZCoreTable.html
+share/doc/ggzcore++/html/GGZCoreTable_h.html
+share/doc/ggzcore++/html/GGZCore_h.html
+share/doc/ggzcore++/html/all-globals.html
+share/doc/ggzcore++/html/full-list-GGZCore.html
+share/doc/ggzcore++/html/full-list-GGZCoreConf.html
+share/doc/ggzcore++/html/full-list-GGZCoreConfio.html
+share/doc/ggzcore++/html/full-list-GGZCoreGame.html
+share/doc/ggzcore++/html/full-list-GGZCoreGametype.html
+share/doc/ggzcore++/html/full-list-GGZCoreModule.html
+share/doc/ggzcore++/html/full-list-GGZCorePlayer.html
+share/doc/ggzcore++/html/full-list-GGZCoreRoom.html
+share/doc/ggzcore++/html/full-list-GGZCoreServer.html
+share/doc/ggzcore++/html/full-list-GGZCoreTable.html
+share/doc/ggzcore++/html/header-list.html
+share/doc/ggzcore++/html/hier.html
+share/doc/ggzcore++/html/index-long.html
+share/doc/ggzcore++/html/index.html
+share/doc/ggzcore++/kdoc-generated.html
+share/icons/hicolor/16x16/apps/compcal.png
+share/icons/hicolor/16x16/apps/ggz.png
+share/icons/hicolor/16x16/apps/ggzap.png
+share/icons/hicolor/16x16/apps/keepalivecontrol.png
+share/icons/hicolor/16x16/apps/kggz.png
+share/icons/hicolor/16x16/apps/shadowbridge.png
+share/icons/hicolor/32x32/apps/compcal.png
+share/icons/hicolor/32x32/apps/ggz.png
+share/icons/hicolor/32x32/apps/ggzap.png
+share/icons/hicolor/32x32/apps/keepalivecontrol.png
+share/icons/hicolor/32x32/apps/kggz.png
+share/icons/hicolor/32x32/apps/shadowbridge.png
+share/icons/hicolor/48x48/apps/compcal.png
+share/icons/hicolor/48x48/apps/keepalivecontrol.png
+share/icons/hicolor/48x48/apps/shadowbridge.png
+share/icons/hicolor/64x64/apps/ggz.png
+share/icons/hicolor/64x64/apps/kgrubby.png
+share/locale/de/LC_MESSAGES/compcal.mo
+share/locale/de/LC_MESSAGES/ggzap.mo
+share/locale/de/LC_MESSAGES/kcmggz.mo
+share/locale/de/LC_MESSAGES/kggz.mo
+share/locale/de/LC_MESSAGES/kgrubby.mo
+share/locale/de/LC_MESSAGES/shadowbridge.mo
+share/locale/es/LC_MESSAGES/kggz.mo
+share/locale/fr/LC_MESSAGES/ggzap.mo
+share/locale/pt_BR/LC_MESSAGES/kggz.mo
+share/services/ggz.protocol
+share/services/ggzmeta.protocol
+@dirrm share/doc/ggzcore++/html
+@dirrm share/doc/ggzcore++
+@dirrm share/doc/HTML/en/kggz
+@dirrm share/doc/HTML/de/kggz
+@dirrm share/apps/kgrubby
+@dirrm share/apps/kggz/shadowbridge
+@dirrm share/apps/kggz/kcmggz/icons
+@dirrm share/apps/kggz/kcmggz
+@dirrm share/apps/kggz/images/splash
+@dirrm share/apps/kggz/images/icons/players
+@dirrm share/apps/kggz/images/icons/games
+@dirrm share/apps/kggz/images/icons
+@dirrm share/apps/kggz/images
+@dirrm share/apps/kggz/help
+@dirrm share/apps/kggz/ggzap
+@dirrm share/apps/kggz
+@dirrm share/apps/keepalivecontrol
+@dirrm share/apps/compcal