aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-01-05 17:55:43 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-01-05 17:55:43 +0000
commitc2ce797f81dd25be1a6e309d80dac882b2dcda19 (patch)
tree41ebe04c1ec44a500722367d134a40f99939a5d9 /games
parent4250ab0e85e9dfcaa4ec5d77b59d94d95582ceaf (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/adgali/Makefile5
-rw-r--r--games/adgali/pkg-plist1
-rw-r--r--games/eduke32/Makefile4
-rw-r--r--games/sdlquake2/Makefile4
-rw-r--r--games/super_methane_brothers/Makefile5
5 files changed, 5 insertions, 14 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 523177db3b1a..de32cbb14109 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -16,11 +16,8 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff \
libfreetype.so:${PORTSDIR}/print/freetype2
-.if !exists(/usr/include/execinfo.h)
-LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-.endif
-USES= gmake libtool tar:bzip2
+USES= execinfo gmake libtool tar:bzip2
USE_LDCONFIG= yes
USE_SDL= sdl
USE_XORG= xpm
diff --git a/games/adgali/pkg-plist b/games/adgali/pkg-plist
index 065423105ff9..3dc409f12144 100644
--- a/games/adgali/pkg-plist
+++ b/games/adgali/pkg-plist
@@ -56,4 +56,3 @@ share/aclocal/adgali.m4
%%PORTDOCS%%%%DOCSDIR%%/structagl__pos.html
%%PORTDOCS%%%%DOCSDIR%%/structagl__rect.html
%%PORTDOCS%%%%DOCSDIR%%/structagl__size.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index 1c9c5e04dc45..aa16db21b4ab 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -15,9 +15,7 @@ COMMENT= Duke Nukem 3D Port based on JFDuke and EDuke
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GNU.TXT
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-
-USES= gmake tar:bzip2
+USES= execinfo gmake tar:bzip2
USE_GCC= any
USE_CSTD= gnu89
USE_GL= gl
diff --git a/games/sdlquake2/Makefile b/games/sdlquake2/Makefile
index c130fb014db1..ad1576409479 100644
--- a/games/sdlquake2/Makefile
+++ b/games/sdlquake2/Makefile
@@ -10,9 +10,7 @@ MASTER_SITES= http://koti.mbnet.fi/~turol/sdlquake2/
MAINTAINER= ports@FreeBSD.org
COMMENT= Combination of R1Q2 and R1GL with SDL code from Quake2Forge
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-
-USES= gmake tar:bzip2
+USES= execinfo gmake tar:bzip2
OPTIONS_DEFINE= CLIENT DEDICATED GAME
OPTIONS_DEFAULT= CLIENT DEDICATED
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index efcc4b0cd97c..bb29be2bb8f9 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -13,10 +13,9 @@ COMMENT= Port of the Amiga platform game of the same name
LICENSE= GPLv2
-LIB_DEPENDS= libclan23Core.so:${PORTSDIR}/devel/clanlib \
- libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libclan23Core.so:${PORTSDIR}/devel/clanlib
-USES= gmake pkgconfig tar:tgz
+USES= execinfo gmake pkgconfig tar:tgz
USE_GCC= yes
USE_GL= glu
MAKE_ENV= METHANE_FLAGS="${CPPFLAGS}" METHANE_LIBS="${LIBS}"