aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-02-14 14:18:59 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-02-14 14:18:59 +0000
commite59df35a157dc5742e417c7de313043f2f0a61b0 (patch)
tree5cdd8b36fa51f8ea72f5248289340033c5b96387 /games
parent2aa05045baa1e8b5b1a6e1a04b5f654a47f7a764 (diff)
downloadports-e59df35a157dc5742e417c7de313043f2f0a61b0.tar.gz
ports-e59df35a157dc5742e417c7de313043f2f0a61b0.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/sfbol/Makefile49
-rw-r--r--games/sfbol/distinfo2
-rw-r--r--games/sfbol/files/sfbol.sh.in13
-rw-r--r--games/sfbol/pkg-descr17
5 files changed, 82 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 10363645eade..85a7273b7f26 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -540,6 +540,7 @@
SUBDIR += senken
SUBDIR += senso
SUBDIR += sex
+ SUBDIR += sfbol
SUBDIR += shaaft
SUBDIR += shootingstar
SUBDIR += six
diff --git a/games/sfbol/Makefile b/games/sfbol/Makefile
new file mode 100644
index 000000000000..5702c565a9cd
--- /dev/null
+++ b/games/sfbol/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: sfbol
+# Date created: 06FEB11
+# Whom: peter.thoenen@yahoo.com
+#
+# $FreeBSD$
+
+PORTNAME= sfbol
+PORTVERSION= 4.18
+CATEGORIES= games java
+MASTER_SITES= http://www.sfbonline.com/install4/InstData/Java/
+DISTNAME= install40
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= peter.thoenen@yahoo.com
+COMMENT= Star Fleet Battles Online
+
+IGNOREFILES= install40.jar
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+SUB_FILES= sfbol.sh
+
+PLIST_FILES= bin/${PORTNAME} \
+ %%DATADIR%%/${DISTFILES} \
+ %%DATADIR%%/sfbicon.ico
+PLIST_DIRS= %%DATADIR%%
+
+DESKTOP_ENTRIES= "SFBOL" "Star Fleet Battles Online" \
+ "${DATADIR}/sfbicon.ico" \
+ "sfbol" "Application;Game;BoardGame;StrategyGame" \
+ false
+
+RESTRICTED= Commerical software. Licenses does not allow redistribution.
+
+post-patch:
+ @cd ${WRKDIR} && ${JAR} -xf ${DISTDIR}/${DISTFILES} D_/SFBOL/dist/core.jar 2>/dev/null | ${TRUE}
+ @cd ${WRKDIR} && ${JAR} -xf D_/SFBOL/dist/core.jar sfbicon.ico
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKDIR}/sfbicon.ico ${DATADIR}
+ @${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${DATADIR}
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME:L}
+
+.include <bsd.port.mk>
diff --git a/games/sfbol/distinfo b/games/sfbol/distinfo
new file mode 100644
index 000000000000..59e64df69c7f
--- /dev/null
+++ b/games/sfbol/distinfo
@@ -0,0 +1,2 @@
+MD5 (install40.jar) = IGNORE
+SHA256 (install40.jar) = IGNORE
diff --git a/games/sfbol/files/sfbol.sh.in b/games/sfbol/files/sfbol.sh.in
new file mode 100644
index 000000000000..4e5b303ea0c8
--- /dev/null
+++ b/games/sfbol/files/sfbol.sh.in
@@ -0,0 +1,13 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+HOME_DIR="${HOME}/SFB_Online_XP"
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+if [ -d ${HOME_DIR} ]; then
+ cd ${HOME_DIR} && exec ${HOME_DIR}/SFB_Online_XP
+else
+ cd ${HOME} && exec "%%LOCALBASE%%/bin/java" -jar "%%DATADIR%%/install40.jar"
+fi
+
diff --git a/games/sfbol/pkg-descr b/games/sfbol/pkg-descr
new file mode 100644
index 000000000000..3e56991eeee2
--- /dev/null
+++ b/games/sfbol/pkg-descr
@@ -0,0 +1,17 @@
+Star Fleet Battles Online (SFBOL) is developed in cooperation with Amarillo
+Design Bureau, Inc. to be a Star Fleet Battles game service. Subscribers are
+able to play SFB games over the internet with other subscribers around the world
+. SFBOL is designed to allow subscribers to compete in an environment that
+emulates face to face play. The difference is the computer interface which
+augments or automates many of the mundane tasks of game play such as energy
+allocation, moving counters across the map, dice rolling and damage allocation.
+Subscribers may play as many games as they like during their subscription period
+. Throughout the year Symbiotic Games will host exclusive online Rated Ace
+Tournaments and subscribers can also compete year round via an online ranking
+system.
+
+SFBOL Authors: Symbiotic Games
+WWW: http://www.sfbonline.com,
+
+SFB Authors: Amarillo Design Bureau
+WWW: http://www.starfleetgames.com