aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-11-11 03:33:50 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-11-11 03:33:50 +0000
commita5828e776ac46ac72ba908ea19754f60d317f71c (patch)
tree72a8689e89e82dba43df60f9f7549e2ddd62c2f5 /games
parent6138ce02ca8982da75feeccc033c04d0c6b5370e (diff)
downloadports-a5828e776ac46ac72ba908ea19754f60d317f71c.tar.gz
ports-a5828e776ac46ac72ba908ea19754f60d317f71c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/pingus/Makefile2
-rw-r--r--games/pingus/files/patch-src_pingus_screens_demo__session.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
index 91b2f578d20c..eb49d23f8511 100644
--- a/games/pingus/Makefile
+++ b/games/pingus/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/boost/signals2.hpp:devel/boost-libs
LIB_DEPENDS= libpng.so:graphics/png
-USES= compiler:c++11-lib iconv scons tar:bzip2
+USES= compiler:c++11-lib gl iconv scons tar:bzip2
USE_GL= gl
USE_SDL= sdl image mixer
LIBS+= ${ICONV_LIB}
diff --git a/games/pingus/files/patch-src_pingus_screens_demo__session.cpp b/games/pingus/files/patch-src_pingus_screens_demo__session.cpp
new file mode 100644
index 000000000000..8146968392f2
--- /dev/null
+++ b/games/pingus/files/patch-src_pingus_screens_demo__session.cpp
@@ -0,0 +1,10 @@
+--- src/pingus/screens/demo_session.cpp.orig 2018-11-02 16:05:42 UTC
++++ src/pingus/screens/demo_session.cpp
+@@ -17,6 +17,7 @@
+ #include "pingus/screens/demo_session.hpp"
+
+ #include <algorithm>
++#include <functional>
+ #include <iostream>
+
+ #include "engine/gui/gui_manager.hpp"