aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2010-01-10 12:02:09 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2010-01-10 12:02:09 +0000
commit2503f854417e42be47f978d3c64dcc6c6e65c967 (patch)
tree5b14da24671838110b866de34ffdb8b0c589d0d2 /games
parentef2bec13c1fcb533b50af8d6d7194163ce121e5e (diff)
downloadports-2503f854417e42be47f978d3c64dcc6c6e65c967.tar.gz
ports-2503f854417e42be47f978d3c64dcc6c6e65c967.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-skulltag/Makefile40
-rw-r--r--games/linux-skulltag/distinfo6
-rw-r--r--games/linux-skulltag/files/pkg-message.in12
-rw-r--r--games/linux-skulltag/files/skulltag.sh.in4
-rw-r--r--games/linux-skulltag/pkg-descr33
-rw-r--r--games/linux-skulltag/pkg-plist24
7 files changed, 120 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index cc34402c464d..b189f5f87c6a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -478,6 +478,7 @@
SUBDIR += linux-quake4-demo
SUBDIR += linux-savage
SUBDIR += linux-savage-samuraiwars
+ SUBDIR += linux-skulltag
SUBDIR += linux-sof
SUBDIR += linux-spheresofchaos-demo
SUBDIR += linux-ssamtfe
diff --git a/games/linux-skulltag/Makefile b/games/linux-skulltag/Makefile
new file mode 100644
index 000000000000..6814a63e762a
--- /dev/null
+++ b/games/linux-skulltag/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: games/linux-skulltag
+# Date created: 2010-01-10
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= skulltag
+PORTVERSION= 0.9.8a
+CATEGORIES= games
+MASTER_SITES= http://skulltag.net/download/files/release/
+DISTFILES= st-v098a_linux-base.tar.bz2 st-v098a_linux-x86.tar.bz2
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= Doom/Doom2/Heretic engine
+
+RUN_DEPENDS= ${LINUXBASE}/lib/libfmodexp-4.24.16.so:${PORTSDIR}/audio/linux-fmodapi \
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0.11.2:${PORTSDIR}/devel/linux-sdl12
+
+ONLY_FOR_ARCHS= i386
+USE_BZIP2= yes
+NO_BUILD= yes
+
+SUB_FILES= skulltag.sh pkg-message
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/skulltag ${PREFIX}/bin/skulltag.bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/skulltag-server ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/skulltag.sh ${PREFIX}/bin/skulltag
+ ${MKDIR} ${PREFIX}/share/games/skulltag
+ ${MKDIR} ${PREFIX}/share/games/skulltag/skins
+ ${MKDIR} ${PREFIX}/share/games/skulltag/announcer
+ for f in ${WRKDIR}/announcer/*; do ${INSTALL_DATA} $${f} ${PREFIX}/share/games/skulltag/announcer; done
+ for f in ${WRKDIR}/skins/*; do ${INSTALL_DATA} $${f} ${PREFIX}/share/games/skulltag/skins; done
+ for f in liboutput_sdl.so libsnes_spc.so skulltag.pk3 skulltag_data.pk3; do ${INSTALL_DATA} ${WRKDIR}/$${f} ${PREFIX}/share/games/skulltag; done
+
+post-install:
+ ${CAT} ${WRKDIR}/pkg-message
+
+.include <bsd.port.mk>
diff --git a/games/linux-skulltag/distinfo b/games/linux-skulltag/distinfo
new file mode 100644
index 000000000000..15a66011e4bc
--- /dev/null
+++ b/games/linux-skulltag/distinfo
@@ -0,0 +1,6 @@
+MD5 (st-v098a_linux-base.tar.bz2) = 38b0e2da2ae8b8ab79c0288302933ec0
+SHA256 (st-v098a_linux-base.tar.bz2) = 98b56262ada4f3266bf3fa35825ee5b3f282d2b34a177ffb6b3ad05a599e9f84
+SIZE (st-v098a_linux-base.tar.bz2) = 19435714
+MD5 (st-v098a_linux-x86.tar.bz2) = aaabd4cea7faf6095e12a01cdb0d25fc
+SHA256 (st-v098a_linux-x86.tar.bz2) = 091fd40b86f55094951856714bd0e7383643ad86e217b68be6e28a4e31aed78d
+SIZE (st-v098a_linux-x86.tar.bz2) = 5015199
diff --git a/games/linux-skulltag/files/pkg-message.in b/games/linux-skulltag/files/pkg-message.in
new file mode 100644
index 000000000000..06df2c606dc5
--- /dev/null
+++ b/games/linux-skulltag/files/pkg-message.in
@@ -0,0 +1,12 @@
+Nearly done!
+
+To be able to work, skulltag needs an official Doom, Doom 2, Heretic
+etc WAD file. This file comes with the official distribution of
+these games. You can still buy these games via the Internet for
+cheap, so use that instead of illegal downloading.
+
+Once you have obtained it, please place it in
+%%PREFIX%%/share/games/skulltag and run the game.
+
+Note: If the sound doesn't work, go to Options -> Sound Options ->
+Select SDL for the Output System and restart the game.
diff --git a/games/linux-skulltag/files/skulltag.sh.in b/games/linux-skulltag/files/skulltag.sh.in
new file mode 100644
index 000000000000..9f475a04cc54
--- /dev/null
+++ b/games/linux-skulltag/files/skulltag.sh.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%PREFIX%%/share/games/skulltag
+skulltag.bin
diff --git a/games/linux-skulltag/pkg-descr b/games/linux-skulltag/pkg-descr
new file mode 100644
index 000000000000..cba92acdbb3b
--- /dev/null
+++ b/games/linux-skulltag/pkg-descr
@@ -0,0 +1,33 @@
+Skulltag is a port for the original Doom and Doom II by id Software.
+
+Skulltag brings classic Doom into the 21st century, maintaining the
+essence of what has made Doom great for so many years and, at the
+same time, adding new features to modernize it, creating a fresh,
+fun new experience.
+
+Here's why you should kill your time with Skulltag, versus vanilla
+Doom:
+
+ * Excellent online play
+ o Client/server architecture: play and switch between games with ease
+ o Supports up to 32 players
+ o Wide array of gameplay modes
+ + Competitive: Team DM, Duel, CTF, Possession, LMS,
+ Terminator, Skulltag
+ + Cooperative: Survival, Invasion (or both!)
+ + Modifiers, like Instagib and Buckshot, can be used
+ to spice up any game.
+ * Modern and beautiful
+ o Choose between GZDoom's OpenGL renderer, or Doom Software
+ o Useful features like a console, Quake-style key bindings,
+ freelooking, and jumping
+ o Full, enthusiastic support for ZDoom and GZDoom mods
+ o Support for Heretic, Hexen, and Strife, as well as Linux/FreeBSD
+ * Innovative new content
+ o Announcers and skins for online play
+ o Runes, new weapons, and new monsters for modders
+ o 50 new, well designed stock maps for any game mode
+ o Bots, and support for custom bots
+ * So much more!
+
+WWW: http://skulltag.net/
diff --git a/games/linux-skulltag/pkg-plist b/games/linux-skulltag/pkg-plist
new file mode 100644
index 000000000000..8a6ebf2e72e8
--- /dev/null
+++ b/games/linux-skulltag/pkg-plist
@@ -0,0 +1,24 @@
+bin/skulltag
+bin/skulltag.bin
+bin/skulltag-server
+share/games/skulltag/skulltag.pk3
+share/games/skulltag/libsnes_spc.so
+share/games/skulltag/liboutput_sdl.so
+share/games/skulltag/skulltag_data.pk3
+share/games/skulltag/announcer/Skulltag_98a_announcer.pk3
+share/games/skulltag/skins/ST_BASEII.pk3
+share/games/skulltag/skins/ST_Chaingun_Marine.pk3
+share/games/skulltag/skins/ST_Chubbs.pk3
+share/games/skulltag/skins/ST_Crash.pk3
+share/games/skulltag/skins/ST_Doom64Guy.pk3
+share/games/skulltag/skins/ST_Illucia.pk3
+share/games/skulltag/skins/ST_Orion.pk3
+share/games/skulltag/skins/ST_Phobos.pk3
+share/games/skulltag/skins/ST_Procyon.pk3
+share/games/skulltag/skins/ST_Seenas.pk3
+share/games/skulltag/skins/ST_Strife_Guy.pk3
+share/games/skulltag/skins/ST_Synas.pk3
+
+@dirrm share/games/skulltag/announcer
+@dirrm share/games/skulltag/skins
+@dirrm share/games/skulltag