aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-05-29 14:35:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-05-29 14:35:01 +0000
commit5bf81ff7896ad4fc0c92d3896360b8aec238adc9 (patch)
tree9820a52f001eb8bb4cc52930dd66d3a150497cf4 /games
parent488b4b165f0440aadc432e6a2d68fe7b690bf982 (diff)
downloadports-5bf81ff7896ad4fc0c92d3896360b8aec238adc9.tar.gz
ports-5bf81ff7896ad4fc0c92d3896360b8aec238adc9.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/adonthell/Makefile3
-rw-r--r--games/balazarbrothers/Makefile4
-rw-r--r--games/blockout/Makefile2
-rw-r--r--games/ceferino/Makefile2
-rw-r--r--games/chanta/Makefile2
-rw-r--r--games/frogatto/Makefile2
-rw-r--r--games/gbottler/Makefile2
-rw-r--r--games/heretic/Makefile2
-rw-r--r--games/lbreakout2/Makefile2
-rw-r--r--games/lgeneral/Makefile2
-rw-r--r--games/nazghul/Makefile2
-rw-r--r--games/nethack32/Makefile2
-rw-r--r--games/nethack33/Makefile2
-rw-r--r--games/nethack34/Makefile2
-rw-r--r--games/ninix-aya/Makefile2
-rw-r--r--games/pioneers/Makefile3
-rw-r--r--games/pongix/Makefile2
-rw-r--r--games/pvpgn/Makefile3
-rw-r--r--games/q2p/Makefile3
-rw-r--r--games/quadra/Makefile3
-rw-r--r--games/quake2-lights/Makefile3
-rw-r--r--games/quake2-matrix/Makefile3
-rw-r--r--games/quake2-psychomod/Makefile3
-rw-r--r--games/quakeforge/Makefile4
-rw-r--r--games/qudos/Makefile3
-rw-r--r--games/residualvm/Makefile2
-rw-r--r--games/rubix/Makefile3
-rw-r--r--games/scourge/Makefile2
-rw-r--r--games/slashem-tty/Makefile2
-rw-r--r--games/tileworld/Makefile2
-rw-r--r--games/tyrquake/Makefile2
-rw-r--r--games/unnethack/Makefile2
-rw-r--r--games/vultures-eye/Makefile4
-rw-r--r--games/wmquake/Makefile3
-rw-r--r--games/xlogical/Makefile3
-rw-r--r--games/zangband/Makefile3
36 files changed, 37 insertions, 54 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index a0480cf770f9..b47f0701bd67 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -21,8 +21,7 @@ LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
USE_SDL= mixer ttf sdl
USE_PYTHON= yes
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
GNU_CONFIGURE= yes
CONFIGURE_ENV= PYPACKAGE="${PYTHON_CMD}" ac_cv_path_P_SWIG=no
CONFIGURE_ARGS= --disable-py-debug
diff --git a/games/balazarbrothers/Makefile b/games/balazarbrothers/Makefile
index e152b09be008..4c7d1fa38273 100644
--- a/games/balazarbrothers/Makefile
+++ b/games/balazarbrothers/Makefile
@@ -18,12 +18,10 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cerealizer/__init__.py:${PORTSDIR}/security/py
${PYTHON_SITELIBDIR}/tofu/__init__.py:${PORTSDIR}/net/py-tofu \
${PYTHON_SITELIBDIR}/ogg/__init__.py:${PORTSDIR}/audio/py-vorbis
-USE_BZIP2= yes
-USES= gettext twisted
+USES= gettext twisted tar:bzip2 gmake
USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_GL= glew
-USE_GMAKE= yes
PYDISTUTILS_PKGNAME= BalazarBrothers
PYDISTUTILS_EGGINFODIR= ${PREFIX}/share
diff --git a/games/blockout/Makefile b/games/blockout/Makefile
index 993f4c7e2ce8..8866eb0e530f 100644
--- a/games/blockout/Makefile
+++ b/games/blockout/Makefile
@@ -15,7 +15,7 @@ COMMENT= BlockOut II is an adaptation of the original Blockout DOS game
ONLY_FOR_ARCHS= i386
USE_SDL= mixer sdl
-USE_GMAKE= yes
+USES= gmake
USE_GL= gl glu
WRKSRC= ${WRKDIR}/bl24_lin_src
diff --git a/games/ceferino/Makefile b/games/ceferino/Makefile
index 856325f0db93..84098b512709 100644
--- a/games/ceferino/Makefile
+++ b/games/ceferino/Makefile
@@ -12,7 +12,7 @@ COMMENT= Game similar to Super Pang
USE_SDL= sdl mixer image
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD}
diff --git a/games/chanta/Makefile b/games/chanta/Makefile
index 81dbe6cb4905..ad5823757a39 100644
--- a/games/chanta/Makefile
+++ b/games/chanta/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= http://www.losersjuegos.com.ar/_media/juegos/chanta/descargas/
MAINTAINER= acm@FreeBSD.org
COMMENT= Free 2D jump and run game
+USES= gmake
USE_SDL= sdl image mixer
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD}
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index a93060a10239..c8669dcd4dbb 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -21,7 +21,7 @@ GH_PROGECT= frogatto
GH_TAGNAME= ${PORTVERSION}
GH_COMMIT= 64c84bf
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= game server
USE_GL= glew
USE_SDL= image mixer ttf
diff --git a/games/gbottler/Makefile b/games/gbottler/Makefile
index 93e03bdca20a..7308ae56e44a 100644
--- a/games/gbottler/Makefile
+++ b/games/gbottler/Makefile
@@ -17,7 +17,7 @@ PLIST_SUB= VERSION=${PORTVERSION}
USE_GNOME= pygtk2
USE_PYTHON= yes
-USE_GMAKE= yes
+USES= gmake
NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/heretic/Makefile b/games/heretic/Makefile
index 5dab6f6e4b5c..f311f0bd9187 100644
--- a/games/heretic/Makefile
+++ b/games/heretic/Makefile
@@ -12,8 +12,8 @@ DISTNAME= gl${PORTNAME}-${PORTVERSION}
MAINTAINER= oliver@FreeBSD.org
COMMENT= Unix source-port of the famous Heretic game by id Software
+USES= gmake
USE_XORG= x11 xi xpm xau
-USE_GMAKE= yes
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
OPTIONS_DEFINE= WAD
diff --git a/games/lbreakout2/Makefile b/games/lbreakout2/Makefile
index ead4bbf52ad9..d1401e0b675e 100644
--- a/games/lbreakout2/Makefile
+++ b/games/lbreakout2/Makefile
@@ -13,7 +13,7 @@ COMMENT= The polished successor to LBreakout
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_SDL= mixer net sdl
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sdl-net \
--localstatedir=/var/games \
diff --git a/games/lgeneral/Makefile b/games/lgeneral/Makefile
index b2bef966cff6..4c2f4d370846 100644
--- a/games/lgeneral/Makefile
+++ b/games/lgeneral/Makefile
@@ -21,7 +21,7 @@ OPTIONS_DEFAULT= SOUND
SOUND_DESC= Enable sound support
USE_SDL= sdl
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_CSTD= gnu89
diff --git a/games/nazghul/Makefile b/games/nazghul/Makefile
index 22e01686648b..4b9e1e883a0b 100644
--- a/games/nazghul/Makefile
+++ b/games/nazghul/Makefile
@@ -13,8 +13,8 @@ COMMENT= A computer role-playing game engine
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_SDL= sdl image mixer
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+USES= gmake
NO_STAGE= yes
post-patch:
diff --git a/games/nethack32/Makefile b/games/nethack32/Makefile
index 62a1782ff657..c84777f4a784 100644
--- a/games/nethack32/Makefile
+++ b/games/nethack32/Makefile
@@ -17,7 +17,7 @@ COMMENT= A dungeon explorin', slashin', hackin' game
WRKSRC= ${WRKDIR}/${TRUEPORTNAME}-3.2.2
-USE_GMAKE= yes
+USES= gmake
USE_XORG= xaw xpm
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKEXT="${HACKEXT}"
diff --git a/games/nethack33/Makefile b/games/nethack33/Makefile
index 737bca3c63df..66e75ed047a3 100644
--- a/games/nethack33/Makefile
+++ b/games/nethack33/Makefile
@@ -15,7 +15,7 @@ COMMENT= A dungeon explorin', slashin', hackin' game
WRKSRC= ${WRKDIR}/${TRUEPORTNAME}-${PORTVERSION}
LATEST_LINK= ${TRUEPORTNAME}33${PKGNAMESUFFIX}
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKEXT="${HACKEXT}"
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 5bba64420402..9077bc8a387f 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -19,7 +19,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GMAKE= yes
+USES= gmake
NO_STAGE= yes
MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
diff --git a/games/ninix-aya/Makefile b/games/ninix-aya/Makefile
index 76e11eb5d888..7c3cd207c75c 100644
--- a/games/ninix-aya/Makefile
+++ b/games/ninix-aya/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
USE_PYTHON= yes
USE_GNOME= pygtk2
-USE_GMAKE= yes
+USES= gmake
OPTIONS_DEFINE= DOCS NLS
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index 0a38de32b7dd..dc95a57ca125 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2
RUN_DEPENDS= yelp:${PORTSDIR}/x11/yelp
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake
USE_GNOME= gnomehack gnomeprefix gtk20 libgnome librsvg2
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
diff --git a/games/pongix/Makefile b/games/pongix/Makefile
index d50dc5ee6527..092095f0c97d 100644
--- a/games/pongix/Makefile
+++ b/games/pongix/Makefile
@@ -12,8 +12,8 @@ COMMENT= Free pong-like game
LICENSE= GPLv2
+USES= gmake
USE_SDL= sdl image net
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD}
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index deed3b9a9ec6..db5fcb5103ce 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -15,8 +15,7 @@ COMMENT= Free Blizzard Battle.net emulation software
PKGINSTALL?= ${WRKDIR}/pkg-install
PKGDEINSTALL?= ${WRKDIR}/pkg-deinstall
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
SED_SCRIPT= -e 's|%%PREFIX%%|${PREFIX}|g'
USERS= bnetd
diff --git a/games/q2p/Makefile b/games/q2p/Makefile
index 5e55fed72c7b..ca826c161f2c 100644
--- a/games/q2p/Makefile
+++ b/games/q2p/Makefile
@@ -11,9 +11,8 @@ DISTNAME= Q2P-0.2-2006-12-31
MAINTAINER= danfe@FreeBSD.org
COMMENT= Enhanced OpenGL-only Quake II engine
-USE_BZIP2= yes
+USES= gmake tar:bzip2
USE_XORG= xxf86dga xext xxf86vm x11
-USE_GMAKE= yes
ALL_TARGET= release
MAKE_ENV= DATADIR="${Q2DIR}" LIBDIR="${LIBDIR}"
diff --git a/games/quadra/Makefile b/games/quadra/Makefile
index 9302406f0169..c4065e318692 100644
--- a/games/quadra/Makefile
+++ b/games/quadra/Makefile
@@ -14,12 +14,11 @@ COMMENT= Tetris like game with multiplayer support
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-USE_BZIP2= yes
+USES= gmake tar:bzip2
USE_SDL= sdl
USE_XORG= x11 xau xdmcp
USE_AUTOTOOLS= autoconf autoheader
GNU_CONFIGURE= yes
-USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/quake2-lights/Makefile b/games/quake2-lights/Makefile
index ba9b2f44b28f..b44fd8177367 100644
--- a/games/quake2-lights/Makefile
+++ b/games/quake2-lights/Makefile
@@ -15,8 +15,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:data,src \
MAINTAINER= danfe@FreeBSD.org
COMMENT= Lights modification for Quake II
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
NO_WRKSUBDIR= yes
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}/src
ALL_TARGET= release
diff --git a/games/quake2-matrix/Makefile b/games/quake2-matrix/Makefile
index ad0e3d17dc9a..1a542f788abf 100644
--- a/games/quake2-matrix/Makefile
+++ b/games/quake2-matrix/Makefile
@@ -11,8 +11,7 @@ DISTNAME= Matrix-v${PORTVERSION}.fixed.Linux
MAINTAINER= danfe@FreeBSD.org
COMMENT= Matrix modification for Quake II
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}
BUILD_WRKSRC= ${WRKSRC}/MatrixFixSource
ALL_TARGET= release
diff --git a/games/quake2-psychomod/Makefile b/games/quake2-psychomod/Makefile
index 555b692087ae..a80ecfe1d5ea 100644
--- a/games/quake2-psychomod/Makefile
+++ b/games/quake2-psychomod/Makefile
@@ -11,8 +11,7 @@ PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Psychomod modification for Quake II
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}
BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= release
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 4cf57205cb48..8c84f99c9079 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -16,9 +16,7 @@ COMMENT= Cleaned up copy of the GPLd Quake 1 source code
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= generated Quake C compiler (qfcc) does not work
USE_AUTOTOOLS= libtool
-USE_BZIP2= yes
-USES= bison
-USE_GMAKE= yes
+USES= bison gmake tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
WANT_SDL= yes
diff --git a/games/qudos/Makefile b/games/qudos/Makefile
index fad594fda879..7e6e2e94433b 100644
--- a/games/qudos/Makefile
+++ b/games/qudos/Makefile
@@ -14,8 +14,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Enhanced OpenGL-only Quake II engine
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
MAKE_ENV= WITH_DATADIR=YES WITH_LIBDIR=YES WITH_XMMS=NO \
DATADIR="${Q2DIR}" LIBDIR="${LIBDIR}"
diff --git a/games/residualvm/Makefile b/games/residualvm/Makefile
index 5aa20e5ac2ae..66293725a320 100644
--- a/games/residualvm/Makefile
+++ b/games/residualvm/Makefile
@@ -18,7 +18,7 @@ GH_COMMIT= 340bbe3
USE_SDL= sdl
HAS_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
MAN6= residualvm.6
NO_MANCOMPRESS= yes
diff --git a/games/rubix/Makefile b/games/rubix/Makefile
index 911e36078c5a..917a19d5e88e 100644
--- a/games/rubix/Makefile
+++ b/games/rubix/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://sed.free.fr/rubix/ \
MAINTAINER= dhn@FreeBSD.org
COMMENT= Another Rubik's cube game with a rather interesting interface
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_XORG= x11
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DENGLISH" \
XINC="-I${LOCALBASE}/include" XLIB="-L${LOCALBASE}/lib -lX11"
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index 7c94b58a09ea..1facfd8500db 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${DATADIR}/config/scourge.cfg:${PORTSDIR}/games/scourge-data
USE_AUTOTOOLS= autoconf:env automake:env
USE_GL= gl
USE_SDL= sdl image mixer net ttf
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_LIBS}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/slashem-tty/Makefile b/games/slashem-tty/Makefile
index f786b673cf51..02615fb47322 100644
--- a/games/slashem-tty/Makefile
+++ b/games/slashem-tty/Makefile
@@ -11,7 +11,7 @@ DISTNAME= se${PORTVERSION:S/.//g:tl}
MAINTAINER= glewis@FreeBSD.org
COMMENT= A dungeon explorin', slashin', hackin' game
-USE_GMAKE= yes
+USES= gmake
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES+= pkg-deinstall
MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
diff --git a/games/tileworld/Makefile b/games/tileworld/Makefile
index 8a4bcec11641..34e10860f861 100644
--- a/games/tileworld/Makefile
+++ b/games/tileworld/Makefile
@@ -13,7 +13,7 @@ COMMENT= An emulation of the game "Chip's Challenge"
USE_SDL= sdl
GNU_CONFIGURE= YES
-USE_GMAKE= YES
+USES= gmake
ALL_TARGET= tworld
DATADIR= share/tworld
diff --git a/games/tyrquake/Makefile b/games/tyrquake/Makefile
index da810c71b0e3..4f518a2ec560 100644
--- a/games/tyrquake/Makefile
+++ b/games/tyrquake/Makefile
@@ -14,7 +14,7 @@ BROKEN= Fails to build
USE_XORG= x11 xxf86vm xdamage xfixes xau xext xdmcp
USE_GL= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= QBASEDIR="${Q1DIR}" X11BASE=${LOCALBASE}
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index 7f39541419b4..d68f6c0fd1cc 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= knu@FreeBSD.org
COMMENT= A new variant of NetHack
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_JOBS_UNSAFE= yes
VARDIR_REL= var/games/${PORTNAME}
diff --git a/games/vultures-eye/Makefile b/games/vultures-eye/Makefile
index 98e1583dd9e8..f08427c61b45 100644
--- a/games/vultures-eye/Makefile
+++ b/games/vultures-eye/Makefile
@@ -16,9 +16,9 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-USE_GMAKE= yes
+
USE_SDL= sdl mixer ttf
-USE_BZIP2= yes
+USES= gmake tar:bzip2
WRKSRC= ${WRKDIR}/${DISTNAME}/nethack
HAS_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/sys/unix
diff --git a/games/wmquake/Makefile b/games/wmquake/Makefile
index 3c5f5b0c6929..9156216d3ae4 100644
--- a/games/wmquake/Makefile
+++ b/games/wmquake/Makefile
@@ -12,8 +12,7 @@ MASTER_SITE_SUBDIR= uqs
MAINTAINER= uqs@FreeBSD.org
COMMENT= Id Software\'s Quake I in a 64x64 WM dockapp window
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_GNOME= gtk12
PLIST_FILES= bin/wmquake
diff --git a/games/xlogical/Makefile b/games/xlogical/Makefile
index fbe6b5b5c9e8..c4b70738a9fd 100644
--- a/games/xlogical/Makefile
+++ b/games/xlogical/Makefile
@@ -12,8 +12,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/-/}
MAINTAINER= aaron@baugher.biz
COMMENT= Remake of the classic puzzle game Logical
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index 6c7a6c623581..a9b3122ef676 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -11,8 +11,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Zangband (Zelazny Angband) with color, X11 support
-USES= perl5
-USE_GMAKE= yes
+USES= perl5 gmake
USE_AUTOTOOLS= automake14 autoconf
USE_PERL5= build
CONFIGURE_ARGS= --datadir=${PREFIX}/lib --mandir=${PREFIX}/man \