aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-06-22 13:54:38 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-06-22 13:54:38 +0000
commit76232f571a2ec24a49ef75db593f709549cf3eac (patch)
tree9359b549d55e3dbadaf5c6e32d009a370eaff06f /games
parent0c9909022d2f48c5c0ae1286fa2b7e40588fdc7d (diff)
downloadports-76232f571a2ec24a49ef75db593f709549cf3eac.tar.gz
ports-76232f571a2ec24a49ef75db593f709549cf3eac.zip
Modernize a bit this port.
Remark: there remain many problem with pinball, more fixes to come.
Notes
Notes: svn path=/head/; revision=504866
Diffstat (limited to 'games')
-rw-r--r--games/pinball/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 5b88a052b70f..1a339e83f226 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pinball
PORTVERSION= 0.3.1
-PORTREVISION= 21
+PORTREVISION= 22
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -13,11 +13,13 @@ COMMENT= Emilia Pinball is a free pinball game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake localbase:ldflags libtool:keepla # .la needed for plugin loading
+USES= gl gmake localbase:ldflags libtool:keepla # .la needed for plugin loading
+USE_XORG= ice sm
USE_GL= gl glu
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-debug
-USE_LDCONFIG= yes
CPPFLAGS+= -DRZR_LIBSTATIC
@@ -29,21 +31,21 @@ LIB_DEPENDS+= liballeg.so:devel/allegro
CONFIGURE_ARGS+= --with-allegro
USE_GL+= glu
.else
+USES+= sdl
USE_SDL= image mixer sdl
.endif
-#MAKE_JOBS_UNSAFE= yes
# For gmake>=3.82
pre-configure:
- @${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
+ ${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
${REINPLACE_CMD} -e 's,^dnl,# dnl,'
post-install:
- @${MV} ${STAGEDIR}/var/games/pinball/professor/highscores \
+ ${MV} ${STAGEDIR}/var/games/pinball/professor/highscores \
${STAGEDIR}/var/games/pinball/professor/highscores.sample
- @${MV} ${STAGEDIR}/var/games/pinball/tux/highscores \
+ ${MV} ${STAGEDIR}/var/games/pinball/tux/highscores \
${STAGEDIR}/var/games/pinball/tux/highscores.sample
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pinball/lib*.so*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pinball/lib*.so*
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}