aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-06-30 09:17:48 +0000
committerRene Ladan <rene@FreeBSD.org>2019-06-30 09:17:48 +0000
commit812baad3969878dcbcd75a89908e5fd1bff1e830 (patch)
treea0b605f760822d7c357a47a6262aff724f0bc4ed /games
parent50921a9a69c65b5bc2ba21b9dc4184395191cdc1 (diff)
downloadports-812baad3969878dcbcd75a89908e5fd1bff1e830.tar.gz
ports-812baad3969878dcbcd75a89908e5fd1bff1e830.zip
games/egoboo: include dirent.h instead of sys/dir.h which is going away.
While here modernize USES PR: 238614 Submitted by: rene Approved by: maintainer timeout (amdmi3, two weeks)
Notes
Notes: svn path=/head/; revision=505412
Diffstat (limited to 'games')
-rw-r--r--games/egoboo/Makefile4
-rw-r--r--games/egoboo/files/patch-game-lin-file.c10
2 files changed, 8 insertions, 6 deletions
diff --git a/games/egoboo/Makefile b/games/egoboo/Makefile
index 875eea17c3dd..791b13f4c933 100644
--- a/games/egoboo/Makefile
+++ b/games/egoboo/Makefile
@@ -13,9 +13,9 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 3D dungeon crawling adventure in the spirit of NetHack
-USES= gmake dos2unix
+USES= dos2unix gl gmake sdl
USE_SDL= sdl ttf mixer image
-USE_GL= yes
+USE_GL= glu
DOS2UNIX_GLOB= *.c
WRKSRC= ${WRKDIR}/${DISTNAME}/game
diff --git a/games/egoboo/files/patch-game-lin-file.c b/games/egoboo/files/patch-game-lin-file.c
index 43e86d6bdfc8..349573027a8f 100644
--- a/games/egoboo/files/patch-game-lin-file.c
+++ b/games/egoboo/files/patch-game-lin-file.c
@@ -1,9 +1,11 @@
---- lin-file.c.orig 2007-11-16 22:36:58.000000000 +0300
-+++ lin-file.c 2008-02-07 04:09:32.000000000 +0300
-@@ -9,6 +9,7 @@
+--- lin-file.c.orig 2019-06-15 14:41:01 UTC
++++ lin-file.c
+@@ -8,7 +8,8 @@
+ #include <glob.h>
#include <sys/types.h>
#include <sys/stat.h>
- #include <sys/dir.h>
+-#include <sys/dir.h>
++#include <dirent.h>
+#include <sys/syslimits.h>
//File Routines-----------------------------------------------------------